BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      07-16-2018, 08:57 PM   #1
OneSickM
Captain
OneSickM's Avatar
80
Rep
666
Posts

Drives: M3
Join Date: Jul 2014
Location: ---

iTrader: (1)

Question EVAP System incomplete

I currently have O2 sensor and EVAP sys incomplete for emissions testing. Does anybody know if tuners disable these to not generate CEL?

I heard some tuners don't set readiness for O2 and CAT but I never heard for EVAP. Can someone chime in and tell me how to set it to be ready to do emission test?
Appreciate 0
      07-18-2018, 09:56 AM   #2
deansbimmer
BimmerPost Supporting Vendor
deansbimmer's Avatar
United_States
1688
Rep
2,153
Posts


Drives: 2011 E93 M3
Join Date: Nov 2014
Location: DFW, Texas

iTrader: (14)

Garage List
2011 X5M  [0.00]
2011 BMW M3  [0.00]
I am not aware of any tuner that disables the evap monitor. They will tune out the o2 sensor for catless cars. Evap usually takes two "complete" drive cycles to go into ready unless there is a problem within the system. Most cars I can get all monitors into ready in about 30 minutes or less. Some cars take longer.
Appreciate 0
      07-18-2018, 10:23 AM   #3
OneSickM
Captain
OneSickM's Avatar
80
Rep
666
Posts

Drives: M3
Join Date: Jul 2014
Location: ---

iTrader: (1)

Quote:
Originally Posted by deansbimmer View Post
I am not aware of any tuner that disables the evap monitor. They will tune out the o2 sensor for catless cars. Evap usually takes two "complete" drive cycles to go into ready unless there is a problem within the system. Most cars I can get all monitors into ready in about 30 minutes or less. Some cars take longer.
Yes it took sometime (3 to 4 proper drive cycle) to complete. Thank you!

What about O2 sensors? How long do they usually need to clear? I have drove the car so far over 100 miles and it still in incomplete state.
Appreciate 0
      07-18-2018, 10:40 AM   #4
deansbimmer
BimmerPost Supporting Vendor
deansbimmer's Avatar
United_States
1688
Rep
2,153
Posts


Drives: 2011 E93 M3
Join Date: Nov 2014
Location: DFW, Texas

iTrader: (14)

Garage List
2011 X5M  [0.00]
2011 BMW M3  [0.00]
Post cat o2 sensors (catalyst efficiency) require the cats to be present in working condition. If you are catless with a tune they will not go into ready. If everything is factory and in good order then it should have gone ready by 100 miles. Check for codes and make sure you're doing a correct drive cycle (no wot).
Appreciate 0
      07-18-2018, 02:09 PM   #5
nycplumber
Lieutenant
135
Rep
473
Posts

Drives: slow
Join Date: Apr 2016
Location: nyc

iTrader: (0)

Does anyone know the next move after reverting back to stock tune when the car wont go into 'ready' state? The car is fully stock at this point minus a cat back. I nor the mechanic knows why the car wont pass inspection but isnt throwing any CEL or codes.
Appreciate 0
      07-18-2018, 02:14 PM   #6
JsL
Major
United_States
338
Rep
1,060
Posts

Drives: 2011 AW M3 ZCP VF620
Join Date: Dec 2013
Location: SF Bay Area

iTrader: (2)

Quote:
Originally Posted by nycplumber View Post
Does anyone know the next move after reverting back to stock tune when the car wont go into 'ready' state? The car is fully stock at this point minus a cat back. I nor the mechanic knows why the car wont pass inspection but isnt throwing any CEL or codes.
Drive 55mph for 5 mins. Do it at night on the right lane on the freeway. Impossible to do during the daytime with traffic.
Appreciate 0
      07-18-2018, 03:20 PM   #7
nycplumber
Lieutenant
135
Rep
473
Posts

Drives: slow
Join Date: Apr 2016
Location: nyc

iTrader: (0)

I have driven 300 miles of the BMW ftp drive cycle. I have driven over 500 miles below 3000 rpm and under 60 mph with no CEL, codes or readiness. Nothing seems to work.
Appreciate 0
      07-18-2018, 04:27 PM   #8
JsL
Major
United_States
338
Rep
1,060
Posts

Drives: 2011 AW M3 ZCP VF620
Join Date: Dec 2013
Location: SF Bay Area

iTrader: (2)

Quote:
Originally Posted by nycplumber View Post
I have driven 300 miles of the BMW ftp drive cycle. I have driven over 500 miles below 3000 rpm and under 60 mph with no CEL, codes or readiness. Nothing seems to work.
Just try it. Don't do the drive cycle, just start the car, let it warm up driving slow on city streets and then 55mph for 5 mins.
Appreciate 0
      07-18-2018, 06:06 PM   #9
nycplumber
Lieutenant
135
Rep
473
Posts

Drives: slow
Join Date: Apr 2016
Location: nyc

iTrader: (0)

Quote:
Originally Posted by JsL View Post
Just try it. Don't do the drive cycle, just start the car, let it warm up driving slow on city streets and then 55mph for 5 mins.
I have driven literally hundreds of miles at 55 mph.
Appreciate 0
      07-18-2018, 06:55 PM   #10
JsL
Major
United_States
338
Rep
1,060
Posts

Drives: 2011 AW M3 ZCP VF620
Join Date: Dec 2013
Location: SF Bay Area

iTrader: (2)

Have you checked pending codes? You may need something nicer than a regular obd2 reader for that. For example, i have a ebay code reader and a P3 guage. The P3 guage will show pending codes while my ebay code reader says no pending codes. The CEL is not illuminated if there's pending codes, so you don't know until you check with a reliable code reader. Just a thought.
Appreciate 0
      07-18-2018, 08:25 PM   #11
Dave07997S
Brigadier General
397
Rep
3,584
Posts

Drives: 2013 BMW M3 ZCP Coupe
Join Date: May 2009
Location: El Segundo, CA

iTrader: (1)

Quote:
Originally Posted by OneSickM View Post
I currently have O2 sensor and EVAP sys incomplete for emissions testing. Does anybody know if tuners disable these to not generate CEL?

I heard some tuners don't set readiness for O2 and CAT but I never heard for EVAP. Can someone chime in and tell me how to set it to be ready to do emission test?
The good news is that most states allow the EVAP sys to be incomplete for testing. In Kalifornia it is the only readiness code that you can have not ready and still pass. Some states only 1 non ready but don't state which.

Dave
__________________
2013 M3 Coupe-MR/BLK ZCP, ACM test pipes, BPM Stg2 dev. tune and Megan catback, AFE Stg2. with C/F elbow VMRV810 19x10&19X11 275/295 Mich PSS.
Previous rides: 2011 M3 Coupe-MR/Blk
2007 Porsche 997C2S Speed Yellow/Blk sport seats
2004 BMW M3 Imola/Blk
Appreciate 0
      07-19-2018, 11:17 AM   #12
OneSickM
Captain
OneSickM's Avatar
80
Rep
666
Posts

Drives: M3
Join Date: Jul 2014
Location: ---

iTrader: (1)

To update anyone who might run to same issue later, the tuner of my car which I don't know whom since I purchased car tuned, disabled the O2 sensor readiness since car was catless at one point. That's why O2 sensor is never going to be ready.

For EVAP, you need to make 2 to 3 "proper" drive cycle to set this to ready.
Appreciate 0
      07-21-2018, 04:30 PM   #13
WayneM3
Second Lieutenant
36
Rep
221
Posts

Drives: E90M3
Join Date: Apr 2011
Location: New York, NY

iTrader: (0)

On my car the EVAP never goes ready no matter what. I have the Evolve Supercharger and a special version of their software for when I have to get the car inspected that allows all monitors to go ready and it still never does. I am able to pass inspection as that is my one monitor not ready.

When I had to pass last month I was able to get all monitors (other than EVAP) to go ready in under 15 minutes with a short drive in Queens and on the LIE and it would have been faster if I was not stuck in traffic on the LIE in the beginning.

Last edited by WayneM3; 07-21-2018 at 04:47 PM. Reason: Forgot something
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:41 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST