BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Cosmetic/Visual (Exterior + Interior) Modifications
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      08-23-2016, 10:39 PM   #1
M3amigos
HP addict
M3amigos's Avatar
United_States
24
Rep
319
Posts

Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

iTrader: (0)

E93 Headliner Repair

The middle section of the headliner in my E93 came loose from all of the mounting clips and is hanging down about 6" in all sides by the cords. It appears that all the adhesive that secures the clips to the fabric liner has come loose from the Florida heat. The replacement part from the dealer is $750, so I'll be attempting a DIY repair. Has anyone seen this issue before? Any tips on how to glue the clips back on? I'm thinking epoxy might do the trick, but I'm not sure if it will stick to the fabric. I'll try to get some pictures of it this weekend.
__________________
2008 Jerez Black Metallic E93 6MT
K&N Drop In Filter | HPA Pulley | Custom Catless Resonated X-Pipe | BPM Stage II Tune | Megan Racing Exhaust
Appreciate 0
      08-28-2016, 10:44 PM   #2
M3amigos
HP addict
M3amigos's Avatar
United_States
24
Rep
319
Posts

Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

iTrader: (0)





Appreciate 0
      08-28-2016, 11:18 PM   #3
M3amigos
HP addict
M3amigos's Avatar
United_States
24
Rep
319
Posts

Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

iTrader: (0)

I took the headliner section out... its a little tricky to remove all of the cords but I did find some decent instructions at workshop-manuals dot com. Took me about 2 hours taking my time not to damage anything.

Two of the cords, one on each side, (see pic above) were really worn so I ordered some replacements from ECS for about $17. According to some other posts, these have been upgraded with stronger steel rope so it shouldn't wear out again so easily. See part number 54377277475.

I was able to epoxy all of the clips back on successfully, 15 total. I was careful to try to align them properly, hopefully the reinstall goes smoothly. I'll report back again after its done.
Appreciate 0
      04-18-2018, 10:25 PM   #4
safarisunit
Registered
0
Rep
1
Posts

Drives: 08 M3 Convertible
Join Date: Apr 2018
Location: Winter Park, FL

iTrader: (0)

I have the same issue. What kind of expoxy did you use for clips?
Appreciate 0
      04-19-2018, 07:22 AM   #5
M3amigos
HP addict
M3amigos's Avatar
United_States
24
Rep
319
Posts

Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

iTrader: (0)

Just standard epoxy from home depot/auto zone with the two tubes that you mix. Itís still holding up well.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:31 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST