BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Lease SwApp
Post Reply
 
Thread Tools Search this Thread
      09-17-2018, 05:36 PM   #111
pucsicsal
SEO1
3
Rep
21
Posts

Drives: 2011 E92 M3 6MT
Join Date: Jun 2011
Location: So Cal - Irvine

iTrader: (0)

Hi guys, any update on this OP?

I've also noticed this on my 2011 E92 M3, 25k miles.. It used to be *always* just below 210 unless I really pushed it, now it's always just above. Haven't had the chance to really push the car hard. Will report back.

I think something isn't right for OP.. that's too high, I think it's either an error with the measurement/sensor error, an error with the gauge, or something is causing the engine to run hotter than it should (assuming OP isn't driving like a hoonigan). I really want to know the outcome of this.
Appreciate 0
      09-17-2018, 05:41 PM   #112
pucsicsal
SEO1
3
Rep
21
Posts

Drives: 2011 E92 M3 6MT
Join Date: Jun 2011
Location: So Cal - Irvine

iTrader: (0)

G'day NashvegasR, any update on this? I'm hoping all is well with your car! NashvegasR Maybe get an oil analysis, and while they're at it have them check around/under the car and the oil cooler to make sure no damage? Those are the two things I'd do. Best of luck, Chris

Quote:
Originally Posted by NashvegasR View Post
Update. Goddamnit. This is not normal.

Btw - oil / filter change today w 10w-60 oil at dealer. This is driving normally. In traffic.

Something is up. Either incorrect reading or high temps. It was just below the mark between 210 and 300 and by time I snapped pic, dropped a bit.
Appreciate 0
      09-17-2018, 11:13 PM   #113
eyanez1230
Private First Class
eyanez1230's Avatar
United_States
37
Rep
137
Posts

Drives: 2013 E92 M3 ZCP
Join Date: Jan 2016
Location: Los Angeles

iTrader: (0)

This is the same oil temperature I get when I hit the canyons and drive it hard. I'm running Castrol 10W-60. I've also seen similar temps with stop and go traffic while A/C is on.
Appreciate 0
      09-18-2018, 01:46 PM   #114
New2Roundel
Lieutenant
163
Rep
475
Posts

Drives: 2011 M3 ZCP
Join Date: Jun 2015
Location: Philly, PA

iTrader: (0)

Quote:
Originally Posted by pucsicsal View Post
. It used to be *always* just below 210 unless I really pushed it, now it's always just above.
That's not really "wrong" though. Have you changed the type of oil you're using. I did notice the car running a little hotter after switching to the Twin Power oil that BMW is currently using. I likely will not be going back to it.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:38 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST