BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
BPM
Post Reply
 
Thread Tools Search this Thread
      04-19-2016, 08:00 PM   #1
///S65
Second Lieutenant
36
Rep
240
Posts

Drives: E92 M3 SSII DCT
Join Date: Apr 2013
Location: Indianapolis, IN

iTrader: (1)

Sudden loss of power on track

Hey guys, I just came from my first trackday this season and my car struggled a lot.

First session of the day, I was doing the warm-up lap (not pushing at all) and all of a sudden, there was no power! The throttle wasn't responsive at all at 3rd gear! Changed down to 2nd, nothing happened, changed up to 4th, and all of a sudden, the power came back on. The weird thing was, there WASN'T ANY WARNING MESSAGES. I have never experienced this on my car before. The rest of the session went well though.

I thought that was just a glitch so I kept on driving through the day. However, the car did the exact same thing again at the last session. Again, no warning message whatsoever. I immediately got off the track and called it a day.

On the way back I stopped for some fuel and guess what, the car STALLED 3 TIMES after refueling. And no warning message again.(I used Vpower from Shell)

So for all of you who take your m3 to track a lot, have you experienced anything like this? Car is a 2010 DCT with 67000 miles. ICV, throttle actuator and oil change were all serviced not long ago. I really don't know if I should take the car to the track any more. It's extremely fun but these isuues with sudden power loss is freaking me out.
__________________
2010 E92 SSII DCT, Akra Evo, ESS Tune, Performance Spolier &Splitter, Edition Side Markers, AD08R
Appreciate 0
      04-19-2016, 08:22 PM   #2
MFKN3
Colonel
MFKN3's Avatar
Australia
98
Rep
2,217
Posts

Drives: supercharged 4.4L stroker E92
Join Date: Nov 2008
Location: Australia

iTrader: (2)

Will prob be some sensor or fuel issue such as injector or pump. I'd get the car scanned for codes and wouldn't get put-off yet
Appreciate 0
      04-19-2016, 10:01 PM   #3
Kash
Private First Class
Kash's Avatar
United_States
63
Rep
190
Posts

Drives: 2011 M3 E92 DCT AW/FR
Join Date: May 2013
Location: Maryland

iTrader: (0)

Check the high pressure fuel vacuum sensor. It is faulty, I guess.
__________________
2011 M3 E92 Alpine White/Fox Red DCT
Appreciate 0
      04-19-2016, 11:40 PM   #4
BzsBimmer
Brigadier General
BzsBimmer's Avatar
South Korea
652
Rep
3,919
Posts

Drives: 2011 X5M & 2015 F80 M3
Join Date: Mar 2006
Location: Nor. Cal

iTrader: (22)

Send a message via Yahoo to BzsBimmer
I'd check for codes that may not be visible using a standard OBD reader. Maybe use INPA to read all errors from all modules.

Just because you used Shell does not mean you have good gas. Maybe try a different gas station in a different area.

Try to recreate the conditions that led to the stall.
Appreciate 0
      04-20-2016, 12:04 AM   #5
elim11
Major
341
Rep
1,272
Posts

Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

iTrader: (13)

This might be a stupid comment but was traction control activated and cutting the power?
__________________
Appreciate 0
      04-20-2016, 12:07 AM   #6
1MOREMOD
2018 track days - 0 ridge 1:52:24 pacific 1:33:30
1MOREMOD's Avatar
United_States
6427
Rep
19,990
Posts

Drives: Race car->
Join Date: Mar 2009
Location: check your mirrors

iTrader: (5)

Or did you get up against rev limiter?
Appreciate 0
      11-14-2018, 08:56 AM   #7
Matheus
Private
Matheus's Avatar
Brazil
18
Rep
55
Posts

Drives: 2012 M3 E92 Fire Orange
Join Date: Mar 2015
Location: Brazil

iTrader: (0)

Sorry to revive such an old thread, but thatís the only case that matches exactly what happened to me. The car suddenly lost power. No lights, no codes, nothing. Thought that could be temperature. After cooldown, another lap and same thing again, almost in the same place.
Anyone figured out the cause of the power loss?
Appreciate 0
      11-14-2018, 10:53 AM   #8
M3Post
Supreme Allied Commander DDE
M3Post's Avatar
United_States
349
Rep
392
Posts

Drives: Red '08 E92 M3 - DCT
Join Date: Jul 2010
Location: Next Door To BMW Plant

iTrader: (0)

Garage List
2015 BMW X5  [0.00]
2008 BMW M3  [0.00]
Quote:
Originally Posted by Matheus View Post
Sorry to revive such an old thread, but thatís the only case that matches exactly what happened to me. The car suddenly lost power. No lights, no codes, nothing. Thought that could be temperature. After cooldown, another lap and same thing again, almost in the same place.
Anyone figured out the cause of the power loss?
Gremlins. Have the car sprinkled with holy water by a Priest.
__________________
'08 E92 M3 DCT Melbourne Red/Bamboo Beige Leather/EDC/HARROP Supercharger/SSP Spec-R clutch discs/Quaife LSD/3:45 Final Drive by Diffs Online/M3 World HFC X-Pipe/Pipercross Air Filter/LUX H8 180/NGK Racing Iridium R2556B-9/BPM Sport Stage II/BPM Sport DCT/PFC Z-Rated Pads/ECS Brass Guide Brake Caliper Bushings/Alex Shop Solid Sub-frame Bushings/ Motul 600/Tint/APEX SM-10 18X11 ET44 + 12mm Spacers/APEX 75mm Stud Kit/
Appreciate 0
      11-14-2018, 11:15 AM   #9
Matheus
Private
Matheus's Avatar
Brazil
18
Rep
55
Posts

Drives: 2012 M3 E92 Fire Orange
Join Date: Mar 2015
Location: Brazil

iTrader: (0)

Quote:
Originally Posted by M3Post View Post
Gremlins. Have the car sprinkled with holy water by a Priest.
I should definitely do it
__________________
2012 E92 M3 ESS VT2 650 - Bilstein B16 Damptronic Coilovers - Brembo 380mm BBK - Innotech Catless Exhaust - GTS Carbon Wing - RollCage - Back Seat Delete - Sparco Evo Racing seats @m3boosted
Appreciate 0
      11-14-2018, 04:22 PM   #10
Bartledoo
Captain
Bartledoo's Avatar
United_States
340
Rep
703
Posts

Drives: 2011 E90 M3 6MT
Join Date: Aug 2015
Location: Seattle, WA

iTrader: (0)

Quote:
Originally Posted by Matheus View Post
I should definitely do it
Just make sure it's redpriest
Appreciate 0
      11-14-2018, 05:11 PM   #11
redpriest
Colonel
redpriest's Avatar
United_States
1297
Rep
2,143
Posts

Drives: 2017 M4 / 2011 M3
Join Date: Apr 2014
Location: Bay Area, CA

iTrader: (0)

Garage List
2006 BMW M3  [0.00]
2017 BMW M4  [5.00]
2011 BMW M3  [5.00]
Quote:
Originally Posted by Matheus View Post
Sorry to revive such an old thread, but that’s the only case that matches exactly what happened to me. The car suddenly lost power. No lights, no codes, nothing. Thought that could be temperature. After cooldown, another lap and same thing again, almost in the same place.
Anyone figured out the cause of the power loss?
It's the battery cable coming loose:



Get it fixed for free:

https://www.m3post.com/forums/showthread.php?t=1373697

Name an e9x M3 track gremlin and I've experienced it, lol:

* FRM module frying - turns out BMW is extending the warranty to 156k miles/10 years - too bad I replaced it!
* battery cable
* blower motor cable damage
* water coolant temp sensor implausible (fixed this with TSB and repair harness after frying it twice)
__________________
'06 BMW M3 ZCP 6MT | JRZ RS Pro + Hyperco 650/750 | Epic Tune | Brembo 355mm BBK | too many to list
'11 BMW M3 ZCP DCT | Akra Evolution | MS Intake/pulley | JRZ RS Pro + Hyperco 700/800 | BPM Stage2/DCT tune | Dinan sway bar + monoballs | AP Racing Radi-CAL BBK by Essex | 265/35-18 Maxxis RC-1 on APEX EC-7s
'17 BMW M4 ZCP 6MT - Individual Tanzanite Blue + Opal White Leather
instagram.com/titomanlio
Appreciate 1
M3Post348.50

      11-15-2018, 12:05 PM   #12
Matheus
Private
Matheus's Avatar
Brazil
18
Rep
55
Posts

Drives: 2012 M3 E92 Fire Orange
Join Date: Mar 2015
Location: Brazil

iTrader: (0)

Life saver! I'll have a look in those things. I have changed the battery cable a few months ago.
In fact what happened to my car was different. Here's a video of the moment

__________________
2012 E92 M3 ESS VT2 650 - Bilstein B16 Damptronic Coilovers - Brembo 380mm BBK - Innotech Catless Exhaust - GTS Carbon Wing - RollCage - Back Seat Delete - Sparco Evo Racing seats @m3boosted
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:24 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST