Bimmerpost for Android has just been updated to version 4.3.55 with a host of bug fixes. Try it out!
BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > BIMMERPOST Universal Forums > General BMW News and Cars Discussion
 
Redline360
Post Reply
 
Thread Tools Search this Thread
      03-08-2018, 05:24 PM   #1
Casotakar
First Lieutenant
Casotakar's Avatar
124
Rep
312
Posts

Drives: X3 M40i
Join Date: Feb 2018
Location: Vienna, VA

iTrader: (0)

Trouble activating included free Sirus XM one year trial

anyone else having as much trouble setting up their 1 year free trial through sirus xm as I am?

I've called 3 times. each time they send me a new signal to activate the subscription and also they send me a text to refresh this so called space signal myself if theirs doesn't work. I've done this one too...

does it take an additional 24-48 hours for this to work? I don't remember it being this hard 3 years ago when I sold my other bmw. I called, they set it up, activated, no problem.

anyone have this issue?

thanks.
__________________
2018 X3 M40i Carbon Black ZDA/ZDB/ZPP/ZPX
Appreciate 0
      03-08-2018, 11:09 PM   #2
DanG
Colonel
DanG's Avatar
United_States
849
Rep
2,300
Posts

Drives: 2018 M2 AW DCT
Join Date: Aug 2012
Location: Seattle, WA

iTrader: (1)

Garage List
2018 BMW M2  [4.87]
You need to have your radio on when they send the signal. Other wise it doesn’t work.
Appreciate 0
      03-09-2018, 12:05 AM   #3
IK6SPEED
Major General
IK6SPEED's Avatar
United_States
1515
Rep
5,273
Posts

Drives: BMW M3 / AH3
Join Date: Feb 2013
Location: Sacramento, CA

iTrader: (14)

Quote:
Originally Posted by Casotakar View Post
anyone else having as much trouble setting up their 1 year free trial through sirus xm as I am?

I've called 3 times. each time they send me a new signal to activate the subscription and also they send me a text to refresh this so called space signal myself if theirs doesn't work. I've done this one too...

does it take an additional 24-48 hours for this to work? I don't remember it being this hard 3 years ago when I sold my other bmw. I called, they set it up, activated, no problem.

anyone have this issue?

thanks.
My Dealer had it setup and working for delivery.

Your dealer obviously not as customer friendly.
__________________
Stable: F80 / AH3
Past: F80 ZCP / F22 M235i / E89 35is
Appreciate 0
      03-09-2018, 02:01 AM   #4
Scout10
Second Lieutenant
United_States
61
Rep
222
Posts

Drives: 2017 BMW X3 X28i
Join Date: Apr 2017
Location: Michigan

iTrader: (0)

done it twice in past two years, no problem.
Car running, radio on, away from garage and or bldgs . . . . bingo !
__________________
2017 BMW X3 x28i
2015 Honda CRV-EXL AWD (wife)
2012 Toyota Rav4 Limited AWD / V6 269hp (sold )
Appreciate 0
      03-09-2018, 02:46 AM   #5
bimmer456
Colonel
885
Rep
2,779
Posts

Drives: 340i
Join Date: Nov 2016
Location: Pasadena, CA

iTrader: (0)

Quote:
Originally Posted by IK6SPEED View Post
My Dealer had it setup and working for delivery.

Your dealer obviously not as customer friendly.
Mine was set up already by the BMW Genius along with the tracking device (BMW Assist and Connected Drive) so I could get the insurance discount. I would have the Genius set it up for you. They scheduled an appointment for me to come back a week later to confirm everything was working right.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:24 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST