BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Post Reply
 
Thread Tools Search this Thread
      04-13-2023, 12:49 PM   #1453
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

For everyone that ordered Mr12volt. How log did the shipping process take?
Appreciate 0
      04-15-2023, 01:37 PM   #1454
Tickler
New Member
England
15
Rep
16
Posts

Drives: BMW Z4 M40i
Join Date: Feb 2020
Location: Liverpool

iTrader: (0)

If it helps anyone, we just installed a P2000 MR12volt unit in our E61Ö. Itís CCC and actually brilliant considering we didnít update to CIC first.

We had to ask for a software upgrade to avoid stretching on CarPlay but no issues really..

Happy to offer any advice if people needÖ
Attached Images
 
Appreciate 1
      04-15-2023, 09:49 PM   #1455
georgebmwM3
Second Lieutenant
georgebmwM3's Avatar
United_States
253
Rep
275
Posts

Drives: 2008 BMW M3
Join Date: Feb 2011
Location: PA

iTrader: (0)

Garage List
2008 BMW M3  [9.00]
2017 Camaro ZL1  [0.00]
Is that the ccc screen?
Appreciate 0
      04-16-2023, 02:43 AM   #1456
Tickler
New Member
England
15
Rep
16
Posts

Drives: BMW Z4 M40i
Join Date: Feb 2020
Location: Liverpool

iTrader: (0)

Yeah thatís the stock ccc screen, much better than I expected if Iím honest
Appreciate 1
      04-16-2023, 05:36 PM   #1457
kawstik
Lieutenant
kawstik's Avatar
United_States
520
Rep
424
Posts

Drives: E92 M3 6MT
Join Date: Jan 2014
Location: Pittsburgh, PA

iTrader: (13)

Quote:
Originally Posted by Tickler View Post
Yeah that’s the stock ccc screen, much better than I expected if I’m honest
Did you have to do any coding to enable the CDC? I just installed my CCC unit today but am not getting the option.

I combed this thread and only found coding for CIC units.
__________________

Last edited by kawstik; 04-16-2023 at 06:00 PM..
Appreciate 0
      04-16-2023, 08:30 PM   #1458
Picanha
30FF
28
Rep
30
Posts

Drives: M3
Join Date: Apr 2017
Location: US

iTrader: (0)

Quote:
Originally Posted by kawstik View Post
Did you have to do any coding to enable the CDC? I just installed my CCC unit today but am not getting the option.

I combed this thread and only found coding for CIC units.
Not the OP, but I had to code CDC into my VO on my CCC install.
Appreciate 0
      04-17-2023, 03:53 PM   #1459
Tickler
New Member
England
15
Rep
16
Posts

Drives: BMW Z4 M40i
Join Date: Feb 2020
Location: Liverpool

iTrader: (0)

Quote:
Originally Posted by kawstik View Post
Did you have to do any coding to enable the CDC? I just installed my CCC unit today but am not getting the option.

I combed this thread and only found coding for CIC units.
We didnít actually, but then our car already had the CDC in the glove box luckily.

Should hopefully be a straightforward add in the coding though from what I have read on hereÖ
Appreciate 0
      04-21-2023, 06:11 PM   #1460
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

Installed Mr12Volt today. Can confirm this works on X3 with CIC. Coded to MP3 and swapped to stock Idrive boot image. Pandora was working intermittently but after reboot it seems to be okay......for now. Overall this is much easier to install then bimmerTech, ZZ2, or Road Top style carplay systems.
Appreciate 0
      04-21-2023, 08:47 PM   #1461
tdott
Brigadier General
3785
Rep
3,869
Posts

Drives: M3
Join Date: Nov 2010
Location: South FL / 6ix

iTrader: (4)

Quote:
Originally Posted by Thorsveinyhammer View Post
Installed Mr12Volt today. Can confirm this works on X3 with CIC. Coded to MP3 and swapped to stock Idrive boot image. Pandora was working intermittently but after reboot it seems to be okay......for now. Overall this is much easier to install then bimmerTech, ZZ2, or Road Top style carplay systems.
Just curious, what path led you guys to this thread? Was it google? It's impressive the number of models this has branched out to and brought you guys here to this little section of bimmerpost.
Appreciate 0
      04-24-2023, 01:35 PM   #1462
Thumbie
Private First Class
Thumbie's Avatar
40
Rep
135
Posts

Drives: 2011 M3/4/6
Join Date: Sep 2021
Location: SF Bay Area

iTrader: (0)

Quote:
Originally Posted by tdott View Post
Just curious, what path led you guys to this thread? Was it google? It's impressive the number of models this has branched out to and brought you guys here to this little section of bimmerpost.
Thinking the same thing. Lol. I found it because I was on the M3 forum and have an M3. Nice thing about BMW is they use the same(ish) system so teh mr12volt works across multiple platforms

Quote:
Originally Posted by Alexey_M View Post
hi guys! sorry for my english, im very far from US)



first of all, my name is Alex and i own Z4 e89 2010)

i install p2000 (blue box) and now i have a few qestions)
1. did somebody find good quality rear camera that work with p2000?
2. did somebody find how to tune equalizer p2000 for best sound? i found for old version without DSP, and now probably someone already tune p2000?
Not sure about for z4. This one is for e90 platform:
https://www.aliexpress.us/item/22518...andl_shipto=US

I have mine on flat, but the OEM DSP I have set according to Malek's post. that's for M3's though. I am sure the best factory settings are posted on the z4 forum somewhere.
__________________
-Thumbie

2011 Jerez E90 M3 6-speed Competition Package
Appreciate 1
tdott3784.50
      04-24-2023, 02:41 PM   #1463
krycha
Registered
0
Rep
1
Posts

Drives: BMW E61
Join Date: Apr 2023
Location: Poland

iTrader: (0)

Hello
I'm from Poland
I bought Android Auto from AliExpress, everything works but I can't get a better resolution, Google maps are not clear. I have CCC
[IMG][/IMG]
Appreciate 0
      04-24-2023, 06:17 PM   #1464
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

Quote:
Originally Posted by tdott View Post
Just curious, what path led you guys to this thread? Was it google? It's impressive the number of models this has branched out to and brought you guys here to this little section of bimmerpost.
Bimmertech was over priced for old tech. ZZ2 was recommended but just as bad as the cheaper Chinese models. Googled away and found this site.
Appreciate 1
tdott3784.50
      04-25-2023, 11:20 AM   #1465
DLucian
Private
6
Rep
56
Posts

Drives: E91 335i N55 | F20 125I B48
Join Date: Mar 2021
Location: Romania

iTrader: (0)

Hey everyone,

After reading extensively here, I went with this option on my freshly retrofitted CIC system on my EU Spec E91 335i LCI.

It seems to work ok at first glance, all though I am not completely done with the CIC coding and didn't test that much.

A first problem that I am getting is that the rear view camera works intermittently. What I noticed (but should test more) is that it almost always works when the car is first started. A few seconds after this, it stops working. It takes me to the "reverse screen" but I am getting a blank image (with the parking sensors on the right side).

Any thoughts? I doubt it's a installation fault. Of course, when I first installed it, I tested it once, it worked and now everything is back on the car and would be a nightmare to disassemble again.

Appreciate 0
      04-25-2023, 11:52 PM   #1466
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

The Mr12volt customer service appears to have went to shit. It's been two days and all I can get our of them is to use the bypass loop. The problem is that it doesn't even have the correct connection. I would need another female/male adapter. I'm also fairly certain that the cd unit that is in the dash on CIC needs to be in the loop. Issues so far are:

Really long times to connect to CarPlay. Usually fails on the first try.

Rear camera is completely blank sometimes. When it does this it will end up starting after CarPlay connects.

Random audio drop (oddly does not affect apple maps). Reboot fixes issue.
Attached Images
  

Last edited by Thorsveinyhammer; 04-25-2023 at 11:57 PM..
Appreciate 0
      04-26-2023, 07:52 AM   #1467
tdott
Brigadier General
3785
Rep
3,869
Posts

Drives: M3
Join Date: Nov 2010
Location: South FL / 6ix

iTrader: (4)

Quote:
Originally Posted by DLucian View Post
Any thoughts? I doubt it's a installation fault. Of course, when I first installed it, I tested it once, it worked and now everything is back on the car and would be a nightmare to disassemble again.
Did you connect the ground wire to the camera? some have report that it works better without connecting the ground for some reason.
Appreciate 0
      04-26-2023, 08:15 AM   #1468
DLucian
Private
6
Rep
56
Posts

Drives: E91 335i N55 | F20 125I B48
Join Date: Mar 2021
Location: Romania

iTrader: (0)

Thanks for the reply.

Yes, I have connected the ground, didn't even consider leaving it disconnected. I also sent an email to the person I bought it from and they also asked me to check the ground. Luckily it's grounded to a place not to hard to reach so I will look into this and see if this helps in any way.
Appreciate 0
      04-26-2023, 10:04 PM   #1469
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Quote:
Originally Posted by DLucian View Post
Hey everyone,

After reading extensively here, I went with this option on my freshly retrofitted CIC system on my EU Spec E91 335i LCI.

It seems to work ok at first glance, all though I am not completely done with the CIC coding and didn't test that much.

A first problem that I am getting is that the rear view camera works intermittently. What I noticed (but should test more) is that it almost always works when the car is first started. A few seconds after this, it stops working. It takes me to the "reverse screen" but I am getting a blank image (with the parking sensors on the right side).

Any thoughts? I doubt it's a installation fault. Of course, when I first installed it, I tested it once, it worked and now everything is back on the car and would be a nightmare to disassemble again.

You need the power filter thingy, I bought one on aliexpress and when hooking it to the ground I wired it directly to the taillight ground wire. Ever since then I had no issues. Before on reverse, it would activate sometimes and it won't.
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
      04-26-2023, 11:01 PM   #1470
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

Quote:
Originally Posted by GORDON.M3 View Post
You need the power filter thingy, I bought one on aliexpress and when hooking it to the ground I wired it directly to the taillight ground wire. Ever since then I had no issues. Before on reverse, it would activate sometimes and it won't.
To confirm, Mr12volt ground is left disconnected but grounding wire on end of camera is connected to a power filter which is grounded?
Appreciate 0
      04-26-2023, 11:33 PM   #1471
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Quote:
Originally Posted by Thorsveinyhammer View Post
To confirm, Mr12volt ground is left disconnected but grounding wire on end of camera is connected to a power filter which is grounded?
Whatever was grounded I had it tapped to the rear taillight ground.
I left no wires disconnected.
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
      04-27-2023, 08:43 AM   #1472
Thorsveinyhammer
WSB Ape
Thorsveinyhammer's Avatar
70
Rep
59
Posts

Drives: BMW X3
Join Date: Feb 2023
Location: West Coast

iTrader: (0)

Update on the M212volt customer support. They responded back last night at like 11pm. After a long an lengthy chat about my intermittent issues, they are convinced that there is a cd changer somewhere that needs to be bypassed. I tried explaining that not all BMW's have multi-disk CD changers.

Update: After a week of bouncing back an forth, it seems that Mr12volt has determined (according to them) that this unit is not compatible with with non-multi disk BMW's unless you can code your car to think it has a multi disk. According to them, the MP3 coding that we needed to do just to get their unit to work is not sufficient unless your drive screen looks exactly like theirs. They are calling it the CDC function and per their website it needs to be enabled either by BMW or bimmercode.
Attached Images
  

Last edited by Thorsveinyhammer; 04-28-2023 at 12:36 PM..
Appreciate 0
      04-28-2023, 03:17 PM   #1473
no.turbos
Private First Class
no.turbos's Avatar
41
Rep
145
Posts

Drives: 2012 Alpine White E92 M3
Join Date: Jul 2018
Location: San Diego

iTrader: (1)

Has anyone here had any luck with the OEM mic splitter? I am going to be installing my unit today but am not going to install the mic until I can figure out a better solution than the included mic.
__________________
IG: no.turbo

2012 Alpine White E92 M3 Coupe w/ Fox Red Extended Leather
Appreciate 0
      04-28-2023, 03:54 PM   #1474
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Quote:
Originally Posted by Thorsveinyhammer View Post
Update on the M212volt customer support. They responded back last night at like 11pm. After a long an lengthy chat about my intermittent issues, they are convinced that there is a cd changer somewhere that needs to be bypassed. I tried explaining that not all BMW's have multi-disk CD changers.

Update: After a week of bouncing back an forth, it seems that Mr12volt has determined (according to them) that this unit is not compatible with with non-multi disk BMW's unless you can code your car to think it has a multi disk. According to them, the MP3 coding that we needed to do just to get their unit to work is not sufficient unless your drive screen looks exactly like theirs. They are calling it the CDC function and per their website it needs to be enabled either by BMW or bimmercode.
The CIC unit can be coded to the multi-disc using a Windows-based coding tool. Unless bimmercode or whatever phone app you are using can do VO codes also.

Simply add CDC VO code, code the headunit and then the CIC will display multi-disc even if it doesn't have a physical cd changer unit plugged in.

And if I'm not mistaken, the cd changer unit is built into the CIC unit for the F-series cars, you wouldn't have a separate unit in the trunk like back when it was CCC Based.
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:55 AM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST