BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Mporium BMW
Post Reply
 
Thread Tools Search this Thread
      10-22-2022, 06:34 PM   #1299
pt00323i
Registered
United_States
0
Rep
3
Posts

Drives: F31 328d/E46 M3
Join Date: Jul 2019
Location: Bay Area, CA

iTrader: (0)

Just installed mine no cd changer, under cd didnít show mr12volt so so I need to program it? All din set at off
No cd Changer in trunk do I still need to look for the fiber to loop it?
Appreciate 0
      10-23-2022, 12:51 PM   #1300
danbav
Private
47
Rep
56
Posts

Drives: E92 330i, 335i. Golf GTI mk1
Join Date: Jan 2022
Location: UK

iTrader: (0)

Does anyone happen know how to enable the TV function on NBT using bimmercode? Did a bit of searching and didnít turn up much. I have a mate who is going to be ordering the NBT version for his M4. This is the missing part of the prep to get everything ready for the installation.
Appreciate 0
      10-24-2022, 12:04 AM   #1301
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Quote:
Originally Posted by pt00323i View Post
Just installed mine no cd changer, under cd didnít show mr12volt so so I need to program it? All din set at off
No cd Changer in trunk do I still need to look for the fiber to loop it?
No need for the fiberoptic loop, just simply do the coding.
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
      10-24-2022, 09:57 AM   #1302
kd7iwp
New Member
0
Rep
22
Posts

Drives: 2009 E61 535i, 2001 E46 325i
Join Date: Feb 2020
Location: Abbotsford, BC

iTrader: (0)

FYI, for those on the fence, the Mr12Volt site has a sale for a week. $30 off.
Appreciate 0
      10-24-2022, 05:42 PM   #1303
alee0729
Lieutenant
alee0729's Avatar
171
Rep
582
Posts

Drives: 2013 E92 M3, 2018 Tesla 3 Perf
Join Date: Mar 2013
Location: New York, NY

iTrader: (0)

Anyone hire a shop in the NYC/NJ area to do the install? I'm sure I could stumble through it, but not exactly something I want to try and do in a parking garage over a few hours.
__________________
2013 E92 M3 (the weekend good weather car), 2018 Tesla Model 3 Performance (the 20k mi/yr beater)
Appreciate 0
      10-24-2022, 08:14 PM   #1304
BlackDelta
New Member
9
Rep
21
Posts

Drives: 2012 BMW E92 M3 ZCP
Join Date: Oct 2021
Location: New York

iTrader: (0)

Does this still have crackle pop issues? I thought firmware update was coming early September?
Appreciate 0
      10-24-2022, 09:46 PM   #1305
khoivo408
Enlisted Member
39
Rep
46
Posts

Drives: BMW E90 M3 6MT
Join Date: Oct 2021
Location: Picatinny, NJ

iTrader: (0)

I am getting the red screen of death on the idrive after installing the P2000 DSP unit. Anyone had this issue before and know how to resolve it? I have the CIC version and all DIP switches are in OFF position. Carplay screen works flawlessly and I was able to connect my iphone to BT and hear sound/music but whenever i switch back to idrive screen, it flickers red then black consantly. I verified that I don't have a faulty CIC unit by connecting original LVDS cable from CID to CIC and the idrive screen works again. Searched through the forums with people able to fix red screens by depressing volume button for ~30 seconds to reboot CIC but that didn't work for me. I am suspecting it's the supplied LVDS cable that is bad and sent emails/ whatsapp messages to Mr12Volt but no reply, please help!
Appreciate 0
      10-25-2022, 11:33 PM   #1306
drwankel
Captain
drwankel's Avatar
943
Rep
973
Posts

Drives: 2012 E92 M3 ZCP
Join Date: Feb 2016
Location: Bothell, WA

iTrader: (0)

Quote:
Originally Posted by khoivo408 View Post
I am getting the red screen of death on the idrive after installing the P2000 DSP unit. Anyone had this issue before and know how to resolve it? I have the CIC version and all DIP switches are in OFF position. Carplay screen works flawlessly and I was able to connect my iphone to BT and hear sound/music but whenever i switch back to idrive screen, it flickers red then black consantly. I verified that I don't have a faulty CIC unit by connecting original LVDS cable from CID to CIC and the idrive screen works again. Searched through the forums with people able to fix red screens by depressing volume button for ~30 seconds to reboot CIC but that didn't work for me. I am suspecting it's the supplied LVDS cable that is bad and sent emails/ whatsapp messages to Mr12Volt but no reply, please help!
I think you are on the right track suspecting the cable. The screen makes that color when it has no signal. When I installed my first p2000 the car for some reason decided to wake up in the middle of the install, and I noticed the screen did that with nothing connected.

The fact that carplay/p2000 shows up on the screen, means the video signal is getting from the p2000 to the screen. Idrive not displaying implies the idrive video signal is not reaching the p2000, or the p2000 is faulty and not passing the video signal through. Start with the cable, and if that doesn't work, try a new box.

Best of luck interacting with support. They've been decent in my interactions with them.

Last edited by drwankel; 10-25-2022 at 11:39 PM..
Appreciate 0
      10-27-2022, 10:07 AM   #1307
khoivo408
Enlisted Member
39
Rep
46
Posts

Drives: BMW E90 M3 6MT
Join Date: Oct 2021
Location: Picatinny, NJ

iTrader: (0)

Quote:
Originally Posted by drwankel View Post
I think you are on the right track suspecting the cable. The screen makes that color when it has no signal. When I installed my first p2000 the car for some reason decided to wake up in the middle of the install, and I noticed the screen did that with nothing connected.

The fact that carplay/p2000 shows up on the screen, means the video signal is getting from the p2000 to the screen. Idrive not displaying implies the idrive video signal is not reaching the p2000, or the p2000 is faulty and not passing the video signal through. Start with the cable, and if that doesn't work, try a new box.

Best of luck interacting with support. They've been decent in my interactions with them.
Hey thanks man, their support team finally reached out. After sending them photos and video of the issue, they are sending over an LVDS cable replacement to me to try out. I hope it fixes it!

On another note, I've been using Carplay on it and have noticed a significant increase in bass compared to the non-DSP version, so definitely a good upgrade!
Appreciate 0
      10-27-2022, 03:13 PM   #1308
djan9el
Private
djan9el's Avatar
46
Rep
70
Posts

Drives: 2010 E92 M3 DCT
Join Date: Aug 2021
Location: OK

iTrader: (0)

New Mr12volt P2000 Firmware update available:

P2000 for CCC v2.7 (bmwCCC_20221019)
P2000 for CIC v2.8 (bmwCIC_20221019)

"bmwCIC_20221013 " fixed iDrive not able to find p2000 issue
"bmwCIC_20221019 " improved BT handsfree call quality, low pass frequency can be adjusted in setting now

MCU Change Log
Appreciate 3
GORDON.M31351.00
drwankel943.00
      10-29-2022, 12:44 PM   #1309
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Anyone have any good DSP settings to share?
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
      10-30-2022, 12:51 PM   #1310
kd7iwp
New Member
0
Rep
22
Posts

Drives: 2009 E61 535i, 2001 E46 325i
Join Date: Feb 2020
Location: Abbotsford, BC

iTrader: (0)

I just finally installed mine last night. One thing I hadnít considered is that since this is using a specific audio source (CD changer) I cannot listen to radio while usingÖ with my old mmi I usually had CarPlay running but radio on. Could do that since the display was controlled independently of audio source. Is there a way to turn the Mr12Volt display while using a different audio source?
Appreciate 0
      10-31-2022, 11:42 AM   #1311
pt00323i
Registered
United_States
0
Rep
3
Posts

Drives: F31 328d/E46 M3
Join Date: Jul 2019
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by GORDON.M3 View Post
No need for the fiberoptic loop, just simply do the coding.
Yea got it just code and is working

No sound issues everything working so far
Appreciate 0
      10-31-2022, 01:19 PM   #1312
drwankel
Captain
drwankel's Avatar
943
Rep
973
Posts

Drives: 2012 E92 M3 ZCP
Join Date: Feb 2016
Location: Bothell, WA

iTrader: (0)

Quote:
Originally Posted by kd7iwp View Post
I just finally installed mine last night. One thing I hadnít considered is that since this is using a specific audio source (CD changer) I cannot listen to radio while usingÖ with my old mmi I usually had CarPlay running but radio on. Could do that since the display was controlled independently of audio source. Is there a way to turn the Mr12Volt display while using a different audio source?
Not possible.

Best advice is to use a streaming app for whatever radio station you are listening to. Many stations are playable in apple music, or other apps like audacy, etc.

This is a limitation I wish didn't exist, but is an unmoveable stone due to the nature of how the p2000 impersonates a CD changer.
Appreciate 0
      11-01-2022, 01:39 PM   #1313
Has39
New Member
6
Rep
14
Posts

Drives: E39 2002 530d, E60 2008 535d
Join Date: Mar 2022
Location: West Midlands, United Kingdom

iTrader: (0)

I'm waiting for them to add folder support on the "video" section on interface
Appreciate 0
      11-01-2022, 05:04 PM   #1314
peteleun
New Member
3
Rep
11
Posts

Drives: E92 M3
Join Date: Sep 2022
Location: Sydney

iTrader: (0)

Anyone experience lack of GPS signals (CarPlay) when going into a tunnel? Does Mr12volt uses its own gps because when it happens, my phone gps still works fine. Is there a way to improve the gps signals?

Another issues I have experienced multiple times is maps like wazes get distorted (some parts of the map are smudged).
Appreciate 0
      11-01-2022, 09:50 PM   #1315
kd7iwp
New Member
0
Rep
22
Posts

Drives: 2009 E61 535i, 2001 E46 325i
Join Date: Feb 2020
Location: Abbotsford, BC

iTrader: (0)

Quote:
Originally Posted by drwankel View Post
Not possible.

Best advice is to use a streaming app for whatever radio station you are listening to. Many stations are playable in apple music, or other apps like audacy, etc.

This is a limitation I wish didn't exist, but is an unmoveable stone due to the nature of how the p2000 impersonates a CD changer.
I suggested a feature request to them to separate the audio and video channels. They chose to have their product output its own video whenever we are on CD changer mode. They own the video switcher and could allow it to switch video whenever, such as when we hold the idrive menu button for a few seconds. I recognize this would bring some people complications because if they were listening to radio and clicked the button for Siri, they would not hear Siri.
Appreciate 0
      11-07-2022, 01:32 PM   #1316
dylim
Second Lieutenant
14
Rep
294
Posts

Drives: 328xi
Join Date: Mar 2012
Location: bay area

iTrader: (3)

Thanks! I just tried updating my CIC DSP unit (bought in april 2022) to the latest firmware. Earlier in the thread people were saying that no cables need to be removed and instead of unplugging the power, you could just reboot the CIC, but that didn't work for me. Am I doing it wrong?

After plugging in the microsd card I see that the blue light next to it lights up solid blue.

I then tried to reboot the CIC by pressing and holding the volume button, and I see that it reboots indeed. But carplay quickly connects, and nothing happens for several minutes (light still solid blue, carplay still connected, system version still the old one).

Then I reboot the CIC again, and the system is still the old version.


Quote:
Originally Posted by djan9el View Post
New Mr12volt P2000 Firmware update available:

P2000 for CCC v2.7 (bmwCCC_20221019)
P2000 for CIC v2.8 (bmwCIC_20221019)

"bmwCIC_20221013 " fixed iDrive not able to find p2000 issue
"bmwCIC_20221019 " improved BT handsfree call quality, low pass frequency can be adjusted in setting now

MCU Change Log
Appreciate 0
      11-07-2022, 03:57 PM   #1317
SteelFK1
Enlisted Member
2
Rep
36
Posts

Drives: bmw e91
Join Date: Jun 2022
Location: Germany

iTrader: (0)

I have a question, I have the blue Mr12Volt box, also I have the GreenYi rear view camera in the E90, and I have the Viofo A139 dashcam, this has an AV port, I also have the AV cable with Cinch Cable wich you can probably connect to Mr12Volt box, can I, if so, see the image from the dashcam on the screen? Where in Mr12Volt would I have to go in the software?

With kind regards
Appreciate 0
      11-07-2022, 06:50 PM   #1318
Ervin87
Lieutenant
Ervin87's Avatar
United_States
519
Rep
595
Posts

Drives: E92 M3 | B5 S4 | E30
Join Date: Aug 2012
Location: Santa Clara, CA

iTrader: (5)

Has anyone recently installed this unit on a CCC system and provide some feedback?
Appreciate 0
      11-07-2022, 11:41 PM   #1319
kd7iwp
New Member
0
Rep
22
Posts

Drives: 2009 E61 535i, 2001 E46 325i
Join Date: Feb 2020
Location: Abbotsford, BC

iTrader: (0)

Quote:
Originally Posted by dylim View Post
Thanks! I just tried updating my CIC DSP unit (bought in april 2022) to the latest firmware. Earlier in the thread people were saying that no cables need to be removed and instead of unplugging the power, you could just reboot the CIC, but that didn't work for me. Am I doing it wrong?

After plugging in the microsd card I see that the blue light next to it lights up solid blue.

I then tried to reboot the CIC by pressing and holding the volume button, and I see that it reboots indeed. But carplay quickly connects, and nothing happens for several minutes (light still solid blue, carplay still connected, system version still the old one).

Then I reboot the CIC again, and the system is still the old version.
Iím having the same issue and canít update. Support told me to try a different micro SD card, unfortunately I have no other.
Appreciate 0
      11-08-2022, 01:02 PM   #1320
GORDON.M3
Colonel
GORDON.M3's Avatar
Canada
1351
Rep
2,920
Posts

Drives: E92 M3 • F25 X3 M-Sport
Join Date: Dec 2013
Location: LAX/YYZ/NRT

iTrader: (10)

Quote:
Originally Posted by kd7iwp View Post
I’m having the same issue and can’t update. Support told me to try a different micro SD card, unfortunately I have no other.
SD Card must be formatted FAT32. Make sure the MOST port is unplugged from the Mr12volt unit before updating.

When you plug in the SD card there will be 2 series of blinking red light.
__________________
INSTAGRAM: GORDON.M3
DINAN | EVOSPORT | VAC | ARP | RD SPORT | NEEZ | EIBACH | CSF | IND | BILSTEIN | KLASSEN | BREMBO | ENDLESS | BBS | BPM SPORT | PROJECT MU | EVENTURI
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:10 AM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST