BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Mporium BMW
Post Reply
 
Thread Tools Search this Thread
      05-06-2019, 07:59 PM   #1
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Slow startup + SES

Hello everyone

Background:08 E90 M3 6Spd 60K Miles

This car is not my daily and seems like the startup is getting worse overtime.
I’ve watched a few cold start videos on YouTube and seems like the car starts after about 1.5-2seconds. Mine seems abnormal and slow at 3 seconds.(will post video when it’s cold again). Timing for startup is not to scale.
Issue:
I was cleaning out the leaves under the hood. Then I started it and obtained a DSC error with SES light. I let it run for about 5 minutes to hopefully remove the errors. Sadly enough, DSC error went away but SES light stayed on.
Voltage:12.15 when off.
Do you think this is a fault SES? Not enough power distributed to the “faulty sensor”? Car ran beautifully on 5/4. It had a similar slow startup.

Last edited by E46tknv; 05-06-2019 at 09:02 PM..
Appreciate 0
      05-06-2019, 08:06 PM   #2
codinge90
Banned
316
Rep
742
Posts

Drives: e92 M3
Join Date: Jun 2015
Location: San Diego

iTrader: (1)

Have you scanned the car and pulled codes?
Appreciate 0
      05-06-2019, 08:12 PM   #3
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Quote:
Originally Posted by codinge90 View Post
Have you scanned the car and pulled codes?
Update:
I let the car cool off for 30min. I started it again and the DSC, yellow brake light and SES light came on. Drove the car to autozone for a diagnosis and looks like it’s telling me I have code p0638. DSC and brake light turned off but SES continues to be on.
P0638 indicates that the throttle actuator control was out of its operating range or had a performance problem, Bank 1 for a predetermined period of time. This is dreadful since I know this is a known issue in this car.

Before I consider replacing this part, could a weak battery be creating all of this? Seems like errors come on/off depending on how long it’s sitting vs driven

Last edited by E46tknv; 05-06-2019 at 09:01 PM..
Appreciate 0
      05-06-2019, 09:05 PM   #4
Route 16
I got lei'd
Route 16's Avatar
Philippines
825
Rep
7,583
Posts

Drives: '10 E90 M3
Join Date: Sep 2011
Location: Dark Side of the Moon

iTrader: (62)

you could let it stay on a battery tender overnight and or unplug the negative let the ECU reset then plug it back in, in the morning

when was the battery last changed? then worse case...replace both throttle actuators
Appreciate 0
      05-06-2019, 09:31 PM   #5
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Quote:
Originally Posted by Route 16 View Post
you could let it stay on a battery tender overnight and or unplug the negative let the ECU reset then plug it back in, in the morning

when was the battery last changed? then worse case...replace both throttle actuators
Battery is at 12.36

According to carfax and records I have, battery was not replaced. Throttle actuator bank 2 was done 5K miles ago.

Are the symptoms I mentioned lead to a bad throttle actuator?

Update: attempted to remove negative terminal but what a pain in the ass it is so I’ll leave it for another day. While doing so, wiggled it around, tightened the hell out of the terminal and the SES light is gone.

What’s going on....

Last edited by E46tknv; 05-06-2019 at 09:55 PM..
Appreciate 0
      05-07-2019, 06:31 AM   #6
Charlievee
Private
23
Rep
60
Posts

Drives: E92 M3
Join Date: Mar 2015
Location: Sydney, Australia

iTrader: (0)

Check the voltage across your battery while the car is running. If itís under 13.x then your alternator is probably working intermittently and probably needs a new voltage regulator.

Throttle actuator wonít cause a slow start up, the prestart will fail and it wonít crank at all.
Appreciate 0
      05-07-2019, 06:38 AM   #7
Mvy
Captain
United_States
530
Rep
979
Posts

Drives: 2008 E93 M3
Join Date: Nov 2014
Location: GA Peach

iTrader: (0)

You need a new battery.
__________________

Harrop Supercharger, BPM Tune, K/W Coil over kit, Stoptek BBK, Magnaflow exhaust, ear to ear grin everytime I drive...
Appreciate 0
      05-07-2019, 06:39 AM   #8
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Battery at 12.05 in the morning. Same slow crank but no warning lights
Appreciate 0
      05-07-2019, 06:45 AM   #9
Charlievee
Private
23
Rep
60
Posts

Drives: E92 M3
Join Date: Mar 2015
Location: Sydney, Australia

iTrader: (0)

Your alternator is dead if youíre getting 12.05 with the car running.
Appreciate 0
      05-07-2019, 06:54 AM   #10
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Quote:
Originally Posted by Charlievee View Post
Your alternator is dead if youíre getting 12.05 with the car running.
Car is not on
Appreciate 0
      05-07-2019, 07:00 AM   #11
Charlievee
Private
23
Rep
60
Posts

Drives: E92 M3
Join Date: Mar 2015
Location: Sydney, Australia

iTrader: (0)

Turn it on and check the voltage... battery is weak, but it seems youíre getting an intermittent charge. Youíre definitely getting weak battery symptoms. Itíll only take a few minutes of driving with a dead alternator till you get a charging error, but it might not come up till your battery charge is really low.
You get all sorts of errors when youíre battery is low including the TA ones.
Appreciate 0
      05-07-2019, 08:37 AM   #12
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Quote:
Originally Posted by Charlievee View Post
Turn it on and check the voltage... battery is weak, but it seems you’re getting an intermittent charge. You’re definitely getting weak battery symptoms. It’ll only take a few minutes of driving with a dead alternator till you get a charging error, but it might not come up till your battery charge is really low.
You get all sorts of errors when you’re battery is low including the TA ones.
Looks like I have a reason to buy the Carly app as well considering I have to register the battery after replacing. I’ll keep a look at the voltages because I am not convinced about the TA just yet.

I drove around for 20minutes yesterday with the dsc, brake lift and SES light on at the same time. Power reduced and all.

Got to autozone. Scanned. Turned back on. Lights went off besides SES.

Got back home, turned car off. Turned it back on, SES is off.

Last edited by E46tknv; 05-07-2019 at 09:11 AM..
Appreciate 0
      05-07-2019, 05:10 PM   #13
ItsGary
Colonel
ItsGary's Avatar
Canada
1457
Rep
2,336
Posts

Drives: 2009 E90 M3
Join Date: Oct 2017
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by E46tknv View Post
Looks like I have a reason to buy the Carly app as well considering I have to register the battery after replacing. Iíll keep a look at the voltages because I am not convinced about the TA just yet.

I drove around for 20minutes yesterday with the dsc, brake lift and SES light on at the same time. Power reduced and all.

Got to autozone. Scanned. Turned back on. Lights went off besides SES.

Got back home, turned car off. Turned it back on, SES is off.
If you have a laptop, I can provide you the necessary links to get ISTA+, that way you just need to buy a cable for $15-25 and save yourself a lot of money.
__________________
'09 ///M3 Sedan - Jerez Black/Fox Red Ext.
'09 335i Coupe - Alpine White/Black - SOLD
Appreciate 0
      05-07-2019, 05:42 PM   #14
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

Quote:
Originally Posted by ItsGary View Post
If you have a laptop, I can provide you the necessary links to get ISTA+, that way you just need to buy a cable for $15-25 and save yourself a lot of money.
Yes I do but already purchased the Carly adapter.



Update:
Morning temperature 50F, Car off= 12.05V

Started vehicle in 77F. Car off=12.15V Car on=14.13
It fired right up without hesitation but of course, SES light with DSC light came on.

Doesnt seem to be a battery would cause these nasty lights to come on.

Last edited by E46tknv; 05-08-2019 at 08:11 PM..
Appreciate 0
      05-08-2019, 08:09 PM   #15
E46tknv
Private First Class
59
Rep
194
Posts

Drives: BMW E90 M3
Join Date: Dec 2014
Location: NY

iTrader: (0)

The throttle actuator has lived its life after 63K miles. Thankfully PO replaced bank 2 at 59K miles. Not sure why both sides werent done if your down there.
Heres a video of reference of what shows a bad actuator, after doing enough reading up on the matter. Thank you everyone

Followed by images inside the actuator.

PM me if you want to save money doing the work Ill charge much less then a dealer

Name:  IMG_3638.JPEG
Views: 575
Size:  229.5 KB

Name:  IMG_3639.JPEG
Views: 556
Size:  215.1 KB

Name:  IMG_3643.JPEG
Views: 569
Size:  231.9 KB

Name:  IMG_3644.JPEG
Views: 550
Size:  219.7 KB
Appreciate 0
Post Reply

Bookmarks

Tags
bmw, cold start, e90, sedan, startup

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:30 AM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST