BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      11-26-2015, 11:31 PM   #1
ash4390
Private First Class
ash4390's Avatar
43
Rep
116
Posts

Drives: 2011 M3
Join Date: Nov 2015
Location: Vancouver

iTrader: (0)

Driver door intermittently doesn't unlock from the inside

So I just picked up a 2011 E90 M3 -- and thus far everything has been great!

Except... maybe 1/10 times, when I turn the car off and do the double pull to open the door from the inside, it doesn't unlock. I can see the lock raise, and then go back in.

If I hit the central unlock button, or use my fob -- all is well. The car is still under warranty, but it'll be tough to show the dealer when it's so intermittent.

Has anyone experienced this before? I've replaced the batteries in the fob and everything, I can't figure it out!
Appreciate 0
      11-27-2015, 02:23 PM   #2
72dan
Enlisted Member
72dan's Avatar
United_States
6
Rep
39
Posts

Drives: 2009 M3 DCT coupe white/beige
Join Date: Nov 2010
Location: Los Angeles

iTrader: (1)

Same problem here on my 2009 M3.
I don't think it has to do with the remote. It is likely a lever bent inside the door.

The lock is to manually unlock with the double pull so that in an accident where power is lost you can get out of the car.
__________________
Regards,
72dan
Appreciate 0
      11-28-2015, 09:35 PM   #3
ash4390
Private First Class
ash4390's Avatar
43
Rep
116
Posts

Drives: 2011 M3
Join Date: Nov 2015
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by 72dan View Post
Same problem here on my 2009 M3.
I don't think it has to do with the remote. It is likely a lever bent inside the door.

The lock is to manually unlock with the double pull so that in an accident where power is lost you can get out of the car.
Yeah that's what I figured, annoying as heck. I just know I'll take it to the dealer and won't be able to reproduce it right at that moment hahaha
Appreciate 0
      12-03-2015, 01:16 PM   #4
tagta3
Enlisted Member
12
Rep
41
Posts

Drives: E90 M3
Join Date: Aug 2015
Location: MA

iTrader: (0)

I have the same problem. I just mine in september. You can tell when it's not going to work that day. When you unlock your car and drive away if the lock selonoid moved the lock slowly when you first unlocked it, most likely it will not unlock and stay up when you double pull to get out of the car. If you exercise it a couple times using the central locking button and then try the double pull it always seems to work. I've tried reading threads about this and this is the first one I've found with the exact symptoms. I read somewhere that the actual solenoid is what keep the lock up/open when you double pull. I find that hard to believe. I thought it was a mechanical latch that opened the door??
Appreciate 0
      12-03-2015, 01:51 PM   #5
Richbot
Brigadier General
1223
Rep
4,227
Posts

Drives: Jerez Black E90
Join Date: Sep 2007
Location: STL

iTrader: (3)

The handle doesn't operate the mechanical latch unless the door lock actuator engages a linkage which allows it, indicated by the button being up.

Probably need to replace your latch system, which is a $171 and there's a puma bulletin on it so you might want to look that up
Appreciate 0
      12-03-2015, 01:53 PM   #6
msan
Captain
273
Rep
938
Posts

Drives: 2011 E90 M3 / 2012 X5 35i M Sp
Join Date: May 2015
Location: Los Angeles, CA

iTrader: (15)

my doors unlock automatically as soon as I stop the engine
Appreciate 0
      12-03-2015, 02:39 PM   #7
tagta3
Enlisted Member
12
Rep
41
Posts

Drives: E90 M3
Join Date: Aug 2015
Location: MA

iTrader: (0)

Quote:
Originally Posted by Richbot View Post
The handle doesn't operate the mechanical latch unless the door lock actuator engages a linkage which allows it, indicated by the button being up.

Probably need to replace your latch system, which is a $171 and there's a puma bulletin on it so you might want to look that up
I tried finding the PUMA bulletin on it but couldn't find it. Is it just an actuator that needs replacement then?
Appreciate 0
      12-03-2015, 05:13 PM   #8
Hierlevelz
Captain
67
Rep
909
Posts

Drives: 11 AW E9X M
Join Date: Dec 2011
Location: ENYC

iTrader: (10)

Happens on my 11 E90 in 1/20 times I open the door. Glad to see its not just some fluke.
Appreciate 0
      12-09-2015, 11:28 AM   #9
tagta3
Enlisted Member
12
Rep
41
Posts

Drives: E90 M3
Join Date: Aug 2015
Location: MA

iTrader: (0)

Is it just the actuator solenoid that needs replacement to fix this?
Appreciate 0
      12-10-2015, 11:10 PM   #10
kenwelch
Lieutenant
United_States
79
Rep
544
Posts

Drives: 2008 E92 M3 M-DCT & 2017 440GC
Join Date: Dec 2006
Location: Mission Viejo, CA

iTrader: (0)

When this happens, push the unlock button in the center of the dash. If the door unlocks it is NOT the actuator, but a problem with the lever, release cable, or latch. Re: it's a mechanical component not the electrical actuator.
Appreciate 0
      12-11-2015, 06:26 AM   #11
tagta3
Enlisted Member
12
Rep
41
Posts

Drives: E90 M3
Join Date: Aug 2015
Location: MA

iTrader: (0)

ok that's what I thought that it was mechanical. Yes the door does unlock with the button on the dash, and once I use the button once then the double pull to unlock works every time after. It's only when it sits for a while that it does this.
Appreciate 0
      12-14-2015, 12:08 PM   #12
Hierlevelz
Captain
67
Rep
909
Posts

Drives: 11 AW E9X M
Join Date: Dec 2011
Location: ENYC

iTrader: (10)

Quote:
Originally Posted by kenwelch View Post
When this happens, push the unlock button in the center of the dash. If the door unlocks it is NOT the actuator, but a problem with the lever, release cable, or latch. Re: it's a mechanical component not the electrical actuator.
fuk mine did it twice yesterday but fortunately the center button allows it to open. So is there an existing DIY or details on the puma case?
Appreciate 0
      12-14-2015, 01:47 PM   #13
kenwelch
Lieutenant
United_States
79
Rep
544
Posts

Drives: 2008 E92 M3 M-DCT & 2017 440GC
Join Date: Dec 2006
Location: Mission Viejo, CA

iTrader: (0)

Mine has done this so rarely that I never searched for a TSB or DIY solution. I'll see what I can find.
Appreciate 0
      12-16-2015, 01:02 PM   #14
kenwelch
Lieutenant
United_States
79
Rep
544
Posts

Drives: 2008 E92 M3 M-DCT & 2017 440GC
Join Date: Dec 2006
Location: Mission Viejo, CA

iTrader: (0)

Quote:
Originally Posted by kenwelch View Post
Mine has done this so rarely that I never searched for a TSB or DIY solution. I'll see what I can find.
I have searched Mitchell ProDemand and internet and was not able to locate a Technical Service Bulletin or DIY for a solution.

I only located a TSB for F series vehicles that refered to boden cable routing
( the cable that connects from the mechanical handle to the locking mechanism). There was a recommended change in the way the attachment clip for the cable was causing a cable binding at low temperature (37 degrees).

Hope someone locates a solution.
Appreciate 0
      12-30-2015, 12:43 PM   #15
tam099
New Member
4
Rep
24
Posts

Drives: 2011 E93
Join Date: Aug 2014
Location: United States

iTrader: (0)

Same thing with my car. Had it fixed under warranty. Working perfectly now!
Appreciate 0
      01-06-2016, 07:33 AM   #16
tagta3
Enlisted Member
12
Rep
41
Posts

Drives: E90 M3
Join Date: Aug 2015
Location: MA

iTrader: (0)

Quote:
Originally Posted by tam099 View Post
Same thing with my car. Had it fixed under warranty. Working perfectly now!
Do you know exactly what they fixed or parts replaced?
Appreciate 0
      01-13-2016, 12:26 AM   #17
W Cole
Major
104
Rep
1,118
Posts

Drives: 2009 M3
Join Date: Dec 2010
Location: Newport Coast, CA

iTrader: (5)

Quote:
Originally Posted by tagta3 View Post
Do you know exactly what they fixed or parts replaced?
Mine was doing this. They replaced the door actuator which fixed the problem.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:25 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST