BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      10-05-2015, 03:06 PM   #1
XxMerlinxX
Private First Class
XxMerlinxX's Avatar
28
Rep
187
Posts

Drives: '08 E92 M3
Join Date: Aug 2015
Location: Greenville, S.C.

iTrader: (0)

Car Died, Pulled The Following Codes

Yesterday, while coming home from work, my car died while making a right hand turn. I pulled into the median and took notice of some error messages displayed on my nav screen. It had something to do with the fuel pump and then once I turned the car off, and restarted it, that message was replaced with one about increased emissions.

I was able to limp it home and pulled the following codes.

U0109 Lost Communication With Fuel Pump Control Module
P0192 Fuel Rail Pressure Sensor Low Input
U0109 again
P0192 again
P0301 Cylinder 1 Misfire Detected
P0302 Cylinder 2 Misfire Detected
P0303 Cylinder 3 Misfire Detected
P0300 Random Misfire Detected

My thought process is that the FP control module went bad, making the pump lose pressure which started the misfires and put it into limp mode.

The car's got about 37k miles on it and is an '08 E92. I have not restarted the car, but I'm considering trying to limp it to BMW as it's not far from here.

I've done a search for the U0109 code and haven't found anything. Has anyone else had any experience with this?
Appreciate 0
      10-05-2015, 05:35 PM   #2
XxMerlinxX
Private First Class
XxMerlinxX's Avatar
28
Rep
187
Posts

Drives: '08 E92 M3
Join Date: Aug 2015
Location: Greenville, S.C.

iTrader: (0)

Just cleared the codes and drove it again. Drove fine for the first 2-3 minutes, then got the same codes before it completely died again, seemingly of fuel starvation. I've ordered the FP controle module, hopefully that will take care of the problem.
Appreciate 0
      10-08-2015, 05:43 PM   #3
XxMerlinxX
Private First Class
XxMerlinxX's Avatar
28
Rep
187
Posts

Drives: '08 E92 M3
Join Date: Aug 2015
Location: Greenville, S.C.

iTrader: (0)

Alright, so for anyone following along or who researches these codes in the future, I'll give a brief update.

The fuel pump control module seems to have done the trick. Evidently it had to be coded, so the dealership got me there, to the tune of $303. On the plus side, my car had the original software from '08 and it has all of the newest software now.

Also, even though the dealership swears that they didn't add any oil, I'm now getting an oil too high reading. When confronted, the dealership said nothing was added and that it will probably go away by tomorrow. Oh, and the tech also said that our crankcase has plenty of extra room for extra oil.... Right.

Anyway, time will tell as to whether or not this actually fixed the problem. *fingers crossed*
Appreciate 0
      10-30-2015, 08:41 PM   #4
Oakleyguy
Resident Engineer
Oakleyguy's Avatar
United_States
125
Rep
771
Posts

Drives: Land Cruiser
Join Date: Oct 2008
Location: Denver, CO / Tulsa, OK

iTrader: (0)

Garage List
2014 Toyota URJ200  [0.00]
2017 BMW M2  [0.00]
2015 BMW M4  [5.00]
2005 Toyota UZJ100  [0.00]
Keep us posted!
__________________
///M4 (SO/BLK/BLK) Exec, LED, Blk 19s, HK, 6MT <- SOLD
///M2 (LBB), Exec, 6MT <- SOLD
2014 Land Cruiser, Slee Sliders, OME Lift, ARB Onboard Air
European Delivery Journal & F8X Door Rattle Fix
Machine Shop Directory - www.mfgcenter.com
Appreciate 0
      11-01-2015, 08:59 AM   #5
trustbran
Lieutenant
trustbran's Avatar
309
Rep
470
Posts

Drives: 2009 M3
Join Date: Sep 2015
Location: Guam, Hawaii, SF

iTrader: (2)

Yes please keep us posted.

-Brandon
Appreciate 0
      11-10-2015, 01:15 AM   #6
Yvette
Major General
Canada
678
Rep
7,385
Posts

Drives: M
Join Date: Sep 2006
Location: Vancouver

iTrader: (18)

Update on this? What are the major difference from the latest software you got?
Appreciate 0
      11-15-2015, 08:33 AM   #7
GMWNashville
Colonel
United_States
165
Rep
2,365
Posts

Drives: 19 G05, 16 F80, 10 E70x5D
Join Date: Jan 2008
Location: Nashville, TN

iTrader: (2)

There is a test plan which can be performed for "oil level disturbed". Only some cars have the ability to have that done but I think m3's do. That should take care of the oil level issue after programming.
Appreciate 0
      11-27-2015, 12:28 AM   #8
XxMerlinxX
Private First Class
XxMerlinxX's Avatar
28
Rep
187
Posts

Drives: '08 E92 M3
Join Date: Aug 2015
Location: Greenville, S.C.

iTrader: (0)

Quote:
Originally Posted by e90sexion View Post
Update on this? What are the major difference from the latest software you got?
Gas mileage has gone up by about 1mpg. Can't say that I've noticed much of a difference otherwise.
Appreciate 0
      11-27-2015, 01:22 AM   #9
vsix
Lieutenant Colonel
vsix's Avatar
No_Country
575
Rep
1,612
Posts

Drives: M3 E92 sold, M4 F82
Join Date: Nov 2012
Location: ATL

iTrader: (0)

Quote:
Originally Posted by XxMerlinxX View Post
Just cleared the codes and drove it again. Drove fine for the first 2-3 minutes, then got the same codes before it completely died again, seemingly of fuel starvation. I've ordered the FP controle module, hopefully that will take care of the problem.
Merlin, since your car is so low mile + "old" definately some fuel rail/ line related issue's need to be considered.
That is alway's my concern, when I hear about "good kept, little to none driven" low miled vehicle's.
Hope you get this problem solved soon and as allready been said, please keep us updated!
Appreciate 0
      11-26-2021, 05:59 PM   #10
cb1
Lieutenant
52
Rep
409
Posts

Drives: e92 M3, e46 M3
Join Date: Jun 2011
Location: 91789

iTrader: (6)

Hey guys,

Need suggestions. Mine failed and got P0192 and misfires at cyls 1-7. Replaced the sensor with the newer version (silver).

The car is cranking but will not start.

Battery is fully charged.
Gas is a little over a quarter.
Fuel pump primes.
Fuel pump fuse is good.

Any other thing I can check?

Thanks.
Appreciate 0
      12-06-2021, 12:18 PM   #11
Vuu
Astronaut
Vuu's Avatar
237
Rep
487
Posts

Drives: E92 M3
Join Date: Nov 2018
Location: Orange County, CA

iTrader: (5)

Quote:
Originally Posted by cb1 View Post
Hey guys,

Need suggestions. Mine failed and got P0192 and misfires at cyls 1-7. Replaced the sensor with the newer version (silver).

The car is cranking but will not start.

Battery is fully charged.
Gas is a little over a quarter.
Fuel pump primes.
Fuel pump fuse is good.

Any other thing I can check?

Thanks.
Can you start it with a jump?
Hold old is the battery?
__________________
Instagram | @undisclosedm3
"Never think that you are above taking out the trash."
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:41 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST