BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
BPM
Post Reply
 
Thread Tools Search this Thread
      07-14-2019, 07:10 AM   #133
DOCTOR.Y
Eric_Y
Australia
59
Rep
439
Posts

Drives: 2016 340i, 2010 E92 M3
Join Date: Sep 2015
Location: Sydney

iTrader: (0)

Garage List
2010 M3 E92  [0.00]
Quote:
Originally Posted by SickJames10 View Post
So I'm having the same issue on my car, I read most of thread. I know this is an old thread. So I'm hoping someone by now found or pinpointed the issue.

I don't believe it has anything to do with oil. I was using Castrol before I switched to Liqui Moly and noise it still there. I noticed the ticking noise more as the weather got hotter. Also, I noticed the noise after I installed TMS test pipes and pulley. Not saying test pipes or pulley have anything to do it, I'm thinking maybe something may be loose. Once my car cools down, I'll take a look.
Did you find anything man?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:55 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST