BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      07-12-2019, 07:32 PM   #1
coneill
Enlisted Member
United_States
2
Rep
31
Posts

Drives: 2013 M3
Join Date: Feb 2018
Location: Royersford, PA

iTrader: (0)

Oil engine level reading jumped

I changed my oil last sunday and put 8.7L in. After warming up the oil level read just slightly over half. Now today after driving for 3-4 days I start it and after it warms up I get the >MAX on the reading.

Any idea whats going on? I can't see how I could have overfilled it and why suddenly the reading would jump up so high one day.

Last edited by coneill; 07-12-2019 at 08:21 PM..
Appreciate 0
      07-12-2019, 08:30 PM   #2
wfdeacon88
Captain
695
Rep
952
Posts

Drives: E90 M3
Join Date: Sep 2018
Location: Triad, NC

iTrader: (0)

Quote:
Originally Posted by coneill View Post
I changed my oil last sunday and put 8.7L in. After warming up the oil level read just slightly over half. Now today after driving for 3-4 days I start it and after it warms up I get the >MAX on the reading.

Any idea whats going on? I can't see how I could have overfilled it and why suddenly the reading would jump up so high one day.
Last time this happened to me (although it wasn't 3-4 days later)... I drove approximately 30-50 miles after the MAX message and it went away. I assumed oil was settling.

the odd thing is that my MAX message happened immediately after the oil change. I even took 1/2 a quart out... but after that, it went away 30-50 miles away.
Appreciate 1
      07-12-2019, 09:18 PM   #3
coneill
Enlisted Member
United_States
2
Rep
31
Posts

Drives: 2013 M3
Join Date: Feb 2018
Location: Royersford, PA

iTrader: (0)

wfdeacon88 Weird. Did you get any dings or warnings come on? I didn't get an exclamation on the dash or anything in iDrive. I just happened to have my cluster set to the oil level since I recently changed it and noticed it was > max on my way to work. it definitely concerned me it showed up a few days later. It's fluctuated a little bit between like 1/4 - 3/4 but its never gone from half to over max for me.

I think tomorrow i'll just let it come up to temp in my driveway and see what the level says. Maybe reset it a few times and let it get a fresh reading.
Appreciate 0
      07-13-2019, 07:44 AM   #4
coneill
Enlisted Member
United_States
2
Rep
31
Posts

Drives: 2013 M3
Join Date: Feb 2018
Location: Royersford, PA

iTrader: (0)

So I ran it again this morning just sitting in my driveway and it gave me the max warning again.

What's the best course here? I've seen guys take oil out from the oil filter housing. Others say drain the front sump (about 1L) or just drive it and see?.
Appreciate 0
      07-13-2019, 05:11 PM   #5
coneill
Enlisted Member
United_States
2
Rep
31
Posts

Drives: 2013 M3
Join Date: Feb 2018
Location: Royersford, PA

iTrader: (0)

So drained front sump. dropped about .75L from it. reset oil level. Now it reads a little under the second notch where max is. No more overfill warning.
Appreciate 0
      07-13-2019, 05:31 PM   #6
dparm
World's greatest HPDE driver
dparm's Avatar
United_States
2136
Rep
7,009
Posts

Drives: C7 Corvette Grand Sport
Join Date: Jun 2013
Location: Dallas, TX

iTrader: (1)

Quote:
Originally Posted by coneill View Post
I changed my oil last sunday and put 8.7L in. After warming up the oil level read just slightly over half. Now today after driving for 3-4 days I start it and after it warms up I get the >MAX on the reading.

Any idea whats going on? I can't see how I could have overfilled it and why suddenly the reading would jump up so high one day.
There's your mistake: putting 8.7L in from the start.
__________________
Now: 2017 Corvette Grand Sport
Past: 2011.5 M3 sedan ZCP
Appreciate 0
      07-20-2019, 08:10 PM   #7
2bits
Private
15
Rep
71
Posts

Drives: 09 M3 e90
Join Date: Sep 2009
Location: Seattle

iTrader: (1)

The first reading at half was wrong, not the max/full reading. 8.7 is correct. No guess work about it as long as you change the filter and fully drain. S65 takes the same amount of oil no matter who, when, or where itís changed.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:32 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST