BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 Marketplace > Vendor Comments/Review/Feedback Forum
 
BPM
Post Reply
 
Thread Tools Search this Thread
      11-03-2018, 11:01 AM   #1
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

ESSTUNING quality control is getting low and not caring about their customers anymore

I’m writing this as Esstuning used to have good quality control with good customer support but unfortunately that is not the case anymore. Here are the parts I bought from Esstuning in the last couple of years. E46 M3 Vt2-525 supercharger kit, E93 M3 Ecu tune, E93 M3 underdrive pulley kit, E93 M3 test pipes, E93 M3 Vt2-625 Supercharger kit.

My main problem with Esstuning started with VT2-625 supercharger kit for my E93 M3 when I purchased it and chose the option of the 7 Rib belt upgrade kit.

1) The kit was shipped to me missing the 7 rib belt upgrade option although I emailed them to make sure they don’t forget it and advised that I purchased the upgrade option. The upgrade option was shipped after I emailed them that it was missing.

2) After disassembling the car and starting to install the kit , I found out that they sent the wrong set of bolts that hold the supercharger bracket to the engine and the wrong set of bolts that hold the supercharger to the bracket, although before starting installation I emailed them to ask them about something in the kit and Mr.Asbjorn assured me that the kit contains everything for installation and to install the kit. After emailing them and I was extremely frustrated as the car was disassembled and I couldn’t complete the installation, they didn’t even apologize for this mistake and just told me “can you source the bolts locally (will refund you the bolts price!!!) or you want us to send you the right bolts”, I requested them to send the right bolts.

3) After installing the kit and going for the break in period , I heard a sound in the engine bay and went to check the engine bay to find that one of the idler pulleys supplied by them flew in my engine bay and luckily it didn’t damage the engine or other parts in the car when it flew in the engine bay , the idler pulley is two parts one metal part and the other part is the bearing, when they have put them together , they forgot to put the locking ring on both idler pulleys, at that incident I called Norway office and Mr.Hans advised that they can either send me new pulleys or I can return the kit but I have to talk to USA office as I purchased the kit from them , at that day I called Mr.Asbjorn in USA and he advised that they have a new staff member called Mike and he is the one responsible for all the mistakes that happened starting from sending the kit missing parts, the wrong bolt kit and ending with the pulley flying in the engine bay as he forgot to put the lock rings on both pulleys!!!! and also he advised that it is because this is a Gen 2 kit and its a new model and better than the old Gen 1 kit.

4) I had performance issues after all was installed and emailed them a couple of times , and called Mr.Hans and he advised me to make a boost leak test and I did and found a leak and fixed it but unfortunately after that I still had performance issues specially in third gear from the 5000 to 6500 RPM , I bought Bmw logger and logged the car and emailed them logs showing that the ignition is fluctuating in this area and asked them if it can be the tune but most of what Mr.Asbjorn was saying is that they sold more than 1800 units and they all perform good so the problem is in my car, I told them please check the logs and advise if I can check anything , they told me to change spark plugs again although the spark plugs were almost new and try new ignition coils, so I bought 8 new spark plugs and installed it and I bought 4 new ignition coils that I tried on both banks but problem still persisted , after that they advised me to put racing fuel and I bought ignite 114 racing fuel and have put 10% racing fuel on 98ron fuel and that also didn’t help, I called Mr.Asbjorn and I was explaining to him the problem he said ” I’m talking so either you listen or I’ll hang up”!!!!!!. Please be advised that this was only my second phone call with him and the first one was regarding their mistake when they supplied pulleys without the lock rings which could have made massive damage to my engine. He told me your car is modified from DCT to manual so we give zero support to any modified car although my car ran perfectly in track before the kit installation without any errors or any problems and here is a link for the car in Yas Marina circuit competing in time attack challenge (( https://www.youtube.com/watch?v=5hLfZ2yq6fg

)), finally He then told me put 50% ignite 114 racing fuel on 50% 98 RON fuel to test and this made my car performed extremely bad and got even a vanos error at that time.

Anyway I have dealt with esstuning for several years and I really can’t imagine how they have reached this level of low quality control and uncaring for their customers, they just want to sell the kits and not help their customers specially Mr.Asbjorn in USA , all what Mr.Asbjorn was interested to say is that he sold more than 1800 units and the problem is in my car and since it is modified from DCT to Manual so they give zero support according to their terms and conditions, maybe the performance issue is caused from my car but at least I expected them to try and help me throughout the problem and check the logs that show the problem and at least respect me when they are talking to me.

The amount of mistakes and defected parts they sent at the beginning costed me a lot of money and time and maybe the performance issue is from my car but at least they should respect their customers and talk to them in a better way. Mr.Hans tried to help and was respectful but on the other side in the USA office Mr.Asbjorn was completely unprofessional.

I have attached the email I sent him when I found out the bolts are wrong and couldn't complete installation and his reply.
Also attached some photos for the old pulley disassembled and the new pulley with the lock ring.

Name:  bearing after pulley flew in engine bay.JPG
Views: 886
Size:  334.9 KB

Name:  other pulley without the lock ring-.jpg
Views: 888
Size:  161.4 KB

Name:  pulley after getting in to two pieces-.jpg
Views: 880
Size:  194.6 KB

Name:  email to esstuning-.png
Views: 874
Size:  202.6 KB
Attached Images
 
Appreciate 2
      11-03-2018, 09:40 PM   #2
dozaiya
Captain
Taiwan
195
Rep
936
Posts

Drives: 2011 MW E92 M3
Join Date: Nov 2012
Location: Shanghai

iTrader: (1)

i get the same feeling when i request for my tune options
he just ignores a lot of my questions and just send me a tune file without any further explanation, it's fine when it's the right one, but i had asked for the cold start to be removed and it wasn't
Appreciate 0
      11-03-2018, 11:01 PM   #3
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

Quote:
Originally Posted by dozaiya View Post
i get the same feeling when i request for my tune options
he just ignores a lot of my questions and just send me a tune file without any further explanation, it's fine when it's the right one, but i had asked for the cold start to be removed and it wasn't
Almost same thing happened to me but for me I requested that cold start not to be removed but he removed it in the tune, I had to email them again so that he sends new files and I installed the new files. A couple of years back this company wasn‘t like this , when I purchased my supercharger kit for my E46 M3 , this company was a lot better, I really don‘t know what happened to them.
Appreciate 0
      11-05-2018, 01:17 PM   #4
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

An update for whats happening with ESStuning. I was contacted by Mr.Asbjorn and Mr.Hans in a conference call and they offered me to return the kit and get a full refund but I told them what guarantees do I get that you will send the full refund after you receive the kit. They advised that its their word and they can make a written document as a guarantee and they are a company from 25 years, but I'm not satisfied by this solution as to be honest I don't trust that they will refund my full amount after they receive the kit so I made a suggestion to them to take photos and videos of the kit and send it to them and they wire 50% to me then I ship the kit and I get my other 50% but they didn't approve on this suggestion. After that they were suggesting a third party company but I'm not approving. Unfortunately I lost trust after all what happened and I have been purchasing parts for years now from them so why should I have to fully trust them that they will full refund me my money when they receive the kit when they don't want even to trust me with 50% being wired before shipping the kit. I have already spent a lot of money in trying to fix the problems I faced with the kit and I didn't request anything for that so at least wiring me 50% as a guarantee would be the minimum to request from them.
Appreciate 0
      11-05-2018, 05:48 PM   #5
Ervin87
Second Lieutenant
United_States
54
Rep
248
Posts

Drives: E92 M3 | B5 S4 | E30
Join Date: Aug 2012
Location: Santa Clara, CA

iTrader: (5)

I would take them up on their offer and return the kit. If they are willing to sign a document even better. ESS has been around for a long time. They have no reason to keep your money, as long as you ship it back. That is pretty standard policy with almost anything you purchase. Funds are refunded after the product is returned.
Appreciate 1
SYT_Shadow5963.00

      11-06-2018, 02:32 AM   #6
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

Quote:
Originally Posted by Ervin87 View Post
I would take them up on their offer and return the kit. If they are willing to sign a document even better. ESS has been around for a long time. They have no reason to keep your money, as long as you ship it back. That is pretty standard policy with almost anything you purchase. Funds are refunded after the product is returned.
Under normal situations I would have accepted to return the kit and then get my money but after how they dealt with me and the disrespect I have seen and how they ignored me sometimes, I wouldn’t proceed with a return except with good gaurantee to get my money . What if I ship it and then they say this is damaged or this is worn or this is scratched, I lost trust in this company and in the case even if they approve to what I requested I’ll make sure to send detailed photos of everything before and after packing so that I don’t get any execuses after shipping the product back but still I wouldn’t risk all the amount to get after they receive the kit.
Appreciate 0
      11-07-2018, 02:28 PM   #7
Iyzmi
Major
659
Rep
1,481
Posts

Drives: E92 M3 6MT ESS625
Join Date: Sep 2014
Location: Midwest

iTrader: (1)

Quote:
Originally Posted by dozaiya View Post
i get the same feeling when i request for my tune options
he just ignores a lot of my questions and just send me a tune file without any further explanation, it's fine when it's the right one, but i had asked for the cold start to be removed and it wasn't
Same here. I've emailed AJ on a few occasions and he frequently ignores my questions or provides incomplete answers. I've never spoken with him on the phone but have felt an arrogant condescending tone in much of our email correspondence. It's quite a shame really, as I still believe ESS has the best supercharger kit and software on the market all things considered. Things seemed to start falling apart in terms of customer service after Roman left. Huge loss for ESS and even bigger loss for their customers.

OP, have you had your car tested on a dyno to see how much power you are missing? Can you describe the issue in 3rd gear between 5-6.5k RPM in more detail?

You may also want to consider posting this in the engine sub-section. More people will see it there and might be able to help diagnose your performance issues. ESS is not a vendor here and I don't think the vendor review section gets much traffic.
__________________

Last edited by Iyzmi; 11-07-2018 at 02:53 PM..
Appreciate 0
      11-08-2018, 07:43 PM   #8
kawasaki00
Lieutenant Colonel
kawasaki00's Avatar
United_States
218
Rep
1,675
Posts

Drives: SG-E92 ESS-650 BPM Tune
Join Date: May 2012
Location: Charlotte NC

iTrader: (11)

Either that is the wrong clip or it is in upside down or the groove is not machined correctly. Furthermore it has been installed and looks like it ran backwards at some point.
On top of that those clips are junk. They should not be used in a high rpm spinning pulley.
These are the correct clips for that application. https://www.mcmaster.com/catalog/124/3380 either the single turn or heavy duty
__________________
Electronics Junkie, Engine Builder.
Appreciate 0
      11-11-2018, 06:01 AM   #9
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

Quote:
Originally Posted by Iyzmi View Post
Same here. I've emailed AJ on a few occasions and he frequently ignores my questions or provides incomplete answers. I've never spoken with him on the phone but have felt an arrogant condescending tone in much of our email correspondence. It's quite a shame really, as I still believe ESS has the best supercharger kit and software on the market all things considered. Things seemed to start falling apart in terms of customer service after Roman left. Huge loss for ESS and even bigger loss for their customers.

OP, have you had your car tested on a dyno to see how much power you are missing? Can you describe the issue in 3rd gear between 5-6.5k RPM in more detail?

You may also want to consider posting this in the engine sub-section. More people will see it there and might be able to help diagnose your performance issues. ESS is not a vendor here and I don't think the vendor review section gets much traffic.
Thank you for your support. The problem in 3rd gear is that at around 5000 rpm the ignition drops to 13 and with the increase in the rpm at wide open throttle the car increases and decreases ignition several times which cause the car to hesitate and shake so it goes for example to 15.7 5200 rpm and back to 13 at 5400 and then back to 16 at 5600 and then at 6000 it can be 15 and then after 6500 rpm the problem is not there anymore and the car keeps climbing in ignition to 20 at 8300 rpm. In 4 th gear this hesistation is not there but the ignition is 13.7 at 5000 rpm also and keeps climbing to 20 ignition at 8300 rpm but I feel the car is weak. If anyone has this kit vt2-625 or any similar supercharger kit I‘d really appreciate it if they can send me their log to see fuel pulse and ignition timing. One other remark I found in the log is that the fuel pressure goes up and down in the rpm 5000 to 6500 . It can be 81.6 psi at 5000 rpm and then 75.8 psi at 5400 and then 87 psi at 5546 rpm. I can‘t confirm if this loss in pressure is caused by the ecu pushing back or fuel pressure is just dropping. I think normally the pressure of the fuel should keep climbing with the increase of rpm.
Appreciate 0
      11-11-2018, 06:04 AM   #10
ibrahimm3
New Member
6
Rep
9
Posts

Drives: E93 M3
Join Date: Jan 2017
Location: Dubai, United Arab emirates

iTrader: (0)

Quote:
Originally Posted by kawasaki00 View Post
Either that is the wrong clip or it is in upside down or the groove is not machined correctly. Furthermore it has been installed and looks like it ran backwards at some point.
On top of that those clips are junk. They should not be used in a high rpm spinning pulley.
These are the correct clips for that application. https://www.mcmaster.com/catalog/124/3380 either the single turn or heavy duty
In the first delivery they forgot to put the clips, it is not that the clip jumped or anything it was totally forgotten to be put in the first place . The photo with the clip are the new pulleys I received with the clips installed and untill now ,it is working fine.
Appreciate 0
      11-11-2018, 08:17 AM   #11
eatsleepboost
Captain
eatsleepboost's Avatar
403
Rep
660
Posts

Drives: Evo
Join Date: Aug 2017
Location: Boston

iTrader: (1)

Quote:
Originally Posted by dozaiya View Post
i get the same feeling when i request for my tune options
he just ignores a lot of my questions and just send me a tune file without any further explanation, it's fine when it's the right one, but i had asked for the cold start to be removed and it wasn't
+3. Same thing happened to me.i have never spent more money on a car part in my life so I was not happy with this to say the least. My car has been together for a few thousand miles and runs excellent however so I'm happy with that.
Appreciate 0
      06-28-2020, 04:08 AM   #12
gnjax
New Member
11
Rep
28
Posts

Drives: E92 M3
Join Date: Aug 2019
Location: France

iTrader: (0)

Thanks for the feedback.
I had a similar experience with asbjorn, not really professionnal and he clearly doesn't like to admit when they make a mistake. My upgrade kits was also missing a few parts. Made a whole thread about it actually.
Appreciate 0
Post Reply

Bookmarks

Tags
bad customer service, bad customer support, bad quality control, esstuning, quality control, supercharger kit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:43 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST