Bimmerpost for Android has just been updated to version 4.3.55 with a host of bug fixes. Try it out!
BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      12-24-2017, 08:53 PM   #1
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Reduced Power...Again.

took the car out, 2011 e90 m3 on the canyons, day went by without a hitch... till i filled up (.9 miles from home) and started the car. had the DSC, ABS, Increased Emissions, lights came on. m3gasm says its actuator.

Odd thing is when i drove home is that it automatically shifts up and down even when in Manual Mode. i have no control of the transmission. It has trouble idling, accelerating and decelerating.

i have yet to read the codes, but i think its TB's, has anyone experienced the part having no control on the transmission?
Appreciate 0
      12-24-2017, 08:56 PM   #2
obe100
First Lieutenant
obe100's Avatar
United_States
154
Rep
366
Posts

Drives: on the weekends…
Join Date: Sep 2011
Location: Planet Earth

iTrader: (1)

..
Appreciate 0
      12-24-2017, 08:58 PM   #3
1MOREMOD
2018 track days - 0 ridge 1:52:24 pacific 1:33:30
1MOREMOD's Avatar
United_States
6152
Rep
19,208
Posts

Drives: Race car->
Join Date: Mar 2009
Location: check your mirrors

iTrader: (5)

Viagra
Appreciate 0
      12-24-2017, 09:02 PM   #4
JsL
Captain
United_States
297
Rep
969
Posts

Drives: 2011 AW M3 ZCP VF620
Join Date: Dec 2013
Location: SF Bay Area

iTrader: (2)

Sucks... But read codes first, then post the codes.
No one can help without them.
Appreciate 0
      12-26-2017, 01:43 PM   #5
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by obe100 View Post
..
has anyone experienced the part having no control on the transmission?

im really only asking about that part.
Appreciate 0
      12-26-2017, 03:15 PM   #6
Rainer M
Private First Class
United_States
34
Rep
117
Posts

Drives: E93 M3
Join Date: Jun 2015
Location: Santa Rosa, CA

iTrader: (0)

Quote:
Originally Posted by ato///M3 View Post
Quote:
Originally Posted by obe100 View Post
..
has anyone experienced the part having no control on the transmission?

im really only asking about that part.
About a month ago you tried to flash the dct and failed.

Did you keep trying?
What happened, did you succeed?

Looks like your car has plenty of codes thrown the last few month. Any solutions for those previous errors?
The tb can cause all kind of codes it seems and so can a battery / alternator issue.

And no, the tb do not interfere with the dct directly.

But who knows what the car is doing when they go bad, perhaps wants to stay in a certain rpm range?
Appreciate 0
      12-26-2017, 09:18 PM   #7
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by Rainer M View Post
About a month ago you tried to flash the dct and failed.

Did you keep trying?
What happened, did you succeed?

Looks like your car has plenty of codes thrown the last few month. Any solutions for those previous errors?
The tb can cause all kind of codes it seems and so can a battery / alternator issue.

And no, the tb do not interfere with the dct directly.

But who knows what the car is doing when they go bad, perhaps wants to stay in a certain rpm range?
i didn't flash the car at all, just try to do a cold run of WinKFP (winkfp was not plugged in to the car)

changed the spark plugs of the car, it solved the previous reduced power Problems.
i totally that the alternator might be bad, however, car seems to be keeping 12V, when off and ~14V when running. i also thought that car was shifting by itself to keep within an RPM target.
Appreciate 0
      12-26-2017, 09:19 PM   #8
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

2AFD
2B27 1634
2B57
2B5B
2796
2B28 161D
2B5C
2B35 301
2B36 302
2B37 0303
2B38 0304
2B39 0305
2B3A 0306
2B41 0300
2B42
2B43
2B44
2B45
2B46
2B47
2B4E

are the codes that INPA gave me.
Appreciate 0
      12-26-2017, 09:50 PM   #9
///M Power-Belgium
Major General
///M Power-Belgium's Avatar
Belgium
18213
Rep
9,862
Posts

Drives: ///M3-DCT- E92 Silverstone II
Join Date: Jul 2012
Location: Belgium

iTrader: (0)

Quote:
Originally Posted by ato///M3 View Post
2AFD
2B27 1634
2B57
2B5B
2796
2B28 161D
2B5C
2B35 301
2B36 302
2B37 0303
2B38 0304
2B39 0305
2B3A 0306
2B41 0300
2B42
2B43
2B44
2B45
2B46
2B47
2B4E

are the codes that INPA gave me.
Here you go => http://www.m3post.com/forums/showthread.php?t=928325
__________________
BPM DEV-Tune & DCT software update & Servotronic & coding///Alpine HID Angeleyes///Oem.exhaust mod.
Appreciate 0
      12-28-2017, 05:33 AM   #10
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

update: cleared the codes and left the car for like 3 days. started the car and took it for a spin around the block 3x when I arrive at the stop sign, car idled really rough, bouncing from 450-750. came back home, and sure enough, it threw a bunch of codes and went limp mode again. its not the old codes this time. Now it is 279D and 2B0D & 2B57

Last edited by ato///M3; 12-28-2017 at 06:09 AM.
Appreciate 0
      12-28-2017, 06:09 AM   #11
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

another update:
cleared codes and adaptations, took the car for a spin around the block, same thing. started to idle badly and went in to limp mode and threw these codes this time
2b39
2b3a
2b3b
2b57
2796
2b38
2b37
2b35
Appreciate 0
      01-19-2018, 01:12 PM   #12
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

another update:
removed the actuators, found that the swing arm takes a lot of force to open
proceed with opening both throttle actuators found that both actuators have been previously rebuilt. they were rebuilt with the brass and delrin or Teflon gears. the brass gear was binding to the shaft of the housing.
Appreciate 0
      02-07-2018, 11:19 AM   #13
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

FIXED

It was the Throttle Actuator, I got Away with just rebuilding mine
Appreciate 0
      02-07-2018, 12:05 PM   #14
dreamspeed
Lieutenant Colonel
dreamspeed's Avatar
United_States
191
Rep
1,620
Posts

Drives: 6MT
Join Date: Jul 2012
Location: Los Angeles

iTrader: (0)

Glad it worked out.
__________________
Appreciate 0
      02-07-2018, 12:17 PM   #15
ato///M3
Private
United_States
24
Rep
65
Posts

Drives: E46 M3 ZCP & E90 M3 ZCP
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by dreamspeed View Post
Glad it worked out.
more mod money for me
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:10 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST