BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
BPM
Post Reply
 
Thread Tools Search this Thread
      08-30-2020, 11:59 AM   #1255
WeekendV8
New Member
Canada
2
Rep
6
Posts

Drives: 2009 E90 M3
Join Date: Jun 2020
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by HGreen335 View Post
Is there separate links for the v1, v2, etc? I don't see any indication on the aliexpress webpages for the Kremersino
I want to know the same thing. I just see one option on aliexpress.

Also, anyone know if this Kremersino unit is the same as Bimmertech's (3x the price)?
Appreciate 0
      08-30-2020, 06:20 PM   #1256
Cyberdemon
Colonel
Cyberdemon's Avatar
785
Rep
2,508
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by WeekendV8 View Post
I want to know the same thing. I just see one option on aliexpress.

Also, anyone know if this Kremersino unit is the same as Bimmertech's (3x the price)?
Does not seem to be. It might all be the same OEM but slightly different kit? I imagine thereís only so many factories in China spitting these out and BimmerTech bought one of those with slightly more time in figuring out the wiring harnesses. Based on the V1, V2, V3 it seems like these come off the line fairly frequently.

Iím considering just waiting for Black Friday it seems like the BimmerTech at least has the best customer support and least headaches but waiting for more buyers to chime in.
Appreciate 0
      09-01-2020, 01:29 AM   #1257
tonylukes
New Member
tonylukes's Avatar
United_States
33
Rep
27
Posts

Drives: 2011 e93 M3
Join Date: Jun 2015
Location: SW Florida

iTrader: (0)

I just installed the Bimmer-tech MMI Prime in my dad's '14 650i coupe. It's really nice, very easy install (similar to our e9x's except I didn't have to run anything up through the A pillar for the mic). Quality of the kit was great, and so far the sound quality seems very good for running via the aux input. It's wireless and connects very fast. I'm going to go this route for my '11 e93, either Black Friday or Christmas time. Not driving it enough right now to justify but it's on my to-do list :-)
Appreciate 2
      09-01-2020, 10:08 AM   #1258
Cyberdemon
Colonel
Cyberdemon's Avatar
785
Rep
2,508
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by tonylukes View Post
I just installed the Bimmer-tech MMI Prime in my dad's '14 650i coupe. It's really nice, very easy install (similar to our e9x's except I didn't have to run anything up through the A pillar for the mic). Quality of the kit was great, and so far the sound quality seems very good for running via the aux input. It's wireless and connects very fast. I'm going to go this route for my '11 e93, either Black Friday or Christmas time. Not driving it enough right now to justify but it's on my to-do list :-)
Good to hear, I feel like the Bimmertech seems to have the least complaints and easiest integration with a rear view cam rather than trying to source multiple parts and then sitting there trying to figure out which pins or software update you need to get things to work. At the end of the day time is money, so I'd rather splurge a few extra hundred for that piece of mind and customer support.

I'm in the same boat, if they have a black Friday sale I'll live with the Tune2Air adapter for the limited amount I'm driving and then do this over the holidays.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 1
      09-01-2020, 10:10 AM   #1259
tonylukes
New Member
tonylukes's Avatar
United_States
33
Rep
27
Posts

Drives: 2011 e93 M3
Join Date: Jun 2015
Location: SW Florida

iTrader: (0)

Quote:
Originally Posted by Cyberdemon View Post
Quote:
Originally Posted by tonylukes View Post
I just installed the Bimmer-tech MMI Prime in my dad's '14 650i coupe. It's really nice, very easy install (similar to our e9x's except I didn't have to run anything up through the A pillar for the mic). Quality of the kit was great, and so far the sound quality seems very good for running via the aux input. It's wireless and connects very fast. I'm going to go this route for my '11 e93, either Black Friday or Christmas time. Not driving it enough right now to justify but it's on my to-do list :-)
Good to hear, I feel like the Bimmertech seems to have the least complaints and easiest integration with a rear view cam rather than trying to source multiple parts and then sitting there trying to figure out which pins or software update you need to get things to work. At the end of the day time is money, so I'd rather splurge a few extra hundred for that piece of mind and customer support.

I'm in the same boat, if they have a black Friday sale I'll live with the Tune2Air adapter for the limited amount I'm driving and then do this over the holidays.
Yeah same here, I don't mind spending more on a true plug n play device. The hardest part was finding a space to stash the MMI box, the rest was very easy especially the connectors.
Appreciate 0
      09-01-2020, 11:59 AM   #1260
derbo
Derbo Tuning
derbo's Avatar
United_States
1779
Rep
1,860
Posts

Drives: 2011 M3
Join Date: Aug 2017
Location: ▆▆▆ ▆▆▆ ▆

iTrader: (0)

Quote:
Originally Posted by tonylukes View Post
Yeah same here, I don't mind spending more on a true plug n play device. The hardest part was finding a space to stash the MMI box, the rest was very easy especially the connectors.
This is where I put my box. It's a nice location.

__________________
-Derek
IG: @ruhrohz_m3
Journal
Appreciate 1
      09-01-2020, 12:23 PM   #1261
smass
Major
299
Rep
1,427
Posts

Drives: BMWs with 3L I6 engines
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Garage List
2009 E70 X35d  [0.00]
2016 F15 35i  [0.00]
2003 E53 3.0  [0.00]
2006 E90 325i  [0.00]
2006 E90 330i  [0.00]
2012 E88 128i  [0.00]
If you pull the cupholders and glove box, there is an area just to the right of the CIC where the box fits.
Appreciate 0
      09-02-2020, 02:15 PM   #1262
noah.s
Lieutenant
88
Rep
433
Posts

Drives: 2011 335i M-Sport
Join Date: Oct 2015
Location: FL

iTrader: (0)

So I have the V2 unit and I've read you can do audio through bluetooth (combox). Right now I've been setting the source to the combox bluetooth on my phone, is that the correct way to do it? Or is it done through the kremersino unit itself?
Appreciate 0
      09-02-2020, 02:22 PM   #1263
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by noah.s View Post
So I have the V2 unit and I've read you can do audio through bluetooth (combox). Right now I've been setting the source to the combox bluetooth on my phone, is that the correct way to do it? Or is it done through the kremersino unit itself?
Yes, and in the BMW source list (on the factory BMW system), select your phone's bluetooth audio connection (instead of AUX In). You don't set anything specific to this in the kremersino unit itself.
Appreciate 0
      09-02-2020, 02:50 PM   #1264
noah.s
Lieutenant
88
Rep
433
Posts

Drives: 2011 335i M-Sport
Join Date: Oct 2015
Location: FL

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
Yes, and in the BMW source list (on the factory BMW system), select your phone's bluetooth audio connection (instead of AUX In). You don't set anything specific to this in the kremersino unit itself.
Ok, appreciate it! That's what I figured. Having some small issues like the steering wheel controls are being buggy but that might be due to iOS 14. I will try and skip to the next song and it will skip but kick right back to the previous song and restart it.
Appreciate 0
      09-02-2020, 04:36 PM   #1265
bighindu79
Private First Class
bighindu79's Avatar
14
Rep
130
Posts

Drives: E93 M3 Jerez Black/Fox Red bla
Join Date: Oct 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by noah.s View Post
Quote:
Originally Posted by brettcp View Post
Yes, and in the BMW source list (on the factory BMW system), select your phone's bluetooth audio connection (instead of AUX In). You don't set anything specific to this in the kremersino unit itself.
Ok, appreciate it! That's what I figured. Having some small issues like the steering wheel controls are being buggy but that might be due to iOS 14. I will try and skip to the next song and it will skip but kick right back to the previous song and restart it.
I am waiting for my v2 to arrive and will be getting into the install hopefully soon. I plan on trying to use the Bluetooth connection as well and will be watching your posts closely. Brettcp's experience has been very helpful in answering a lot of my questions. Did you still run the aux cable and plug it in as an option to easily switch to that source if the Bluetooth connection becomes too unreliable?
__________________
Current: E93 M3 DCT/Jerez Black/Fox Red-Black
Gone: E93 M3 DCT/Alpine White/Fox Red/Premium/Enhanced sound/Convenience Pkg.
ED: 10/04/2010
Appreciate 0
      09-02-2020, 06:05 PM   #1266
derbo
Derbo Tuning
derbo's Avatar
United_States
1779
Rep
1,860
Posts

Drives: 2011 M3
Join Date: Aug 2017
Location: ▆▆▆ ▆▆▆ ▆

iTrader: (0)

Quote:
Originally Posted by bighindu79 View Post
I am waiting for my v2 to arrive and will be getting into the install hopefully soon. I plan on trying to use the Bluetooth connection as well and will be watching your posts closely. Brettcp's experience has been very helpful in answering a lot of my questions. Did you still run the aux cable and plug it in as an option to easily switch to that source if the Bluetooth connection becomes too unreliable?
I personally gave up on the Bluetooth connection as it was unreliable switching over the connection from Carplay Audio to Combox BT audio consistently. Since switching over to AUX for input, its been solid. Hell even Phone calls using the Carplay side sounds better than the Combox BT.
__________________
-Derek
IG: @ruhrohz_m3
Journal
Appreciate 1
      09-02-2020, 07:15 PM   #1267
noah.s
Lieutenant
88
Rep
433
Posts

Drives: 2011 335i M-Sport
Join Date: Oct 2015
Location: FL

iTrader: (0)

Quote:
Originally Posted by bighindu79 View Post
I am waiting for my v2 to arrive and will be getting into the install hopefully soon. I plan on trying to use the Bluetooth connection as well and will be watching your posts closely. Brettcp's experience has been very helpful in answering a lot of my questions. Did you still run the aux cable and plug it in as an option to easily switch to that source if the Bluetooth connection becomes too unreliable?
Yes I ran it and have tried both. Even with tweaking the AUX quality it noticeable worse. Wondering if I shouldíve gotten the V3 with the DSP and just used AUX. The Bluetooth sounds great but like others have said you will be missing all sounds other than music, and say I trigger Siri it will switch to CarPlay audio source and youíll have the manually switch it back.
Appreciate 0
      09-02-2020, 08:02 PM   #1268
bighindu79
Private First Class
bighindu79's Avatar
14
Rep
130
Posts

Drives: E93 M3 Jerez Black/Fox Red bla
Join Date: Oct 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by noah.s View Post
Quote:
Originally Posted by bighindu79 View Post
I am waiting for my v2 to arrive and will be getting into the install hopefully soon. I plan on trying to use the Bluetooth connection as well and will be watching your posts closely. Brettcp's experience has been very helpful in answering a lot of my questions. Did you still run the aux cable and plug it in as an option to easily switch to that source if the Bluetooth connection becomes too unreliable?
Yes I ran it and have tried both. Even with tweaking the AUX quality it noticeable worse. Wondering if I should’ve gotten the V3 with the DSP and just used AUX. The Bluetooth sounds great but like others have said you will be missing all sounds other than music, and say I trigger Siri it will switch to CarPlay audio source and you’ll have the manually switch it back.
Thanks for the feedback. For sounds from Waze and google maps, have you tried setting the sound settings to "Play as Bluetooth phone call" to see if you get sound? Not sure if this setting is available in Apple Maps but it is there in waze and google maps.
__________________
Current: E93 M3 DCT/Jerez Black/Fox Red-Black
Gone: E93 M3 DCT/Alpine White/Fox Red/Premium/Enhanced sound/Convenience Pkg.
ED: 10/04/2010
Appreciate 0
      09-02-2020, 08:25 PM   #1269
noah.s
Lieutenant
88
Rep
433
Posts

Drives: 2011 335i M-Sport
Join Date: Oct 2015
Location: FL

iTrader: (0)

Quote:
Originally Posted by bighindu79 View Post
Thanks for the feedback. For sounds from Waze and google maps, have you tried setting the sound settings to "Play as Bluetooth phone call" to see if you get sound? Not sure if this setting is available in Apple Maps but it is there in waze and google maps.
I actually havenít, I remember seeing some pages back that it didnít work. Iím also having some screen retention issues, some UI elements stay on the screen for a couple minutes after it changes.
Appreciate 0
      09-02-2020, 09:18 PM   #1270
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by derbo View Post
Hell even Phone calls using the Carplay side sounds better than the Combox BT.
I noticed this as well.. I was experiencing poor BT call quality with my iPhone (11 pro max), a bit garbled/static sounding. Lots of iPhone users are reporting the same issue when using a recent iPhone model with an E9x BMW - tons of posts on the Apple forums, several on E90post as well.

After installing the carplay unit, the call quality issues went away completely and calls all sounded great.

I only realized this after removing the carplay unit a couple of weeks ago when the quality went back to being poor.
Appreciate 0
      09-02-2020, 10:05 PM   #1271
bighindu79
Private First Class
bighindu79's Avatar
14
Rep
130
Posts

Drives: E93 M3 Jerez Black/Fox Red bla
Join Date: Oct 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
Quote:
Originally Posted by derbo View Post
Hell even Phone calls using the Carplay side sounds better than the Combox BT.
I noticed this as well.. I was experiencing poor BT call quality with my iPhone (11 pro max), a bit garbled/static sounding. Lots of iPhone users are reporting the same issue when using a recent iPhone model with an E9x BMW - tons of posts on the Apple forums, several on E90post as well.

After installing the carplay unit, the call quality issues went away completely and calls all sounded great.

I only realized this after removing the carplay unit a couple of weeks ago when the quality went back to being poor.
have you applied the latest tx and mx update for e9x? I believe the bin file is named upd10008.bin when you download it from bmw's connected drive site. I had similar issues with the factory Bluetooth call quality and those went away after I applied this update.
__________________
Current: E93 M3 DCT/Jerez Black/Fox Red-Black
Gone: E93 M3 DCT/Alpine White/Fox Red/Premium/Enhanced sound/Convenience Pkg.
ED: 10/04/2010
Appreciate 0
      09-03-2020, 12:01 AM   #1272
derbo
Derbo Tuning
derbo's Avatar
United_States
1779
Rep
1,860
Posts

Drives: 2011 M3
Join Date: Aug 2017
Location: ▆▆▆ ▆▆▆ ▆

iTrader: (0)

Quote:
Originally Posted by bighindu79 View Post
have you applied the latest tx and mx update for e9x? I believe the bin file is named upd10008.bin when you download it from bmw's connected drive site. I had similar issues with the factory Bluetooth call quality and those went away after I applied this update.
It's been reported to still have issues after this update.
__________________
-Derek
IG: @ruhrohz_m3
Journal
Appreciate 0
      09-03-2020, 03:19 PM   #1273
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by bighindu79 View Post
have you applied the latest tx and mx update for e9x? I believe the bin file is named upd10008.bin when you download it from bmw's connected drive site. I had similar issues with the factory Bluetooth call quality and those went away after I applied this update.
Yes I have.. no change. Don't know if BMW will ever resolve it, not sure they're updating E9x software anymore.
Appreciate 0
      09-08-2020, 08:31 PM   #1274
noah.s
Lieutenant
88
Rep
433
Posts

Drives: 2011 335i M-Sport
Join Date: Oct 2015
Location: FL

iTrader: (0)

So I saw a few pages back that Version 2 is not compatible with AHD cameras, although the Aliexpress page says it is. Can anyone confirm?

Edit: So I actually bought an AHD1080P camera which I don't think is compatible. I can switch it to CVBS though so I'll try that. Well CVBS didnít work. Wonder what I did wrong or is anyone else not getting video from their camera?

Last edited by noah.s; 09-08-2020 at 09:56 PM..
Appreciate 0
      09-09-2020, 11:00 AM   #1275
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by noah.s View Post
So I saw a few pages back that Version 2 is not compatible with AHD cameras, although the Aliexpress page says it is. Can anyone confirm?

Edit: So I actually bought an AHD1080P camera which I don't think is compatible. I can switch it to CVBS though so I'll try that. Well CVBS didnít work. Wonder what I did wrong or is anyone else not getting video from their camera?
When I got my V2 unit, I had tried to get my aftermarket reverse camera working with it (I'd previously been using an emulator and using it as a factory BMW backup camera, worked great). I worked with Michael from Kremersino, and he even sent me a video clip of him wiring his up on a bench and it clearly worked with his camera, but not with the camera I had. Tried the different camera type settings as well. I suspect they're using a specific camera - I believe they actually sell BMW E9x backup cameras as well on their aliexpress store.

In the end I just continued using my backup camera via the factory setup - within the carplay settings, you can set the backup camera to "Factory" and it auto switches over to the BMW factory backup screen/camera when you put the car in reverse, then automatically switches back to the carplay screen when you take it out of reverse. Worked great.
Appreciate 0
      09-09-2020, 11:33 AM   #1276
derbo
Derbo Tuning
derbo's Avatar
United_States
1779
Rep
1,860
Posts

Drives: 2011 M3
Join Date: Aug 2017
Location: ▆▆▆ ▆▆▆ ▆

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
When I got my V2 unit, I had tried to get my aftermarket reverse camera working with it (I'd previously been using an emulator and using it as a factory BMW backup camera, worked great). I worked with Michael from Kremersino, and he even sent me a video clip of him wiring his up on a bench and it clearly worked with his camera, but not with the camera I had. Tried the different camera type settings as well. I suspect they're using a specific camera - I believe they actually sell BMW E9x backup cameras as well on their aliexpress store.

In the end I just continued using my backup camera via the factory setup - within the carplay settings, you can set the backup camera to "Factory" and it auto switches over to the BMW factory backup screen/camera when you put the car in reverse, then automatically switches back to the carplay screen when you take it out of reverse. Worked great.
Hey brettcp do you have access to BMW diagnostics software? I checked my car for a separate error for a failed wheel speed sensor and I noticed the CIC, MOST, CID all had errors for communication. When I ran a normal OBD scan reader (BimmerLink App), I didn't see the errors. How interesting! I do not believe I had these errors with the V2 old harness, and I did have them with the V1 module.
__________________
-Derek
IG: @ruhrohz_m3
Journal
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:29 AM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST