BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      09-02-2016, 06:27 PM   #1
matte
New Member
2
Rep
27
Posts

Drives: 2008 M3 Coupe
Join Date: May 2014
Location: Canada

iTrader: (0)

Triangle, Bluetooth drops calls e92 m3 08'

e92 M3 2008
Happened with Samsung s5, s6 edge, and now s7 edge. More frequently over time.

Have had this issue over last two years, since I got the car.

It's not an idrive, and has the professional audio system.

Basically you can be on a call and all of a sudden bluetooth drops it seems, and a triangle appears in the place of the phone symbol. Without power cycling the car, you can't reconnect. Happens completely randomly.

It's an 08, so I can't seem to download a update from the bmw website.

Oddly, it will let my bluetooth ad2p adapter stream music to the ipod aux in, but phone won't reconnect. So seems specific to the bluetooth/phone function. Can't re-pair either.

Anyone have any suggestions. I don't want to replace the same old crappy stereo, and I also don't want to put 2k into a pioneer android auto deck atm.
Appreciate 0
      09-03-2016, 12:33 AM   #2
6ixSpd
Save the manuals!
6ixSpd's Avatar
Canada
5270
Rep
6,288
Posts

Drives: '12 M3 6MT
Join Date: Feb 2016
Location: 416

iTrader: (4)

Not sure on what the exact cause is, but worst case scenario it sounds like your TCU is on its way out. Not expensive to replace - maybe a couple hundred bucks or so for a used one off eBay and you can swap it in yourself in 20 mins.

Edit: come to think of it, I believe I have one laying around after my 335i's Combox retrofit.
__________________
'12 M3 6MT Alpine White + Fox Red Extended

@tailor.mad3
Appreciate 0
      09-15-2016, 09:35 PM   #3
matte
New Member
2
Rep
27
Posts

Drives: 2008 M3 Coupe
Join Date: May 2014
Location: Canada

iTrader: (0)

Just doing a bit of reading, perhaps that is the case, sorry for late reply, didn't get notification of a reply.

Just looking a bit, if I don't have nav, is there any reason to upgrade the TCU to combox or am I totally off base here. Not sure what it is, but i see lots of people upgrading it...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:42 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST