BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
EXXEL Distributions
Post Reply
 
Thread Tools Search this Thread
      09-13-2019, 01:37 PM   #573
PACarGuy
Captain
PACarGuy's Avatar
United_States
298
Rep
627
Posts

Drives: 2012 E92 M3 DCT ZCP
Join Date: Nov 2015
Location: Philly burbs, PA

iTrader: (1)

Garage List
Quote:
Originally Posted by derbo View Post
I finally updated like the rest of you. No real change. Going to tell Michael this is terrible.
Yeah, calls are unusable. I also started having issues with wireless connection occasionally too - would drop connection or be laggy so I switched to wired carplay only and that actually works better for me. And when I am on a call on my Airpods (bluetooth) and then get into my car, now the box actually will connect to CarPlay, whereas with wireless it waits until the call is over to connect to Carplay because bluetooth is in use.
__________________
2012 E92 M3 | ZCP | DCT | Space Grey Metallic | Black Novillo | BE Bearings | CF Rear Spoiler, Diffuser, Front Splitters | Black grill + side gills | DTEC 160W Angel Eyes
Appreciate 0
      09-13-2019, 01:48 PM   #574
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

I also noticed my Apple Maps does not turn to night mode.

Waze and Google work fine.


I'm on iOS 13 Beta..but that shouldn't affect it as it works in my Civic.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 0
      09-14-2019, 12:40 AM   #575
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

Just to confirm with the folks with the Kremersino one,

In ACP, does your ACP have a BMW logo with a BMW title underneath it? Originally, I thought I updated correctly, and it was showing Limecet Logo, Limecet text. After doing it correctly, it shows BMW/BMW.

Wrongly updated:


Updated correctly:



I've been chatting with Michael the sales guy and said the new units will be using the wired carplay PCB board with a revision to adopt for Wireless ACP. I'm going to swap my brother's JoyeAuto wired ACP only (Kremersino produced) module into my car with the existing wiring as they are the same minus PCB revisions with cheaper components to see if the quality of the streaming audio improves. I can confirm my brother's module sounds better in his E90D which has the same 676 HiFi as my car but to rule out everything, I'll swap the modules tomorrow for testing. I believe the better audio quality will follow the wired module vs the wireless module.

Current wireless ACP module:
I'm noticing alerts from Waze or Google are full of static, and audio in the music is not clear as well. It's basically piss poor for even the stock HiFi.
Phone calls are poor with the unit as well as others have expressed.
Apple Maps seems to stay in day mode, but Waze/google maps seem to be okay.


Anyways, I'll keep you guys updated.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS

Last edited by derbo; 09-14-2019 at 12:48 AM..
Appreciate 0
      09-14-2019, 12:58 AM   #576
MJBO
Lieutenant
MJBO's Avatar
Australia
295
Rep
436
Posts

Drives: 2011 M3 E90 DCT
Join Date: May 2012
Location: Australia

iTrader: (0)

Quote:
Originally Posted by derbo View Post
Just to confirm with the folks with the Kremersino one,

In ACP, does your ACP have a BMW logo with a BMW title underneath it? Originally, I thought I updated correctly, and it was showing Limecet Logo, Limecet text. After doing it correctly, it shows BMW/BMW.
What do you mean by updated correctly?

Mine originally showed BMW text on the CP screen, but pretty sure it doesn't now after the updates.

As for audio quality, mines only ever been flat, not crackly.
Appreciate 0
      09-14-2019, 10:54 AM   #577
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by MJBO View Post
Quote:
Originally Posted by derbo View Post
Just to confirm with the folks with the Kremersino one,

In ACP, does your ACP have a BMW logo with a BMW title underneath it? Originally, I thought I updated correctly, and it was showing Limecet Logo, Limecet text. After doing it correctly, it shows BMW/BMW.
What do you mean by updated correctly?

Mine originally showed BMW text on the CP screen, but pretty sure it doesn't now after the updates.

As for audio quality, mines only ever been flat, not crackly.
I guess the update process isn't fully complete until the logo says bmw and is a bmw rounded in the logo.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 0
      09-14-2019, 04:05 PM   #578
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

This morning, I swapped my brother's JoyeAuto (made by Kremersino) wired ACP module into my M3. I only swapped the module itself and left all the wiring the same since it is the same wiring as our Kremersino wireless ACP module.

The wired ACP module restored audio quality to an acceptable level with lots of bass. I was unable to test the phone calls but I suspect that will still be poor.

This definitely confirms the wireless module PCB hardware is the issue and we will need new units to get this fixed. I contacted Micheal with this information to see what the next steps are. It currently is Autumm Festival in China (think asian thanksgiving) and I believe they are all on holidays till October.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 1
PACarGuy297.50

      09-14-2019, 05:19 PM   #579
brettcp
First Lieutenant
United_States
93
Rep
331
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by derbo View Post
This morning, I swapped my brother's JoyeAuto (made by Kremersino) wired ACP module into my M3. I only swapped the module itself and left all the wiring the same since it is the same wiring as our Kremersino wireless ACP module.

The wired ACP module restored audio quality to an acceptable level with lots of bass. I was unable to test the phone calls but I suspect that will still be poor.

This definitely confirms the wireless module PCB hardware is the issue and we will need new units to get this fixed. I contacted Micheal with this information to see what the next steps are. It currently is Autumm Festival in China (think asian thanksgiving) and I believe they are all on holidays till October.
Thanks for your testing and for keeping us posted.. looks like I'll be waiting until they revise these units before placing an order..

Still wondering about the Unichip version and if will exhibit similar issues.. they claim its not the same as the joyeauto/kremesino units.
Appreciate 0
      09-16-2019, 05:42 PM   #580
luckyse7en
Private First Class
55
Rep
168
Posts

Drives: 2013 BMW E92 M3 ZCP
Join Date: May 2013
Location: Oregon

iTrader: (0)

Quote:
Originally Posted by PACarGuy View Post
Are you getting full bass in streaming audio as well? Because even when I used wired (USB) Carplay, the bass is lacking. If the Joyeauto box has better bass then clearly it is processing it differently than the Kremersino unit and may be incentive enough to switch.
Sorry for the late reply. I've been super MIA from the forums.

As you guys already have figured out from derbo's testing. Yeah my wired unit has decent bass. Sound is clear and very little drop in quality over OEM bluetooth streaming. Playing around with the EQ in idrive and also my spotify app I was able to get nice audio. I have the premium individual audio package (S752A).

Hope you guys get to do an exchange after they revise the hardware. It really is a great product if it is working correctly. Good luck.
__________________
2013 Alpine White E92 M3 ZCP - IND Paint Matched Reflectors
Appreciate 1
PACarGuy297.50

      09-17-2019, 10:17 PM   #581
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
Thanks for your testing and for keeping us posted.. looks like I'll be waiting until they revise these units before placing an order..

Still wondering about the Unichip version and if will exhibit similar issues.. they claim its not the same as the joyeauto/kremesino units.
No problem!

Just to be specific, the wired Joyauto is a Kremersino unit without wireless capability.
The new Joyeauto wireless is the same unit as the BimmerRetrofit unit.
Unichip is an unknown one as well.

So from what I can tell, there are 3 different types of units at the moment.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 0
      09-18-2019, 06:50 PM   #582
MJBO
Lieutenant
MJBO's Avatar
Australia
295
Rep
436
Posts

Drives: 2011 M3 E90 DCT
Join Date: May 2012
Location: Australia

iTrader: (0)

I messaged Michael last night asking for updates, and he sent through a new file to try. Also reiterated this thing about the update not being complete without the BMW logo appearing in CarPlay, honestly not sure how to make that happen.

Hope to try the new update today, if the BMW logo doesn't appear I might try running it a second time in succession and see if that helps.
Appreciate 0
      09-19-2019, 12:27 AM   #583
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by MJBO View Post
I messaged Michael last night asking for updates, and he sent through a new file to try. Also reiterated this thing about the update not being complete without the BMW logo appearing in CarPlay, honestly not sure how to make that happen.

Hope to try the new update today, if the BMW logo doesn't appear I might try running it a second time in succession and see if that helps.
Micheal said to stick the USB in, let it update twice, unplug the USB then select the right button in the message and it should reboot without the USB plugged in to finish the update.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 0
      09-19-2019, 01:13 AM   #584
MJBO
Lieutenant
MJBO's Avatar
Australia
295
Rep
436
Posts

Drives: 2011 M3 E90 DCT
Join Date: May 2012
Location: Australia

iTrader: (0)

Heh, got to give the update a go before seeing your message. Not quite sure what mix of things I did to finally get it there, but I now have a BMW icon on my CarPlay screen again.

Audio still sucks (flat with no bass, but not crackly like others have reported), will have to see how the connection reliability fairs.
Appreciate 0
      09-19-2019, 11:24 PM   #585
krazi3azn
First Lieutenant
krazi3azn's Avatar
Canada
46
Rep
350
Posts

Drives: 135i
Join Date: Dec 2013
Location: Canada

iTrader: (3)

Garage List
2009 BMW 135i  [0.00]
So I just bought one couple days ago and installed it. Music sounds okay. Michael reassured me I had the better chip (from the old wired one)

I have not kept up with the thread, so how can I check itís the old chip and what kind of sound issues did you guys experneice?
Appreciate 0
      Yesterday, 06:25 PM   #586
brettcp
First Lieutenant
United_States
93
Rep
331
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by krazi3azn View Post
So I just bought one couple days ago and installed it. Music sounds okay. Michael reassured me I had the better chip (from the old wired one)

I have not kept up with the thread, so how can I check itís the old chip and what kind of sound issues did you guys experneice?
That's interesting they were able to revise the hardware so quickly... I'd be curious how you can verify this as well.
Appreciate 0
      Yesterday, 08:23 PM   #587
derbo
Keeper of Blinky Lights
derbo's Avatar
United_States
1000
Rep
1,181
Posts

Drives: Beluga Whale
Join Date: Aug 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
Quote:
Originally Posted by krazi3azn View Post
So I just bought one couple days ago and installed it. Music sounds okay. Michael reassured me I had the better chip (from the old wired one)

I have not kept up with the thread, so how can I check it’s the old chip and what kind of sound issues did you guys experneice?
That's interesting they were able to revise the hardware so quickly... I'd be curious how you can verify this as well.
The "revised" wireless PCB would be reusing the old wired version PCB. That doesn't seem to require too much work considering its an older design. Michael said it uses more expensive components. Their cost reduction PCB in the wireless version is definitely subpar compared to the one in the wired one.
__________________
-Derek
IG: @ruhrohz_m3
E90 OEM+| MCS | BBS
Appreciate 0
      Today, 01:30 AM   #588
MJBO
Lieutenant
MJBO's Avatar
Australia
295
Rep
436
Posts

Drives: 2011 M3 E90 DCT
Join Date: May 2012
Location: Australia

iTrader: (0)

Quote:
Originally Posted by krazi3azn View Post
So I just bought one couple days ago and installed it. Music sounds okay. Michael reassured me I had the better chip (from the old wired one)

I have not kept up with the thread, so how can I check it’s the old chip and what kind of sound issues did you guys experneice?
For starters could take a photo of the system info screen to see how the software details are different from those of us with the crap unit?

I'm yet again back to using mine in wired mode with music streaming over factory BMW bluetooth.
Appreciate 0
      Today, 01:59 PM   #589
krazi3azn
First Lieutenant
krazi3azn's Avatar
Canada
46
Rep
350
Posts

Drives: 135i
Join Date: Dec 2013
Location: Canada

iTrader: (3)

Garage List
2009 BMW 135i  [0.00]
Update - the carplay sounds just like regular aux and has bass. Doesn't sound flat like other members are experiencing.

That being said, aux in these cars suck to begin with. Went on amazon and got a Aux ground isolator and made it 10x better. Overall I love this system. Also installed a rear view camera.
Attached Images
  
__________________
2009 135i SGM 6MT | Vargas Stage 2 | JB4 + MHD Backend | Spec Stage 3+ | AR Design Resonated DP | HPF FMIC | BMW PE | KW V1 | Apex Arc-8 245/265 |
Appreciate 0
      Today, 03:06 PM   #590
Fede16
New Member
Fede16's Avatar
Argentina
2
Rep
5
Posts

Drives: bmw 135 and 328
Join Date: Oct 2018
Location: Argentina

iTrader: (0)

Some of you could scan the car with the ISTA or INPA to see what failures you had?

If anyone has them I would thank them too much!

I uploaded mine in a previous post.
Thank you!
Appreciate 0
      Today, 03:41 PM   #591
akkando
Brigadier General
2640
Rep
3,600
Posts

Drives: 2017 M2 LBB DCT
Join Date: Jan 2017
Location: Bay Area

iTrader: (1)

I've read through I think every post in this thread and I'm trying to understand the state of things.

Let me know if I have this correct.

Most people are getting the wireless Kremersino unit because it's slightly cheaper, but they're not happy with the audio quality. Bass problems and maybe some audio dropping out.

The Joyaudio unit has the same audio problems as the Kremersino and has basically same features, but costs sightly more.

Unichip also makes a wireless box but no one has it, and no one knows how it compares to the other units or if it even works at all.

The wired versions have better audio quality currently, but Kremersino claims to be looking into updating the hardware on the wireless to have better audio, but the parts are more expensive.


Is the correct state of things?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:32 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST