BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
EXXEL Distributions
Post Reply
 
Thread Tools Search this Thread
      05-05-2018, 07:35 AM   #1
lagos e92 m3
New Member
lagos e92 m3's Avatar
Nigeria
0
Rep
6
Posts

Drives: white 2009 e92 M3
Join Date: May 2018
Location: lagos Nigeria

iTrader: (0)

Garage List
2009 bmw  [0.00]
No Error Messages, Temporary Limping

Please my car seems to temporarily limp when i drive slow at speeds of 20-30mph between 2nd and 3rd gears. Even when i kick down it doesn't accelerate. Its a bit dangerous and this scares me at times when the car isn't able to accelerate properly. How ever i have found some sort of solution which includes me turning off the ignition or pressing the M power button. Please what can i do?
Appreciate 0
      05-07-2018, 05:06 PM   #2
premo
M3
premo's Avatar
United_States
39
Rep
199
Posts

Drives: E92 ///M3 Jerez Black
Join Date: Apr 2014
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by lagos e92 m3 View Post
Please my car seems to temporarily limp when i drive slow at speeds of 20-30mph between 2nd and 3rd gears. Even when i kick down it doesn't accelerate. Its a bit dangerous and this scares me at times when the car isn't able to accelerate properly. How ever i have found some sort of solution which includes me turning off the ignition or pressing the M power button. Please what can i do?
Read out the codes. It could be: a bad spark plug, coil pack, or throttle body actuators....

Find a scanner and read it out first. The above listed issue are all very common problems.
__________________
Appreciate 0
      06-08-2018, 05:29 AM   #3
lagos e92 m3
New Member
lagos e92 m3's Avatar
Nigeria
0
Rep
6
Posts

Drives: white 2009 e92 M3
Join Date: May 2018
Location: lagos Nigeria

iTrader: (0)

Garage List
2009 bmw  [0.00]
New Error codes

please what do these codes mean.

10212 plausibility vacuum pump mastervac (HEX) 27E4

P2098 POST CATALYST FUEL TRIM SYSTEM TOO LEAN BANK 2

10134 AUX TRANS FLUID PMP CTRL CKT

10183 LAMBDA SENSOR AD DIAGNOSIS TRIM CONTROL BANK 2
HEX(27C7) INTERMITTENT

10134 ENG. EMERG. PROGRAM ACTIVATED (HEX)2796

11095 ENG. EMERG. ACTIVATED (HEX)2B57

AFTER CHANGING MY ACTUATORS MY CAR WENT INTO LIMP MODE AGAIN. ALTHOUGH THIS CLEARS WHEN I RESTART, I PUT A SCANNER ON I GOT THESE CODES AGAIN
Appreciate 0
      07-21-2019, 12:18 AM   #4
blacklisted.m3
New Member
0
Rep
9
Posts

Drives: E92 M3
Join Date: Jan 2019
Location: NEW YORK

iTrader: (0)

did u ever find a solution to this?
Appreciate 0
      07-21-2019, 07:01 AM   #5
Dpc2u
Lieutenant
Dpc2u's Avatar
United_States
312
Rep
452
Posts

Drives: 2011 E93 M3
Join Date: Feb 2019
Location: Tennessee

iTrader: (0)

The 27e4 indicates an issue with the secondary vaccum pump for the brake booster. That can be a bad pump, bad vacuum sensor, or vacuum leak in one of the booster lines. The accompanying lean codes could result from that issue if indeed there is a vacuum leak which is introducing more air into the engine. 1st thing, do you hear the vacuum pump running a lot, especially after hitting the brake pedal? It will be a humming of an electric pump coming from the area of the master cylinder, driver fender well area.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:08 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST