BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Mporium BMW
Post Reply
 
Thread Tools Search this Thread
      04-03-2021, 01:06 PM   #1
gagan23
New Member
United_States
1
Rep
15
Posts

Drives: 2012 BMW M3 / 2011 Nissan GTR
Join Date: Jan 2014
Location: New Jersey

iTrader: (0)

Bavsound Ghost subs not working

My oem subs stopped working so i replaced them with the Bavsound subs, which worked for almost a year up until yesterday when they suddenly went out and I heard no bass coming from the system.

Im not sure if the subs are bad or if the AMP is bad cause weirdly the passenger side sub goes in/out sometimes but the driver side is completely out.
Appreciate 0
      04-07-2021, 01:08 PM   #2
jimmsters
New Member
2
Rep
7
Posts

Drives: '16 xDrive28d, M-Sport, LEDs
Join Date: Oct 2015
Location: Newport News, VA

iTrader: (0)

Reach out to Bavsound. I am on my third set now, getting a little annoyed, but they keep honoring the warranty. I would rather find out what is causing this though.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:00 AM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST