BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      01-14-2020, 06:44 PM   #1
KawBoy
Lieutenant
United_States
99
Rep
467
Posts

Drives: M
Join Date: May 2012
Location: SE FL

iTrader: (2)

iPhone 11 BT not working fine - '12 E92

Hello Everyone,

Ever since I've got the iPhone 11, I could never had it working fine with the BT system. It only shows my address book (full), and a couple of received and placed calls.
The main issue however, is that the voice quality (in/out) is terrible, to the point that I have the BT disabled. I checked the firmware version and it looks like I have the latest, dated back when iPhone 5 and 6 were released.

I have deleted/disabled-add/enable iPhone and BT several times, but no luck.

Have you guys experienced this? Any help would be highly appreciated.

Brgds.
Appreciate 0
      01-14-2020, 07:37 PM   #2
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Same here, sometimes the quality is fine, other times its terrible and I just have to pick up the phone and not use bluetooth for a call. Do a google search on it, there are hundreds of posts about it on Apple's support forums - seems to be an issue with recent versions of iOS. Hopefully Apple will fix it.
Appreciate 1
KawBoy98.50

      01-14-2020, 09:07 PM   #3
KawBoy
Lieutenant
United_States
99
Rep
467
Posts

Drives: M
Join Date: May 2012
Location: SE FL

iTrader: (2)

It looks like it is a known problem. Thanks for the reply.
Appreciate 0
      01-15-2020, 08:19 AM   #4
doogee
Major
doogee's Avatar
Canada
692
Rep
1,242
Posts

Drives: '08 M3, '97 328is
Join Date: Oct 2008
Location: Ancaster, ON, Canada

iTrader: (0)

Interesting. Music be an issue specifically with CIC/Combox.

I have NBT and have had no issues.
__________________
Appreciate 0
      01-15-2020, 04:34 PM   #5
brettcp
Lieutenant
United_States
187
Rep
539
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by KawBoy View Post
It looks like it is a known problem. Thanks for the reply.
If you come across any solutions, please let me know!
Appreciate 0
      01-16-2020, 08:36 PM   #6
KawBoy
Lieutenant
United_States
99
Rep
467
Posts

Drives: M
Join Date: May 2012
Location: SE FL

iTrader: (2)

Quote:
Originally Posted by brettcp View Post
If you come across any solutions, please let me know!
Sure will!
Appreciate 0
      03-10-2020, 01:56 AM   #7
Scrippy
Lord Scrip
Scrippy's Avatar
United_States
1040
Rep
2,360
Posts

Drives: 2011 M3 Coupe
Join Date: Jan 2012
Location: LA,Ca

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
Have you loaded the latest update 1008? I only have the iPhone 10x and no issues in my 2011 build, so I'm not sure if this is an 11 only issue or what. Try this url and I put in your VIN.... https://www.bmw.com/en/footer/software-updates.html. Like I said 1008 is the last update created and if you don't have it load it.
__________________
Appreciate 1
KawBoy98.50

      03-10-2020, 05:01 PM   #8
KawBoy
Lieutenant
United_States
99
Rep
467
Posts

Drives: M
Join Date: May 2012
Location: SE FL

iTrader: (2)

Yes, that's the one I am currently running. It is like 4 or 6 years old (iirc) and it worked fine for iPhone 6.
I am just not using BT anymore; pretty much not using the cell while driving. Thanks for the thought though.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:43 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST