BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
BPM
Post Reply
 
Thread Tools Search this Thread
      11-18-2020, 08:02 PM   #1497
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

I screwed something up on mine by trying to switch from carplay to airplay (Wanted to see if I could stream football). Never got Airplay working and now the unit doesn't seem to like auto detecting when I get in the car (but works fine when I pick it from bluetooth).

Might just need to disconnect and re-pair the whole thing but clearly switching between the two is not easy or pleasant.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-21-2020, 04:52 AM   #1498
admator
New Member
Slovakia
0
Rep
5
Posts

Drives: 06 E60
Join Date: Sep 2020
Location: Slovakia

iTrader: (0)

Carplay Buzzing

Hello,

I have successfully installed and functional CarPlay from Andream in my E60 2006 with CIC and L7. Everything works. But I'm solving one last problem. When I turn on the key, I hear the buzzing. At higher volumes, it's pretty annoying. The buzzing can only be heard through Carplay AUX. If I turn on the AUX directly from the phone, the buzzer will disappear.

Question1: Do you have any ideas on how to remove the buzz?

Question2: Is there any Carplay from other manufacturer that allows you to pair audio with Combox BT? (I have it too)

Thanks a lot!
Appreciate 0
      11-21-2020, 11:37 AM   #1499
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by admator View Post
Hello,

I have successfully installed and functional CarPlay from Andream in my E60 2006 with CIC and L7. Everything works. But I'm solving one last problem. When I turn on the key, I hear the buzzing. At higher volumes, it's pretty annoying. The buzzing can only be heard through Carplay AUX. If I turn on the AUX directly from the phone, the buzzer will disappear.

Question1: Do you have any ideas on how to remove the buzz?

Question2: Is there any Carplay from other manufacturer that allows you to pair audio with Combox BT? (I have it too)

Thanks a lot!
Check the output volume on the Carplay unit and the Aux volume on the CIC. Theres a chance of interference from somewhere else in the system but make sure those volumes both aren't maxxed out. Then see if it reduces or eliminates the buzz.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-21-2020, 02:35 PM   #1500
danzio2020
Private
19
Rep
66
Posts

Drives: X6M
Join Date: Aug 2013
Location: Canada

iTrader: (0)

Quote:
Originally Posted by cannyjock View Post
Success! I've managed to code the headunit to use the aux input from the harness using Bimmercode. This is using the Carsara box. The values I changed were:

CDMM_AUX_HU
aktiv

CDMM_USB_AUDIO_SINGLE
nicht_aktiv

CDMM_USB_AUDIO_DOUBLE_0B
nicht_aktiv

@Cyberdemon I tried to code it with the can cable as it is - this didn't work, the app couldn't connect to the headunit module. I then wired in the iDrive harness, connecting it to the can high cable (not sure if this really matters) and I could then code it.

It was a little tricky to route the cable from under the front of the gearstick, down to the drivers footwell and back up into the headunit area but it worked - the Bimmertech video helped again.

The sound seems better than via the aux cable, with bass in particular better defined. I need to spend more time playing with the EQ and try some direct comparisons but so far so good.

I still have Bluetooth streaming via the Combox working which was one concern raised earlier.

The only (very minor) negative is that when the system starts up there doesn't seem to be any sound, until I switch to aux again - however this is very easy as I have a shortcut button set up for it (the row of numbered buttons on the CIC headunit) and just press this then it's OK. It seems that the aux in volume stays as 0 unless I do this. Doesn't really bother me.

BTW - never coded the BMW before, Bimmercode (£30) and a cheap (£20) vGate adapter was very easy to use. Only issue I had was that it wouldn't seem to connect to the car, then I tried starting the engine and it worked OK then. Seems easier than using a laptop with cable, and gives some easy shortcut options in addition to 'expert' coding.
Thanks that worked perfect with my RoadTop/CarSara box. No need to run an aux cord with those parameters coded!

If not using the iDrive controller cable you’ll need to disconnect the CAN headunit from the CAN carplay plug and add put the little CAN loop to the headunit CAN plug.
Appreciate 0
      11-23-2020, 07:45 AM   #1501
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by danzio2020 View Post
Quote:
Originally Posted by cannyjock View Post
Success! I've managed to code the headunit to use the aux input from the harness using Bimmercode. This is using the Carsara box. The values I changed were:

CDMM_AUX_HU
aktiv

CDMM_USB_AUDIO_SINGLE
nicht_aktiv

CDMM_USB_AUDIO_DOUBLE_0B
nicht_aktiv

@Cyberdemon I tried to code it with the can cable as it is - this didn't work, the app couldn't connect to the headunit module. I then wired in the iDrive harness, connecting it to the can high cable (not sure if this really matters) and I could then code it.

It was a little tricky to route the cable from under the front of the gearstick, down to the drivers footwell and back up into the headunit area but it worked - the Bimmertech video helped again.

The sound seems better than via the aux cable, with bass in particular better defined. I need to spend more time playing with the EQ and try some direct comparisons but so far so good.

I still have Bluetooth streaming via the Combox working which was one concern raised earlier.

The only (very minor) negative is that when the system starts up there doesn't seem to be any sound, until I switch to aux again - however this is very easy as I have a shortcut button set up for it (the row of numbered buttons on the CIC headunit) and just press this then it's OK. It seems that the aux in volume stays as 0 unless I do this. Doesn't really bother me.

BTW - never coded the BMW before, Bimmercode (£30) and a cheap (£20) vGate adapter was very easy to use. Only issue I had was that it wouldn't seem to connect to the car, then I tried starting the engine and it worked OK then. Seems easier than using a laptop with cable, and gives some easy shortcut options in addition to 'expert' coding.
Thanks that worked perfect with my RoadTop/CarSara box. No need to run an aux cord with those parameters coded!

If not using the iDrive controller cable you'll need to disconnect the CAN headunit from the CAN carplay plug and add put the little CAN loop to the headunit CAN plug.
Did you get it to code without the IDrive extension cable just by using the white loop to terminate the connection instead of hooking it to the can at all? I didn't quite understand the comment.

How do you guys feel about the audio quality going through the HU now?

I picked up a cable for coding but haven't had any time to tear the interior apart again.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-23-2020, 11:03 AM   #1502
cannyjock
Private
39
Rep
81
Posts

Drives: BMW e90 M3
Join Date: Nov 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by Cyberdemon View Post
Did you get it to code without the IDrive extension cable just by using the white loop to terminate the connection instead of hooking it to the can at all? I didn't quite understand the comment.

How do you guys feel about the audio quality going through the HU now?

I picked up a cable for coding but haven't had any time to tear the interior apart again.
I'm happier with the audio quality now - I would give it 8 out of 10 compared to other sources, although I haven't done too much testing. I've set the EQ back to standard now and the bass is decent.

You could try just replacing the loop first to try coding like that, if it doesn't work then try the separate cable option?
Appreciate 0
      11-23-2020, 02:20 PM   #1503
e92335drew
New Member
0
Rep
21
Posts

Drives: 335 e92
Join Date: Nov 2020
Location: Toronto

iTrader: (0)

https://www.aliexpress.com/item/4000...archweb201603_

Is this the carsara link that everyone is recommending? It's on sale for black friday and I'm thinking of finally pulling the trigger after trying to do research on how well these actually run.

Im in an 09 e92 without combox, so i'm already running a USB powered bluetooth thats plugged into the aux. The sound from that is actually pretty good, so I assume that this will be the same with the Carsara unit.

The one item I was always wondering about, is making sure that I don't need to wire up a new microphone as the factory unit works great. If i can wire into an aux at the back of the factory unit that would be lovely, and have protool to code.
Appreciate 0
      11-23-2020, 02:36 PM   #1504
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by e92335drew View Post
https://www.aliexpress.com/item/4000...archweb201603_

Is this the carsara link that everyone is recommending? It's on sale for black friday and I'm thinking of finally pulling the trigger after trying to do research on how well these actually run.

Im in an 09 e92 without combox, so i'm already running a USB powered bluetooth thats plugged into the aux. The sound from that is actually pretty good, so I assume that this will be the same with the Carsara unit.

The one item I was always wondering about, is making sure that I don't need to wire up a new microphone as the factory unit works great. If i can wire into an aux at the back of the factory unit that would be lovely, and have protool to code.
Yes that is the unit. As discussed above, it sounds like you can code to get aux directly through the HU cable which is slightly better than running it through the 3.5mm jack. (I'll have to test that when I have free time), but generally, I'm OK with the audio quality even using the aux 3.5mm, and if it can improve, great.

You don't need a new microphone, the kit includes a pigtail which runs up your A pillar and spilts the signal for you. I tried making several calls and quality seemed great, no concerns at all.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-23-2020, 05:02 PM   #1505
GTiceman
Parrothead
GTiceman's Avatar
98
Rep
1,204
Posts

Drives: E90 M3
Join Date: Jul 2010
Location: Tampa

iTrader: (5)

Garage List
2009 BMW M3  [0.00]
Quote:
Originally Posted by Cyberdemon View Post
Yes that is the unit. As discussed above, it sounds like you can code to get aux directly through the HU cable which is slightly better than running it through the 3.5mm jack. (I'll have to test that when I have free time), but generally, I'm OK with the audio quality even using the aux 3.5mm, and if it can improve, great.

You don't need a new microphone, the kit includes a pigtail which runs up your A pillar and spilts the signal for you. I tried making several calls and quality seemed great, no concerns at all.
Thanks for confirming this unit. I just got my M and was going to hold off tearing it apart but I might jump on the sale. I hate pulling off the A pillar.

I retrofitted CiC into an 07 335 with no iDrive but messing with the M scares me!
__________________
|e46 M3 Stahlgrau/Red| - Sold
|E92 335i BSM/Saddle| - Sold
|e90 M3 Space Gray/Fox Red/6MT|
See Garage for Mods
Appreciate 0
      11-23-2020, 05:13 PM   #1506
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by GTiceman View Post
Quote:
Originally Posted by Cyberdemon View Post
Yes that is the unit. As discussed above, it sounds like you can code to get aux directly through the HU cable which is slightly better than running it through the 3.5mm jack. (I'll have to test that when I have free time), but generally, I'm OK with the audio quality even using the aux 3.5mm, and if it can improve, great.

You don't need a new microphone, the kit includes a pigtail which runs up your A pillar and spilts the signal for you. I tried making several calls and quality seemed great, no concerns at all.
Thanks for confirming this unit. I just got my M and was going to hold off tearing it apart but I might jump on the sale. I hate pulling off the A pillar.

I retrofitted CiC into an 07 335 with no iDrive but messing with the M scares me!
The A pillar was not bad just getting the little airbag badge off for me was a pain. A good thin guitar pick actually probably would've been perfect in hindsight. My regular trim tools were too thick.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-23-2020, 05:34 PM   #1507
e92335drew
New Member
0
Rep
21
Posts

Drives: 335 e92
Join Date: Nov 2020
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Cyberdemon View Post
Yes that is the unit. As discussed above, it sounds like you can code to get aux directly through the HU cable which is slightly better than running it through the 3.5mm jack. (I'll have to test that when I have free time), but generally, I'm OK with the audio quality even using the aux 3.5mm, and if it can improve, great.

You don't need a new microphone, the kit includes a pigtail which runs up your A pillar and spilts the signal for you. I tried making several calls and quality seemed great, no concerns at all.
Ah damn, you have to do all that! I was hoping it would just use the stock harness from the HU and work.
Appreciate 0
      11-23-2020, 05:49 PM   #1508
brettcp
Captain
United_States
234
Rep
600
Posts

Drives: 2012 E93 M3
Join Date: Mar 2011
Location: So Cal

iTrader: (2)

Looks like we'll be getting Waze on the carplay dashboard soon (instead of being forced to use Apple Maps):

https://www.theverge.com/2020/11/23/...ashboard-apple

Looking forward to this!
Appreciate 0
      11-23-2020, 05:56 PM   #1509
bighindu79
Private First Class
bighindu79's Avatar
United_States
26
Rep
182
Posts

Drives: E93 M3 Jerez Black/Fox Red bla
Join Date: Oct 2007
Location: CA

iTrader: (0)

Quote:
Originally Posted by brettcp View Post
Looks like we'll be getting Waze on the carplay dashboard soon (instead of being forced to use Apple Maps):

https://www.theverge.com/2020/11/23/...ashboard-apple

Looking forward to this!
Google maps introduced this feature in August. Since Google owns waze it was only a matter of time.
__________________
Current: E93 M3 DCT/Jerez Black/Fox Red-Black
Gone: E93 M3 DCT/Alpine White/Fox Red/Premium/Enhanced sound/Convenience Pkg.
ED: 10/04/2010
Appreciate 0
      11-23-2020, 06:00 PM   #1510
bighindu79
Private First Class
bighindu79's Avatar
United_States
26
Rep
182
Posts

Drives: E93 M3 Jerez Black/Fox Red bla
Join Date: Oct 2007
Location: CA

iTrader: (0)

Quote:
Originally Posted by cannyjock View Post
Quote:
Originally Posted by Cyberdemon View Post
Did you get it to code without the IDrive extension cable just by using the white loop to terminate the connection instead of hooking it to the can at all? I didn't quite understand the comment.

How do you guys feel about the audio quality going through the HU now?

I picked up a cable for coding but haven't had any time to tear the interior apart again.
I'm happier with the audio quality now - I would give it 8 out of 10 compared to other sources, although I haven't done too much testing. I've set the EQ back to standard now and the bass is decent.

You could try just replacing the loop first to try coding like that, if it doesn't work then try the separate cable option?
I'm a little confused about the wiring. I currently don't have the idrive pigtail installed. it didn't work for me when I first installed the carsara unit. I do want to be able to code. could you post a picture of how you have yours wired to allow coding?
__________________
Current: E93 M3 DCT/Jerez Black/Fox Red-Black
Gone: E93 M3 DCT/Alpine White/Fox Red/Premium/Enhanced sound/Convenience Pkg.
ED: 10/04/2010
Appreciate 0
      11-23-2020, 08:41 PM   #1511
Jonzny
First Lieutenant
76
Rep
334
Posts

Drives: 2011 E92 M3
Join Date: Feb 2016
Location: New York

iTrader: (0)

Hey, maybe someone knows the answer to this or maybe I am just doing it wrong.

Installed this back in June it has worked great for me using wireless Carplay.

Just sold my car, new owner has android- he can connect the bluetooth but the Wifi is asking for a password? I don't recall there being one when I set this up, if there is one does anyone know what it is?
Appreciate 0
      11-23-2020, 11:42 PM   #1512
icanturn
Private
icanturn's Avatar
United_States
18
Rep
99
Posts

Drives: e90 m3
Join Date: Apr 2016
Location: San Jose, CA

iTrader: (1)

is it asking for a PIN? Try 1111 or 0000
Appreciate 0
      11-24-2020, 06:20 AM   #1513
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by Jonzny View Post
Hey, maybe someone knows the answer to this or maybe I am just doing it wrong.

Installed this back in June it has worked great for me using wireless Carplay.

Just sold my car, new owner has android- he can connect the bluetooth but the Wifi is asking for a password? I don't recall there being one when I set this up, if there is one does anyone know what it is?
The head unit lists the WiFi password as 88888888 if that's needed for the android setup. I've only paired my iOS phone so far but might try my android device since my iPhone seems to get shit coverage lately.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      11-24-2020, 09:05 AM   #1514
GTiceman
Parrothead
GTiceman's Avatar
98
Rep
1,204
Posts

Drives: E90 M3
Join Date: Jul 2010
Location: Tampa

iTrader: (5)

Garage List
2009 BMW M3  [0.00]
Quote:
Originally Posted by Cyberdemon View Post
The A pillar was not bad just getting the little airbag badge off for me was a pain. A good thin guitar pick actually probably would've been perfect in hindsight. My regular trim tools were too thick.
My trim tools are pretty thick too. My other concern is this car is dead silent right now inside, no squeaks or rattles. I worry that one this trim is pulled it will never be the same.
__________________
|e46 M3 Stahlgrau/Red| - Sold
|E92 335i BSM/Saddle| - Sold
|e90 M3 Space Gray/Fox Red/6MT|
See Garage for Mods
Appreciate 0
      11-24-2020, 10:39 AM   #1515
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1302
Rep
3,099
Posts

Drives: 2020 X5 40i, 2011 E90 M3
Join Date: Jun 2012
Location: Long Island NY

iTrader: (1)

Quote:
Originally Posted by GTiceman View Post
My trim tools are pretty thick too. My other concern is this car is dead silent right now inside, no squeaks or rattles. I worry that one this trim is pulled it will never be the same.
I've done the A pillar on all 3 of my cars and never had an issue. First it's a "Soft" piece, usually rattles happen with the hard bits. The fact that it's covered with fabric keeps it quite tight.

The little cap that sticks on is held really secure by some metal tabs, nothing to rattle there either. Pretty low risk, just make sure the cable is dressed and zip tied snug. That would be the only thing that could possibly tap around when moving but I haven't noticed any obvious issues.

I definitely wouldn't call my car "dead silent" between the exhaust alone and the squeaks from the door seals and tire noise I wouldn't call it the calmest place in the world but it's not bad. I haven't noticed any major rattles to annoy me on long highway cruises.
__________________
Current: '20 X5, '11 E90 M3 Comp
Previous: '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 1
      11-24-2020, 01:02 PM   #1516
pbonsalb
Major General
3564
Rep
8,266
Posts

Drives: 08 E90 M3, 99 E36 M3 Turbo
Join Date: Feb 2011
Location: Concord, NH

iTrader: (4)

If I have an 08 with CCC (no usb or Y), am I better off converting to CIC or buying one of these CarPlay retrofits like joyeauto or carsera or others? I am not an audiophile, listen to the radio or pandora, and would like Waze on the display.
Appreciate 0
      11-24-2020, 01:11 PM   #1517
tdott
Brigadier General
2969
Rep
3,319
Posts

Drives: M3
Join Date: Nov 2010
Location: South FL / 6ix

iTrader: (4)

Quote:
Originally Posted by pbonsalb View Post
If I have an 08 with CCC (no usb or Y), am I better off converting to CIC or buying one of these CarPlay retrofits like joyeauto or carsera or others? I am not an audiophile, listen to the radio or pandora, and would like Waze on the display.
I've been eyeing this one to add to my CCC in one of my cars. https://www.android-car-dvd.com/collections/for-bmw/products/ew963wadcpxccc?variant=33378244952200

It replaces the screen, the mic is built in there so doesn't seem like it will have mic issues like some of these boxes.

But haven't seen anyone here try it.
Appreciate 0
      11-24-2020, 07:24 PM   #1518
GTiceman
Parrothead
GTiceman's Avatar
98
Rep
1,204
Posts

Drives: E90 M3
Join Date: Jul 2010
Location: Tampa

iTrader: (5)

Garage List
2009 BMW M3  [0.00]
Quote:
Originally Posted by Cyberdemon View Post
I've done the A pillar on all 3 of my cars and never had an issue. First it's a "Soft" piece, usually rattles happen with the hard bits. The fact that it's covered with fabric keeps it quite tight.

The little cap that sticks on is held really secure by some metal tabs, nothing to rattle there either. Pretty low risk, just make sure the cable is dressed and zip tied snug. That would be the only thing that could possibly tap around when moving but I haven't noticed any obvious issues.

I definitely wouldn't call my car "dead silent" between the exhaust alone and the squeaks from the door seals and tire noise I wouldn't call it the calmest place in the world but it's not bad. I haven't noticed any major rattles to annoy me on long highway cruises.
I meant the other pieces like dash trim but thanks for the feedback. My car isn't silent by any means but I meant no squeaking. I hit the door seals with 303 and keeps them quiet. Did you hide your module above/around the glove box?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:44 PM.




m3post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST