BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      03-03-2014, 04:17 PM   #1
gpitts
Private First Class
 
Drives: 2011 E92 M3
Join Date: Oct 2010
Location: Portland, OR

Posts: 120
iTrader: (0)

E92 M3 Erratic Idle After Fill-Up

I have an E92 M3, and love the car, BUT... In the past month or so, I noticed what I can only describe as "erratic" idling when sitting at a traffic light immediately after a fill-up. I generally use Chevron or 76 fuel, and only use premium. It now happens most every time I fill-up. Sometimes it "chases" the proper idle, others the car completely stalls. More the former than the latter though. Once I go past the traffic light, things seem to settle out. I've never seen this other than immediately after the fill-up. Maybe I should just avoid stopping at that traffic light.

The first time in to the dealer, the service guys could not reproduce the issue. The second time in to the dealer, they were able to reproduce it and ultimately replaced a fuel system canister and idle control somethingoranother. After my next fill-up, the issue resurfaced and she's now back in the shop for a third time.

Anyone else had a similar issue with their M3?
__________________

2011 E92 M3, Jerez Black, Black Interior
Escort 9500ci
gpitts is offline   United_States
0
Reply With Quote
      03-03-2014, 05:03 PM   #2
grantmax
Major
 
Drives: 2011 M3 ZCP
Join Date: Mar 2011
Location: LA

Posts: 1,101
iTrader: (1)

I have this issue. Not every time I fill up but it's there. I've experience one full stall and a number of narrow misses.

Sounds like they replaced what I considered the issue to be: the idle control valve. If that didn't do the trick, my next guess is an injector or the fuel pump.

I'd like to know if other have this and if it has ever been successfully diagnosed and/or fixed.
grantmax is offline  
0
Reply With Quote
      03-03-2014, 05:34 PM   #3
rdoctor
Private First Class
 
Drives: 09 e92 M3
Join Date: Oct 2013
Location: SC

Posts: 139
iTrader: (0)

It could be the gas you're using. These cars are VERY sensitive to fuel. One companies premium is mid grade for others. The car will adapt to different octane levels to a point but if you go below the 93 octane threshold you can see interesting messages on the OBC. I was getting the dreaded "increased emissions" message when I used 91 octane at an Exxon station (their "premium") and when I filled up the car the next time with my normal 93 octane ethanol free Shell V-Power I have never had a problem.

It's worth a try. These are special cars that like special gas. Go figure.
__________________
e92 M3 6MT, Jet Black/Black
Dinan: Tune, CF Intake, Exhaust, Pulley Kit, Stage 1 Suspension
rdoctor is offline  
0
Reply With Quote
      03-03-2014, 06:09 PM   #4
330indy
CCA member
 
330indy's Avatar
 
Drives: e46 + e92
Join Date: May 2005
Location: Indy

Posts: 869
iTrader: (0)

Where do you find E-0 V-Power 93 ????
__________________
V8 M3 in the barn

E46 330i 2002: DD; Z4M 2006- sold; E39 530i 2001- sold; E36 325iC 1994- sold
330indy is offline   United_States
0
Reply With Quote
      03-03-2014, 06:34 PM   #5
bde
Private First Class
 
Drives: 2008 E92 M3 JB, 6MT
Join Date: Oct 2009
Location: Toronto

Posts: 148
iTrader: (0)

definitely sounds like a faulty gas, try a different location
bde is offline  
0
Reply With Quote
      03-03-2014, 07:44 PM   #6
gpitts
Private First Class
 
Drives: 2011 E92 M3
Join Date: Oct 2010
Location: Portland, OR

Posts: 120
iTrader: (0)

Quote:
Originally Posted by bde View Post
definitely sounds like a faulty gas, try a different location
That was my guess as well, but the fuel checked out fine per BMW standards (one of the first things they checked). Additionally, I do move from station to station, and there has been no correlation to any particular brand or station.
__________________

2011 E92 M3, Jerez Black, Black Interior
Escort 9500ci
gpitts is offline   United_States
0
Reply With Quote
      03-03-2014, 09:29 PM   #7
rdoctor
Private First Class
 
Drives: 09 e92 M3
Join Date: Oct 2013
Location: SC

Posts: 139
iTrader: (0)

Quote:
Originally Posted by 330indy View Post
Where do you find E-0 V-Power 93 ????
We've got a couple of Shell stations with the good stuff here in the Charleston, SC area and 146 other stations in the state that have 93 octane E=0 fuel. It's all I've ever put in both of the M3's I've owned.

Look for some Shell stations on this site: http://pure-gas.org/ Looks like you have 5 stations (no Shell) in the entire state of IN that have 93+ E=0

City Brand Octane Name Street Address GPS*
Bremen AMOCO 93 Bellman Oil Co [574-546-2342] 550 E 2nd St N41.45340 W86.13805
Evansville UNBRANDED 93 St Joe Mini Mart [812-963-5761] 6000 W St Joseph Rd N38.06610 W87.64662
Hamilton UNBRANDED 93 Clarks Landing Marina [260-488-2169] 80 Ln 101b Hamilton Lk N41.56115 W84.91157
Mishawaka BP 93 Bell-Mart Bp [574-252-5290] 3505 Bremen Hwy N41.62927 W86.17716
Somerset UNBRANDED 94 Somerset Super Store [765-981-2600] 2 Shopping Center Rd N40.66692 W85.82755
__________________
e92 M3 6MT, Jet Black/Black
Dinan: Tune, CF Intake, Exhaust, Pulley Kit, Stage 1 Suspension

Last edited by rdoctor; 03-03-2014 at 09:53 PM.
rdoctor is offline  
0
Reply With Quote
      03-04-2014, 02:12 AM   #8
grantmax
Major
 
Drives: 2011 M3 ZCP
Join Date: Mar 2011
Location: LA

Posts: 1,101
iTrader: (1)

Quote:
Originally Posted by rdoctor
It could be the gas you're using. These cars are VERY sensitive to fuel. One companies premium is mid grade for others. The car will adapt to different octane levels to a point but if you go below the 93 octane threshold you can see interesting messages on the OBC. I was getting the dreaded "increased emissions" message when I used 91 octane at an Exxon station (their "premium") and when I filled up the car the next time with my normal 93 octane ethanol free Shell V-Power I have never had a problem.

It's worth a try. These are special cars that like special gas. Go figure.
Seems like a good guess. Although you haven't taken into account California. We don't have 93. It's 91 or bust. Also, our adaptive ECUs should be able to figure this out without choking out.

I only use Shell. And mid-grade (89) fuel is the one that could be faulty. Some stations use tanks underground to mix 87 and 91. Other stations order actual 89 fuel.

I think this issue has to be more than a bad batch of fuel. Or two.
grantmax is offline  
0
Reply With Quote
      03-04-2014, 01:36 PM   #9
gpitts
Private First Class
 
Drives: 2011 E92 M3
Join Date: Oct 2010
Location: Portland, OR

Posts: 120
iTrader: (0)

Quote:
Originally Posted by gpitts View Post
I have an E92 M3, and love the car, BUT... In the past month or so, I noticed what I can only describe as "erratic" idling when sitting at a traffic light immediately after a fill-up. I generally use Chevron or 76 fuel, and only use premium. It now happens most every time I fill-up. Sometimes it "chases" the proper idle, others the car completely stalls. More the former than the latter though. Once I go past the traffic light, things seem to settle out. I've never seen this other than immediately after the fill-up. Maybe I should just avoid stopping at that traffic light.

The first time in to the dealer, the service guys could not reproduce the issue. The second time in to the dealer, they were able to reproduce it and ultimately replaced a fuel system canister and idle control somethingoranother. After my next fill-up, the issue resurfaced and she's now back in the shop for a third time.

Anyone else had a similar issue with their M3?
Just an update... apparently BMWNA is sending a Field tech to take a look at the car. Should be on the ground Thursday morning.
__________________

2011 E92 M3, Jerez Black, Black Interior
Escort 9500ci
gpitts is offline   United_States
0
Reply With Quote
      03-04-2014, 02:41 PM   #10
RezTTU
Private First Class
 
Drives: Mineral White E92 ZCP
Join Date: May 2011
Location: Irving, TX

Posts: 122
iTrader: (0)

My car is at the dealer for this EXACT issue, it stalled once, and I have it recorded, and showed them, and they are having issues figuring it out. Keep us updated please, my car has been at the dealer for 2 weeks now. I figured it was either idle control valve or fuel pump/injector.
RezTTU is offline  
0
Reply With Quote
      03-04-2014, 03:04 PM   #11
kscarrol
Colonel
 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

Posts: 2,095
iTrader: (0)

Same here. Was recently at the dealer for regular service and mentioned the issue. Despite keeping it overnight they were unable to replicate the issue and the car had no codes indicating problems. Happened again yesterday after filling up at my local Shell station. Unfortunately I do not have it filmed to show the dealer. Tried yesterday but the idle smoothed to before I could dig my phone out...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
kscarrol is offline   United_States
0
Reply With Quote
      03-04-2014, 03:51 PM   #12
RezTTU
Private First Class
 
Drives: Mineral White E92 ZCP
Join Date: May 2011
Location: Irving, TX

Posts: 122
iTrader: (0)

I got my clip uploaded. I wish i commented on it, and recorded me filling it up. This clip is recorded right after I got done filling up. I got in the car and started it up, and it started erratically idling, here is the video:

RezTTU is offline  
0
Reply With Quote
      03-04-2014, 05:16 PM   #13
MMM3PWR
E90 6MT MASTER
 
MMM3PWR's Avatar
 
Drives: 2008 BMW M3 Sedan
Join Date: Mar 2013
Location: Poughkeepsie

Posts: 241
iTrader: (0)

I have an early 08 e90 m3 and mine has done thing for the past 70k miles...all different types of gas ..now at 120k and counting
__________________
MMM3PWR is offline   United_States
0
Reply With Quote
      03-04-2014, 05:22 PM   #14
5soko
Brigadier General
 
5soko's Avatar
 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

Posts: 4,210
iTrader: (4)

Alot of M5 S85's have this issue aswell..

It also does this when the car is at full temp, left to sit for a hour and started again.
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
5soko is offline   Montenegro
0
Reply With Quote
      03-04-2014, 11:05 PM   #15
skate0518
Second Lieutenant
 
Drives: e46 ///M,e85 ///M, e92 ///M3
Join Date: Feb 2010
Location: Rusnake Porsche (Pasadena)

Posts: 246
iTrader: (2)

I have same issue after full Gas it stalled, but only happened couple times ....
skate0518 is offline   United_States
0
Reply With Quote
      03-05-2014, 02:16 PM   #16
RD1M3
Second Lieutenant
 
Drives: '11 JZB DCT E92 M3
Join Date: Jun 2013
Location: NC

Posts: 215
iTrader: (0)

Ditto, just happened to me for the first time after my last fill up. Let's hope it doesn't become a recurring issue...
RD1M3 is offline  
0
Reply With Quote
      03-05-2014, 08:59 PM   #17
330indy
CCA member
 
330indy's Avatar
 
Drives: e46 + e92
Join Date: May 2005
Location: Indy

Posts: 869
iTrader: (0)

I assume you guys are not overfilling/ topping off
Right?
__________________
V8 M3 in the barn

E46 330i 2002: DD; Z4M 2006- sold; E39 530i 2001- sold; E36 325iC 1994- sold
330indy is offline   United_States
0
Reply With Quote
      03-07-2014, 05:32 PM   #18
RezTTU
Private First Class
 
Drives: Mineral White E92 ZCP
Join Date: May 2011
Location: Irving, TX

Posts: 122
iTrader: (0)

I let it click twice, I can usually tell how much I need to fill up. 14.5-15 gallons.
RezTTU is offline  
0
Reply With Quote
      03-07-2014, 05:36 PM   #19
mjposner
Captain
 
mjposner's Avatar
 
Drives: 2014 235i
Join Date: Mar 2011
Location: US

Posts: 992
iTrader: (2)

Trying stopping at the first click, and see if that helps. You maybe overfilling it.
__________________
Previous BMW: 11 BMW M3; 08 BMW M3; 08 BMW Z4M; 04 X3; 02 M3 Convertible; 02 M3; 00 M Roadster; 94 325 convertible; 85 635csi
My other ride: www.mjposner.com/corvair
Check out my Mountain retreat:www.blueridge-rental.com
My Car Photo Blog: http://carfisheye.blogspot.com/
mjposner is offline   United_States
0
Reply With Quote
      03-09-2014, 05:22 PM   #20
kscarrol
Colonel
 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

Posts: 2,095
iTrader: (0)

Here is a quick video from this afternoon right after filling up. But it also did this earlier today around a 1/4 tank of gas. The rough idle earlier didn't stall the car but did cause the DCT to go into neutral...

Edit: And no, I did not over fill, simply let the pump shut itself off and removed nozzle with no extra topping off!

__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.

Last edited by kscarrol; 03-09-2014 at 05:35 PM.
kscarrol is offline   United_States
0
Reply With Quote
      03-10-2014, 03:44 PM   #21
gpitts
Private First Class
 
Drives: 2011 E92 M3
Join Date: Oct 2010
Location: Portland, OR

Posts: 120
iTrader: (0)

Quote:
Originally Posted by kscarrol View Post
Here is a quick video from this afternoon right after filling up. But it also did this earlier today around a 1/4 tank of gas. The rough idle earlier didn't stall the car but did cause the DCT to go into neutral...

Edit: And no, I did not over fill, simply let the pump shut itself off and removed nozzle with no extra topping off!
Update on my car (and confirmation to kscarrol that what is shown on the video is exactly what I experienced)...

The Field Tech had the service department change the fuel pump and also a fuel pressure valve (don't have the paperwork in front of me, so I'm probably off a bit on the exact name of the part). Neither of those items is monitored by the engine control unit. I picked up my car Friday, but as I was leaving the dealership the "Increased Emissions" indication came on, so I took it back to them this morning.

I can't say with 100 percent certainty that my issue is resolved, but it makes sense that a stall caused by a component that is not monitored would result in the absence of a logged fault.
__________________

2011 E92 M3, Jerez Black, Black Interior
Escort 9500ci
gpitts is offline   United_States
0
Reply With Quote
      03-10-2014, 03:45 PM   #22
gpitts
Private First Class
 
Drives: 2011 E92 M3
Join Date: Oct 2010
Location: Portland, OR

Posts: 120
iTrader: (0)

Quote:
Originally Posted by M3DreamTTU View Post
My car is at the dealer for this EXACT issue, it stalled once, and I have it recorded, and showed them, and they are having issues figuring it out. Keep us updated please, my car has been at the dealer for 2 weeks now. I figured it was either idle control valve or fuel pump/injector.
Check my post (above) for an update on my situation. Hope it helps you!
__________________

2011 E92 M3, Jerez Black, Black Interior
Escort 9500ci
gpitts is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:18 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST