BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > Australia
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      01-18-2014, 01:14 AM   #1
gerrya
Registered
0
Rep
3
Posts

Drives: E92 M3
Join Date: Aug 2013
Location: Melbourne, Australia

iTrader: (0)

Question LEDs not working on just installed LCI tail lights

Solved
=====
It turns out I may have had a loose connection in my right tail light. I left the headlights on and jiggled the connection in the back of the right tail light and the tail lights came on (both sides). But now the tail lights seem to stay on permanently even when the headlights are off. I don't know if these are like the daytime running lights which stay on all the time or if it's another issue (from no tail lights to too much tail lights). I'll have a closer look at other beemmers with LCI tail lights and see if their tail lights stay on too.

Thanks for reading.
-------------------------

Hi guys,

Hoping to get advice from those of you who have had experience with LCI upgrades. I have installed a set of LCI tail lights into my 08 E92 M3 but the tail lights are not working.

Indicators and brake lights works but not tail lights.

I have coded out the bulb checks and indicators flash at the correct speed. My only issue is with the tail lights. These don't come on when the head lights are on. These were plug and play and I have I have checked the connections to the tail lights.

Still looking at other forums and doing google searches but no luck so far. It seems to just work for others who have done the upgrade so I must be missing something very simple.

Please chime in if you have any suggestions.

Last edited by gerrya; 01-18-2014 at 01:40 AM. Reason: issue resolved
Appreciate 0
      01-19-2014, 05:32 PM   #2
MFKN3
Colonel
MFKN3's Avatar
Australia
43
Rep
2,056
Posts

Drives: 4.5L supercharged stroker E92
Join Date: Nov 2008
Location: Australia

iTrader: (2)

The tail lights also have DRL, if you have it turned on in idrive
Appreciate 0
      01-21-2014, 12:37 AM   #3
Stuart@BMRAutowerkes
Brigadier General
Stuart@BMRAutowerkes's Avatar
107
Rep
4,928
Posts

Drives: a black car
Join Date: Sep 2010
Location: Sydney

iTrader: (3)

Good to hear you got it all worked out Gerry,

I should've pointed out as well that the retrofit cables have a LH and a RH side and are not interchangeable
Appreciate 0
      01-21-2014, 08:34 AM   #4
gerrya
Registered
0
Rep
3
Posts

Drives: E92 M3
Join Date: Aug 2013
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by MFKN3 View Post
The tail lights also have DRL, if you have it turned on in idrive
Thanks MFKN3. I found out that on another forum that it was a feature that could be turned off or on.

I have coded them off for now. Everything working great.
Appreciate 0
      01-21-2014, 08:35 AM   #5
gerrya
Registered
0
Rep
3
Posts

Drives: E92 M3
Join Date: Aug 2013
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by Stuart@BMRAutowerkes View Post
Good to hear you got it all worked out Gerry,

I should've pointed out as well that the retrofit cables have a LH and a RH side and are not interchangeable
Haha - just blind luck I got them right then. cheers mate.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:46 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST