BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      08-27-2014, 06:57 PM   #1
Ilikemike
Enlisted Member
Canada
0
Rep
46
Posts

 
Drives: 2013 M3 Coupe
Join Date: Sep 2010
Location: Port Moody B.C

iTrader: (0)

low power and missing over 6k rpm under WOT

Car has 12,000 miles and pulls strongly under WOT until 6k where the power drops off ~20% and there is some 'light' miss-firing.... Thoughts?
Appreciate 0
      08-27-2014, 07:47 PM   #2
thekurgan
Bad Lieutenant
thekurgan's Avatar
United_States
36
Rep
2,902
Posts

 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Any stored codes/lights?
__________________

08 E90M3 6MT Alpinweiss/Carbon/BPMSport 91 octane tune/BPMSport Feature coding/BMW Pedals/Dinan Exhaust/Alcantara Wheel/Rear Fog Switch/Rattle fixes
Appreciate 0
      08-27-2014, 08:13 PM   #3
Devant
Banned
2
Rep
104
Posts

 
Drives: '11 M3
Join Date: Aug 2014
Location: NYC

iTrader: (0)

Plugs and coilpacks would be the first thing I'd check if I was mis firing.
Appreciate 0
      08-27-2014, 08:39 PM   #4
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
98
Rep
4,813
Posts


 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal

iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by Devant
Plugs and coilpacks would be the first thing I'd check if I was mis firing.
This - or fuel pressure sensor
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      08-27-2014, 09:47 PM   #5
D@AP
Second Lieutenant
United_States
3
Rep
229
Posts

 
Drives: 09 Audi R8
Join Date: Apr 2014
Location: Alhambra, CA

iTrader: (0)

Quote:
Originally Posted by thekurgan View Post
Any stored codes/lights?
That's the first thing I would do also, then look into plugs/coil packs.
Appreciate 0
      08-28-2014, 12:04 AM   #6
Hujan
Lieutenant Colonel
United_States
27
Rep
1,970
Posts

 
Drives: 2013 E92 M3; 2010 Z4 35i
Join Date: Apr 2013
Location: San Diego, CA

iTrader: (4)

Quote:
Originally Posted by Ilikemike View Post
Car has 12,000 miles and pulls strongly under WOT until 6k where the power drops off ~20% and there is some 'light' miss-firing.... Thoughts?
I have nothing to add except to check to be sure you don't have an F8x M3/M4.

Appreciate 0
      08-28-2014, 12:12 PM   #7
Ilikemike
Enlisted Member
Canada
0
Rep
46
Posts

 
Drives: 2013 M3 Coupe
Join Date: Sep 2010
Location: Port Moody B.C

iTrader: (0)

power problem

Quote:
Originally Posted by Hujan View Post
I have nothing to add except to check to be sure you don't have an F8x M3/M4.

Very Good! Funny! I should have checked.
Appreciate 0
      08-28-2014, 12:13 PM   #8
Ilikemike
Enlisted Member
Canada
0
Rep
46
Posts

 
Drives: 2013 M3 Coupe
Join Date: Sep 2010
Location: Port Moody B.C

iTrader: (0)

low power

No warning lights... Thanks for the heads up on the coils and plugs, seems a bit early for them to be going south, no?
Appreciate 0
      08-28-2014, 04:41 PM   #9
Dave07997S
Colonel
38
Rep
2,556
Posts

 
Drives: 2013 BMW M3 ZCP Coupe
Join Date: May 2009
Location: Playa del Rey, CA

iTrader: (1)

Its a 2013 M3, just take it to the dealer and let them deal with it. I think its a bad coil pack. Usually it throws codes for that though. Maybe bad gas?

Dave
__________________
2013 M3 Coupe-MR/BLK ZCP, ACM test pipes, BPM Stg2 dev. tune and Megan catback, AFE Stg2. with C/F elbow
Previous rides: 2011 M3 Coupe-MR/Blk
2007 Porsche 997C2S Speed Yellow/Blk sport seats
2004 BMW M3 Imola/Blk
Appreciate 0
      08-28-2014, 04:55 PM   #10
Rupes
Captain
Rupes's Avatar
United_States
23
Rep
848
Posts

 
Drives: 2011 E92 M3
Join Date: Apr 2013
Location: Ohio

iTrader: (0)

Quote:
Originally Posted by Hujan
I have nothing to add except to check to be sure you don't have an F8x M3/M4.

Hah, that's a good one!
Appreciate 0
      08-28-2014, 06:18 PM   #11
Alex07M3
Colonel
27
Rep
2,151
Posts

 
Drives: E92 M3, Evo X MR, A4 Allroad
Join Date: Jan 2012
Location: Gatineau

iTrader: (1)

Quote:
Originally Posted by Hujan
Quote:
Originally Posted by Ilikemike View Post
Car has 12,000 miles and pulls strongly under WOT until 6k where the power drops off ~20% and there is some 'light' miss-firing.... Thoughts?
I have nothing to add except to check to be sure you don't have an F8x M3/M4.

LOL
__________________
ESS VT1, M Performance exhaust, Turner test pipes, KW V3s, Michelin PSS 255/295
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:09 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST