BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
E92-lighting
Post Reply
 
Thread Tools Search this Thread
      11-12-2013, 12:27 AM   #1
E92inSG
First Lieutenant
 
E92inSG's Avatar
 
Drives: E92 M3
Join Date: Jul 2012
Location: Asia

Posts: 351
iTrader: (1)

Hey guys. Need some input here

I recently installed ohlins R&T coilovers and replaced all my bushings with powerflex black series (minus subframe bushing) including sway bar bushings

Now I've got a horrible squishing sound when going over humps slowly. It SOUNDS like damper noise. But when I had the ohlins on prior to the bushings upgrade (about a wekk) there was no noise.

Would it be possible that this sound is caused by the bushings? Possibly insufficient lubrication? Has anyone experienced something like that? Normal driving no sounds whatsoever.

The weird part is the noise is less at hard damper settings and becomes noisier at soft settings so I'm not sure if it's caused by the coilovers?

What's the best way to isolate the cause?

Last edited by E92inSG; 11-12-2013 at 02:06 AM.
E92inSG is offline  
0
Reply With Quote
      11-12-2013, 02:05 AM   #2
E92inSG
First Lieutenant
 
E92inSG's Avatar
 
Drives: E92 M3
Join Date: Jul 2012
Location: Asia

Posts: 351
iTrader: (1)

these are the only 2 parts i changed on the front:

Race Polyurethane Front Tension Arm Bushings - Front Position Control Arm


Race Polyurethane Rear Sway Bar Bushing Set
E92inSG is offline  
0
Reply With Quote
      11-27-2013, 05:09 AM   #3
raziel5201314
Lieutenant
 
Drives: 2008 E92 M3
Join Date: Jan 2012
Location: Santa Barbara, CA

Posts: 556
iTrader: (1)

My right front damper makes squishing sound too, but it only happens when i go over the bumpy road from above 40mph. The shop just told me today that i will need to replace the link, because one of the bushing need to be replaced. So now i'm guessing that mind be the problem that causes the sound.
raziel5201314 is offline  
0
Reply With Quote
      01-02-2014, 05:15 AM   #4
E92inSG
First Lieutenant
 
E92inSG's Avatar
 
Drives: E92 M3
Join Date: Jul 2012
Location: Asia

Posts: 351
iTrader: (1)

Solved the problem. Make sure sway bar bushings always have enough grease.
E92inSG is offline  
0
Reply With Quote
      01-02-2014, 12:31 PM   #5
Z K
Lieutenant Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 1,970
iTrader: (3)

Quote:
Originally Posted by E92inSG View Post
Solved the problem. Make sure sway bar bushings always have enough grease.
I really don't like using polyurethane bushings. They require constant greasing and make a lot of noise when it is not lubed.
__________________
Auto Detailing Enthusiast!
Z K is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:45 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST