BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > Canada
 
BPM Sport
Post Reply
 
Thread Tools Search this Thread
      10-25-2013, 12:51 PM   #1
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

My '13 M3 approaching its 2 month Anniversary...

of being in the service department at Endras!

The real kicker is that most of the time has been waiting for parts! I know it's a German car and part delays are part of the game but to wait over 2 weeks for screws and washers... How can the parts distribution center in Canada forget to re-order screws and washers?

Anyway, I've made a formal complaint with BMW Canada and though "No one ever reviews these complaints" (that is word-for-word what the customer services employee told me over the phone) I was told that I can call back once my car has been returned and they may "do something for me" based on the total down time.

Has anyone else gone through a similar experience? Did you get anywhere with BMW Canada or your dealer?

Thanks!
Appreciate 0
      10-25-2013, 01:10 PM   #2
///Matt.BLU
Private First Class
///Matt.BLU's Avatar
1
Rep
171
Posts

 
Drives: E92 M3
Join Date: Jan 2013
Location: Toronto

iTrader: (1)

you have a '13 and it's been in the shop for 2 months?

Did I interpret that wrong?
Appreciate 0
      10-25-2013, 01:12 PM   #3
D88
Private
0
Rep
78
Posts

 
Drives: 2009 E90 BMW M3
Join Date: Sep 2013
Location: Houston

iTrader: (0)

Congrats?


What are they doing to your car? That's an awful long time without the M...
Appreciate 0
      10-25-2013, 01:26 PM   #4
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by ///Matt.BLU View Post
you have a '13 and it's been in the shop for 2 months?

Did I interpret that wrong?
Unfortunately yes...

I picked up the last 2013 Endras had in early August. I've always loved the E9x M3, so much so, I chose it over a 2012 GTR BE but now I'm really second guessing my decision...
Appreciate 0
      10-25-2013, 01:27 PM   #5
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by D88 View Post
Congrats?


What are they doing to your car? That's an awful long time without the M...
Thanks?

The first issue was a broken valve spring now it's the venos unit.
Appreciate 0
      10-25-2013, 03:07 PM   #6
swifty
Major
23
Rep
1,295
Posts

 
Drives: FO M3
Join Date: Aug 2008
Location: canada

iTrader: (5)

Was this a demo car? When did they recognize these issues... few days after taking delivery? I'm getting my '13 in the next week and this is scaring the hell out of me.

Did you get a loaner? if so which one?
__________________
__________________
Past: '89 Cutlass, Alpine white e46 323i, Jet Black e39 530, Sapphire Black e60 530, Space Grey 2008 e92 335, Mineral White 2011 e92 335

Current: FO e92 M3
Appreciate 0
      10-25-2013, 04:22 PM   #7
bobblehead
Brigadier General
bobblehead's Avatar
Canada
50
Rep
3,764
Posts

 
Drives: warp speed
Join Date: Aug 2009
Location: Toronto, On

iTrader: (0)

If you have a loan or lease with BMWFS and your down time is like a month, then you can certainly ask them to waive one month of payment. You just have to push them harder, rather than just phone call or general email, I suggest you to put it into writing and send the letter to the vp of customer relation & vp of financial service.
Appreciate 0
      10-26-2013, 12:04 PM   #8
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by swifty View Post
Was this a demo car? When did they recognize these issues... few days after taking delivery? I'm getting my '13 in the next week and this is scaring the hell out of me.

Did you get a loaner? if so which one?
Technically it was a demo for 3 weeks. I was told it was only driven by the owner of the dealership and I took ownership of the car with less than 900 kms on it.

The car went into limp mode the first week in September (I got the car the first week in August). They diagnosed the problem as a broken valve spring causing the cylinder to shutdown. They replaced all 8 springs but the bolts and washers needed to button up the engine were on back order. After 2+ weeks of waiting they got the wrong bolts in so then they had to reorder them. Luckily it was only a few days. Once everything was put back together the car was running much better but still not right. They checked the codes again and this time there was a vanos code and of course the unit is on back order. They placed the order October 7th and I spoke to my sales rep and he has been able to confirm the vanos unit has landed at the parts depo via a "priority US shipment" (I hate to see how long standard priority would be...) and that the part should be at the dealership Monday Oct 28.

I wouldn't worry man. These things happen with all makes and models. I'm just shocked at how disorganized BMW is with their parts depo and the time lag to receive parts. The service department has been a bit of a pain as we'll but most are...

They did reluctantly give me a loaner after I complained to the service manager, which was no use, and my sales rep who spoke to both the sales manager and owner. It is a 535GT. Probably as far as you can get from an M3...

Last edited by 81bear; 10-26-2013 at 12:09 PM.
Appreciate 0
      10-26-2013, 12:05 PM   #9
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by bobblehead View Post
If you have a loan or lease with BMWFS and your down time is like a month, then you can certainly ask them to waive one month of payment. You just have to push them harder, rather than just phone call or general email, I suggest you to put it into writing and send the letter to the vp of customer relation & vp of financial service.
Yeah I'm going to see what I get talking with them on the phone and will escalate it if need be. Thanks for the advice!
Appreciate 0
      10-26-2013, 09:25 PM   #10
///Matt.BLU
Private First Class
///Matt.BLU's Avatar
1
Rep
171
Posts

 
Drives: E92 M3
Join Date: Jan 2013
Location: Toronto

iTrader: (1)

dang, that sucks to hear.

I also have a '13 M3, and luckily its running well.

I hope you get this all resolved soon.
Appreciate 0
      10-27-2013, 01:36 PM   #11
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Quote:
Originally Posted by ///Matt.BLU View Post
dang, that sucks to hear.

I also have a '13 M3, and luckily its running well.

I hope you get this all resolved soon.
Thanks man!

I'm sure I've just been a bit unlucky. Hopefully all will be fine from this point on...
Appreciate 0
      10-27-2013, 03:51 PM   #12
bing240sx
Lieutenant
6
Rep
405
Posts

 
Drives: E90 M3 Sedan
Join Date: Dec 2012
Location: Canada

iTrader: (2)

i had a similar issue with parts distribution from BMW Canada on the Dinan stuff... took 3 weeks after ordering for BMW to ship it out of California...

it really is something that should be addressed. premium brands should have premium service at all levels of the OE and aftermarket supply chain.
__________________
Appreciate 0
      10-27-2013, 04:02 PM   #13
N1tr0gen
Private First Class
N1tr0gen's Avatar
1
Rep
108
Posts

 
Drives: M3Vert
Join Date: Jul 2013
Location: Canada

iTrader: (0)

Same thing happened to my friends M5 at Budds... they ordered incorrect part and now it is on backorder for god knows how long again..
__________________
Topless is better.
Appreciate 0
      10-27-2013, 05:16 PM   #14
bing240sx
Lieutenant
6
Rep
405
Posts

 
Drives: E90 M3 Sedan
Join Date: Dec 2012
Location: Canada

iTrader: (2)

there should be enough of these cars on the road such that this type of thing never happens.

it's not like we're ripping around in exotics.
__________________
Appreciate 0
      11-01-2013, 10:11 AM   #15
baba louey
Second Lieutenant
2
Rep
235
Posts

 
Drives: 2012 M3 coupe
Join Date: Aug 2012
Location: calgary

iTrader: (0)

When I had my RX7, I could get parts from the dealer within 24hrs if the part was in Canada, 48-72 hrs if it had to come from the US, and about 2 weeks if from Japan. I thought that was very good service. I'm surprised that BMW is taking so long.
Appreciate 0
      11-02-2013, 10:37 AM   #16
81bear
Private
0
Rep
88
Posts

 
Drives: 2013 E92 M3
Join Date: Sep 2010
Location: Toronto

iTrader: (1)

Thanks for the support guys!

Update - I got my car back yesterday. The car seems to be running stronger than it was before. Not sure if it truly is or a result of getting used to driving the 535 GT. Lol!

Anyway, the dealership fully detailed the car (interior, exterior, and engine bay), topped up the gas, and offered to reimburse me for the two months of payments they had the car for. The final, and most important, thing the dealership gave me was an apology. For the first time during this whole fiasco the dealership took responsibility for the situation and apologies accordingly.

All in all I am satisfied with the overall result.
Appreciate 0
      11-02-2013, 11:32 AM   #17
baba louey
Second Lieutenant
2
Rep
235
Posts

 
Drives: 2012 M3 coupe
Join Date: Aug 2012
Location: calgary

iTrader: (0)

Quote:
Originally Posted by 81bear View Post
Thanks for the support guys!

Update - I got my car back yesterday. The car seems to be running stronger than it was before. Not sure if it truly is or a result of getting used to driving the 535 GT. Lol!

Anyway, the dealership fully detailed the car (interior, exterior, and engine bay), topped up the gas, and offered to reimburse me for the two months of payments they had the car for. The final, and most important, thing the dealership gave me was an apology. For the first time during this whole fiasco the dealership took responsibility for the situation and apologies accordingly.

All in all I am satisfied with the overall result.
Glad to hear that you're satisfied. I would find it very trying to be without a newly purchased car for so long.
Appreciate 0
      11-10-2013, 11:00 PM   #18
Thik
Private First Class
6
Rep
146
Posts

 
Drives: 2010 Space Grey E92 M3 6spd
Join Date: Jan 2013
Location: Toronto

iTrader: (0)

Maybe the car was not properly broken in during the first 900km?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:03 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST