BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Post Reply
 
Thread Tools Search this Thread
      10-09-2013, 11:37 PM   #1
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

Question Weird stalling issue happened today.......

Today I was in my car waiting in line at a fast food restaurant. There were 7-8 cars in front of me. When I begin to move forward as each car in front of me did something weird followed:

Each time I would give it a little gas to move forward about 10 feet, my car would start surging as soon as I got off the gas and started to apply the brakes. Best way to describe the surging is it dropped all the way down to 100-200 rpm's and then shot up to 1800-2000 rpms a couple times and then surged between 500-1200 until I moved forward again.

When I attempted to move forward again, it did the exact same thing but this time the engine stalled as soon as I applied the brakes from the slow the crawl forward.

The car did this another 4-5 times until I got my order at the window.

During this entire ordeal, it never threw a single SES, CEL, Half Engine, NOTHING.

Once I exited the drive through, I pulled in to the parking and plugged in my BT OBD-II. Checked for any codes and none were present. I'm aware OBD-II smart phone apps aren't 100% accurate, so there very well may be some shadow or PENDING codes stored in the DME.

I called my SA and explained to him what my car just did and he told me to bring it in and he would give me a loaner until they could get it diagnosed.

During my 45 minute drive to the dealer in a lot of stop and go traffic, the car didn't have a single hiccup the entire way. Drove perfect as it has the day I brought it home.

Only other thing worth mentioning is that I filled up my tank 2 minutes prior to entering the drive through.

Does the weird surging/stalling issue sound like an isolated hardware fault or something different? I've searched pretty deep today prior to posting this and couldn't find anything that matched my exact issues. I've read multiple threads on IAC valves and throttle actuators causing surging but have yet to read about them causing a car to stall.

Also if the dealer comes back with the infamous "Unable to reproduce reported problem", what should I do if anything can be done??

I've owned this car for about a month and its been a VERY solid car thus far and a blast to drive.

Sorry for the long post, just want it to be as understandable as possible.

-Nick
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-10-2013, 01:04 AM   #2
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

Almost a 100 views and not a single opinion or guess. Hmmmmmm
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-10-2013, 02:09 AM   #3
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

I haven't ruled bad gas out as a possibility yet but how would bad gas display these symptoms upon a fresh fill up and not continue to do it? Doesn't add up to me. Just the way I see it though.
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-10-2013, 02:11 AM   #4
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

Might also help to add that I always fill up gas from the same station on post and its 92oct.
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-11-2013, 01:38 AM   #5
fastmike
Second Lieutenant
3
Rep
259
Posts

 
Drives: E93 M3
Join Date: Mar 2011
Location: USA

iTrader: (0)

My car does this almost every time I fill up. It'll only do it once within of 1 mile of filling up then never again until I fill up next time. I've tried keeping logs it seems to not happen as often if I fill up sooner like 1/4 tank left. I usually fill up 91 octane premium (SoCal) Chevron or Mobil.

I've never seen any weird lights but haven't scanned codes.
Appreciate 0
      10-11-2013, 01:44 AM   #6
fastmike
Second Lieutenant
3
Rep
259
Posts

 
Drives: E93 M3
Join Date: Mar 2011
Location: USA

iTrader: (0)

http://www.m3post.com/forums/showthread.php?t=828104

Here's another thread for a similar issue. OP said it hasn't happened since he updated his DME software.
Appreciate 0
      10-11-2013, 02:03 AM   #7
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

Quote:
Originally Posted by fastmike View Post
My car does this almost every time I fill up. It'll only do it once within of 1 mile of filling up then never again until I fill up next time. I've tried keeping logs it seems to not happen as often if I fill up sooner like 1/4 tank left. I usually fill up 91 octane premium (SoCal) Chevron or Mobil.

I've never seen any weird lights but haven't scanned codes.
Quote:
Originally Posted by fastmike View Post
http://www.m3post.com/forums/showthread.php?t=828104

Here's another thread for a similar issue. OP said it hasn't happened since he updated his DME software.
Good find. Seems like were not alone with this issue

Just got the car back from the dealer today. I got the infamous "unable to duplicate reported issues". It is running normally as it did on the drive down to the dealer.

One of my co-workers called me as I was at the dealer waiting to take delivery of my car. He asked me where I filled my tank up at. I told him where and he informed that he filled up his tank today at the same place as I did and now his car(Audi TT) is idling and surging some. He stated that his car has never acted this way also.

Once I heard this from him I pretty much knew the gas station on post must have just received a bad batch. While I was at the dealer I picked up a bottle of the BMW fuel treatment and added half the bottle to my full tank.

So far all is well.

-Nick
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-11-2013, 10:56 AM   #8
fastmike
Second Lieutenant
3
Rep
259
Posts

 
Drives: E93 M3
Join Date: Mar 2011
Location: USA

iTrader: (0)

Personally I find it hard to believe it's the gas for this symptom.

It only happens once after I fill up. It happens across all major brands across many different gas stations in the LA area for me.

I would think if its the gas it would happen through the whole tank

Quote:
Originally Posted by e46m3to135i View Post
Good find. Seems like were not alone with this issue

Just got the car back from the dealer today. I got the infamous "unable to duplicate reported issues". It is running normally as it did on the drive down to the dealer.

One of my co-workers called me as I was at the dealer waiting to take delivery of my car. He asked me where I filled my tank up at. I told him where and he informed that he filled up his tank today at the same place as I did and now his car(Audi TT) is idling and surging some. He stated that his car has never acted this way also.

Once I heard this from him I pretty much knew the gas station on post must have just received a bad batch. While I was at the dealer I picked up a bottle of the BMW fuel treatment and added half the bottle to my full tank.

So far all is well.

-Nick
Appreciate 0
      10-12-2013, 01:22 AM   #9
Mr. Liu
First Lieutenant
Mr. Liu's Avatar
5
Rep
303
Posts

 
Drives: 2011 AW/FR E90 M3
Join Date: Jul 2010
Location: Los Angeles, CA

iTrader: (0)

I get the same kind of surging and buckling just pulling out of the gas station... feathering the throttle my car would lunge. Only lasts like less than a mile.
__________________
Turner - Megan - Rogue Engineering - RDSport - AFe - Akra
Appreciate 0
      10-12-2013, 01:47 AM   #10
fastmike
Second Lieutenant
3
Rep
259
Posts

 
Drives: E93 M3
Join Date: Mar 2011
Location: USA

iTrader: (0)

Quote:
Originally Posted by Mr. Liu View Post
I get the same kind of surging and buckling just pulling out of the gas station... feathering the throttle my car would lunge. Only lasts like less than a mile.
How many miles do you have on your car? What brand of gas do you usually buy?

I have 69k, usually buy Chevron or Mobil.
Appreciate 0
      10-28-2013, 11:34 PM   #11
e46m3to135i
Private First Class
United_States
1
Rep
161
Posts

 
Drives: 2010 MR E92 M3
Join Date: Jan 2010
Location: Schofield Barracks, HI

iTrader: (0)

Quote:
Originally Posted by Mr. Liu View Post
I get the same kind of surging and buckling just pulling out of the gas station... feathering the throttle my car would lunge. Only lasts like less than a mile.
Quote:
Originally Posted by fastmike View Post
How many miles do you have on your car? What brand of gas do you usually buy?

I have 69k, usually buy Chevron or Mobil.
Have either of you brought this issue to the dealer?

My idle started randomly surging (500-1700) yesterday. This time it happened on my way to fill it up(tank was a little under a 1/8th of a tank).
It did this 4 traffic lights in a row as I was stopped and waiting for the light to turn green. It didn't stall this time, just surged up and down over and over until it was time to move forward. Its been fine ever since I filled up. Weird

Really seems like its a fuel pressure related issue or something. Its pretty frustrating that it wont throw a code. At least it would give me a place to start.

I'm almost thinking about changing the fuel rail pressure sensor for shits and gigs. Other than this intermittent issue, its runs awesome.

At this point it's pointless to take it back to the dealer. Odds are they won't be able to replicate the issue and as I said before, it's not throwing any codes while or after it does this.

-Nick
__________________
2010 Melbourne Red E92 M3 / DCT / 220M / CF Roof / Premium / Assist / BT / PDC.

Evolve Stage 1 Tune / GTS DCT Flash / Servo Tune / OEM Exhaust Mod / BMC Drop In / H&R Sports Springs / BMS 15/12mm Spacers / CF Grilles / CF Gills / CF Hood Vents / Painted Reflectors / Extended Paddles / BMS ARC AE's / Cyba Scoops / 20% Tint
Appreciate 0
      10-29-2013, 09:56 AM   #12
Mr. Liu
First Lieutenant
Mr. Liu's Avatar
5
Rep
303
Posts

 
Drives: 2011 AW/FR E90 M3
Join Date: Jul 2010
Location: Los Angeles, CA

iTrader: (0)

^ I use all different types of fuel lol. It really isn't a big issue for me - we all know our cars have some quirks here and there. My car has 23k miles roughly.
__________________
Turner - Megan - Rogue Engineering - RDSport - AFe - Akra
Appreciate 0
      12-19-2013, 07:45 PM   #13
nishboo
Private
0
Rep
67
Posts

 
Drives: E92 M3
Join Date: Feb 2013
Location: Orlando, FL

iTrader: (1)

This is really odd, and my car did this today. I have to note the ac was off every time it did it. Not sure if that matters, however with the ac on it doesnt feel like it will stall.

And mine also happened directly after refueling all the way full.

Last edited by nishboo; 12-19-2013 at 07:57 PM.
Appreciate 0
      12-19-2013, 09:56 PM   #14
UroGator
Private
UroGator's Avatar
0
Rep
88
Posts

 
Drives: 2008 MR E92 M3 6MT
Join Date: Aug 2013
Location: FL

iTrader: (2)

Quote:
Originally Posted by nishboo
This is really odd, and my car did this today. I have to note the ac was off every time it did it. Not sure if that matters, however with the ac on it doesnt feel like it will stall.

And mine also happened directly after refueling all the way full.
How low was your fuel (how many miles left to empty) before you filled up? I have had a complete stall out when I tried to let the tank get too empty. I don't have any problems when I refill with around 40 miles left on tank.
Appreciate 0
      12-19-2013, 10:46 PM   #15
fastmike
Second Lieutenant
3
Rep
259
Posts

 
Drives: E93 M3
Join Date: Mar 2011
Location: USA

iTrader: (0)

Quote:
Originally Posted by UroGator View Post
How low was your fuel (how many miles left to empty) before you filled up? I have had a complete stall out when I tried to let the tank get too empty. I don't have any problems when I refill with around 40 miles left on tank.
My car does this when I fill up also.

I mentioned this to my mechanic, he had a plausible theory (which I don't remember). Something to do with the charcoal canister could be failing, something about a valve not opening, so it dumps into the engine when its idling causing the sputtering/stall out because its too rich. He didn't make it sound like a big deal and mostly for smog.
Appreciate 0
      12-20-2013, 01:15 AM   #16
4corners
Captain
4corners's Avatar
United_States
21
Rep
818
Posts

 
Drives: 2008 Jet Black M3 Coupe
Join Date: Feb 2011
Location: Yucca Valley, CA - Kelowna, BC

iTrader: (0)

Garage List
2008 BMW M3  [0.00]
2007 Ford E350 4x4  [2.75]
Idle control device
Appreciate 0
      12-20-2013, 02:23 AM   #17
swhat
Lieutenant
12
Rep
480
Posts

 
Drives: '11 MW E92
Join Date: May 2010
Location: Bay Area

iTrader: (1)

It happened to me too. I think it's the child temperature and bad gas. I normally use shells, but recently changed to chevron and hasn't happened yet.
Appreciate 0
      12-20-2013, 02:28 AM   #18
nishboo
Private
0
Rep
67
Posts

 
Drives: E92 M3
Join Date: Feb 2013
Location: Orlando, FL

iTrader: (1)

Quote:
Originally Posted by UroGator View Post
How low was your fuel (how many miles left to empty) before you filled up? I have had a complete stall out when I tried to let the tank get too empty. I don't have any problems when I refill with around 40 miles left on tank.
I had 58 miles til empty.. Its not doing it anymore, only after a complete refueling.
Appreciate 0
      12-20-2013, 02:36 AM   #19
Vic311
Banned
United_States
17
Rep
1,469
Posts

 
Drives: 2011 e92 M3
Join Date: Dec 2012
Location: NY

iTrader: (0)

Could be vapor lock, air in the system? Would explain why it seems to happen on fill up. Should maybe check the fuel filler neck for any leaks
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:32 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST