BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      10-07-2013, 11:54 AM   #1
wuzupfoo
First Lieutenant
wuzupfoo's Avatar
8
Rep
315
Posts

 
Drives: 08 Jet Black MTrizz Cpe
Join Date: Jun 2009
Location: Mean streets of Irvine

iTrader: (2)

Codes and Service?

Hey so over the weekend I got two random error messages. First started with "Increased Emissions" which comes and goes so I wasn't too concerned but all of sudden after really getting on it.. a new code Ive never seen popped up, "Fuel Pump Error" then the car went into limp mode (Only rev to 5 or 6K).

This AM I went to the car thinking Id have to baby it till I get to my service appt. on Friday but the CEL is gone... car runs fine though Im rather paranoid esp. after limp mode since Ive never had the car do that before.

My question is even though the car is not showing an active CEL and errors when I take it in BMW they should see it right? I just don't want to have to argue with my SA about something being wrong.
__________________
HRE C20/Remus Race/MS Filter/KWV3/Vorsteiner Diffuser/JL Lip/Murdered Grills/Pinnacle F1 Ceramic/ZCP Wing/Alcantara Wheel/Custom Alcantara Boots/Custom ZCP Shifter/MRF Subframe Bushings/Turner Delrin Diff Bushings
Appreciate 0
      10-08-2013, 06:10 PM   #2
wuzupfoo
First Lieutenant
wuzupfoo's Avatar
8
Rep
315
Posts

 
Drives: 08 Jet Black MTrizz Cpe
Join Date: Jun 2009
Location: Mean streets of Irvine

iTrader: (2)

all these views and no answer... must mean Im probably sol... and need to replicate it before I go in...
__________________
HRE C20/Remus Race/MS Filter/KWV3/Vorsteiner Diffuser/JL Lip/Murdered Grills/Pinnacle F1 Ceramic/ZCP Wing/Alcantara Wheel/Custom Alcantara Boots/Custom ZCP Shifter/MRF Subframe Bushings/Turner Delrin Diff Bushings
Appreciate 0
      10-08-2013, 06:14 PM   #3
LightWerkz
Banned
13
Rep
534
Posts

 
Drives: E90 M3
Join Date: May 2007
Location: Oakland, NJ

iTrader: (1)

My increased emissions light came and went a few times. Pretty sure they replaced an oil sensor. You can bring it in, I think the fault is stored and they should know whats up.
Appreciate 0
      10-08-2013, 06:32 PM   #4
wuzupfoo
First Lieutenant
wuzupfoo's Avatar
8
Rep
315
Posts

 
Drives: 08 Jet Black MTrizz Cpe
Join Date: Jun 2009
Location: Mean streets of Irvine

iTrader: (2)

Quote:
Originally Posted by LightWerkz View Post
My increased emissions light came and went a few times. Pretty sure they replaced an oil sensor. You can bring it in, I think the fault is stored and they should know whats up.
Cool thanks, I'll find out one way or another when I take it in this weekend.
__________________
HRE C20/Remus Race/MS Filter/KWV3/Vorsteiner Diffuser/JL Lip/Murdered Grills/Pinnacle F1 Ceramic/ZCP Wing/Alcantara Wheel/Custom Alcantara Boots/Custom ZCP Shifter/MRF Subframe Bushings/Turner Delrin Diff Bushings
Appreciate 0
      10-09-2013, 11:22 AM   #5
///Mpatient
Private
0
Rep
53
Posts

 
Drives: 2008 E92 M3
Join Date: Mar 2013
Location: Nashville

iTrader: (0)

This happened to me, I had to replace the fuel pump.
It sucked, about $600-$750 after labor and everything.

Good luck
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:05 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST