BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      10-02-2013, 08:58 AM   #1
jms_w
Second Lieutenant
 
jms_w's Avatar
 
Drives: '08 SG E93 M3
Join Date: May 2008
Location: VA

Posts: 252
iTrader: (0)

Clicking sound from passenger rear area when weight is loaded

When I make a hard left turn at 15mph or more I hear clicking from the passenger rear area. It is louder the more load is put on that side and the clicking is faster as I drive faster. I do not hear the clicking when driving in a straight line, even with the top down. Has anyone had this problem? Hopefully it's something I can repair myself. Car out of warranty. Thanks in advance.
__________________

jms_w
'08 E93 M3 SG | BLK | 6MT

Last edited by jms_w; 10-02-2013 at 03:27 PM.
jms_w is offline  
0
Reply With Quote
      10-02-2013, 09:54 PM   #2
ThatGuyMikee
Captain
 
ThatGuyMikee's Avatar
 
Drives: 2008 m3 e90 6spd
Join Date: Jul 2012
Location: Staten island

Posts: 698
iTrader: (2)

Theirs a thread about this problem somewhere, if inremeber it was
The rear brake dust shield making the noise on turns
ThatGuyMikee is offline  
0
Reply With Quote
      10-03-2013, 08:00 AM   #3
jms_w
Second Lieutenant
 
jms_w's Avatar
 
Drives: '08 SG E93 M3
Join Date: May 2008
Location: VA

Posts: 252
iTrader: (0)

Thanks. I've read a few of them. Mine seems different. Doesn't happen from a dead stop. Only happens when I turn left and hard (weight of car leaning on right side). No scraping sounds. I'll try looking at the rear brake shield for a pebble but with the way I drive it should've been gone a long time ago. I've had this nuisance for months now. I'll keep everyone posted.
jms_w is offline  
0
Reply With Quote
      10-19-2013, 07:27 PM   #4
jms_w
Second Lieutenant
 
jms_w's Avatar
 
Drives: '08 SG E93 M3
Join Date: May 2008
Location: VA

Posts: 252
iTrader: (0)

So I was finally able to find the thread that speaks to this very issue. And it's only because another member responded to an older thread. When you search for "clicking" I get stuff related to brake dust shields. BUT if you search for "ticking" I get this thread:

http://www.m3post.com/forums/showthread.php?t=283458

Hopefully this helps those using the "wrong" search criteria.
__________________

jms_w
'08 E93 M3 SG | BLK | 6MT
jms_w is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:19 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST