BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Post Reply
 
Thread Tools Search this Thread
      08-04-2013, 03:17 PM   #1
flea333
Lieutenant
 
flea333's Avatar
 
Drives: 2013 M3 ZCP, LMB, DCT
Join Date: Jan 2011
Location: South Bay Area, CA

Posts: 446
iTrader: (0)

Garage List
2008 328i  [0.00]
Y cable doesn't work with Pandora/BMW Apps

What is the Y-cable not working with the BMW Apps? What cable do they expect you to use? I need to find a short regular USB cable I guess?

Also the dumbest thing in the world that you can't charge your phone with the USB and continue to use the Bluetooth audio... wtf is that?!

Then after I connect the USB if I come back in the car the Bluetooth connection doesn't reestablish automatically, I have to go into my iPhone and press the Bluetooth connection to reestablish.

I don't think BMW actually tested this system before releasing it...
flea333 is offline   United_States
0
Reply With Quote
      08-04-2013, 03:58 PM   #2
nullrouted
Studying...
 
nullrouted's Avatar
 
Drives: AW '13 E92 ZCP 6MT M3
Join Date: Apr 2013
Location: North Central Florida

Posts: 850
iTrader: (0)

Quote:
Originally Posted by flea333
What is the Y-cable not working with the BMW Apps? What cable do they expect you to use? I need to find a short regular USB cable I guess?

Also the dumbest thing in the world that you can't charge your phone with the USB and continue to use the Bluetooth audio... wtf is that?!

Then after I connect the USB if I come back in the car the Bluetooth connection doesn't reestablish automatically, I have to go into my iPhone and press the Bluetooth connection to reestablish.

I don't think BMW actually tested this system before releasing it...
I have not had any problems with the Bluetooth re-establishing connection upon entering the car with my iPhone5, is your phone running 6.1.3/4? However I do agree that the charging=no audio is dumb as hell. Made me switch from Spotify via BT to MOG via USB to compensate. I do not use the Y cable, just the standard iPhone cable to the USB port in the console.
nullrouted is offline   United_States
0
Reply With Quote
      08-05-2013, 01:08 AM   #3
flea333
Lieutenant
 
flea333's Avatar
 
Drives: 2013 M3 ZCP, LMB, DCT
Join Date: Jan 2011
Location: South Bay Area, CA

Posts: 446
iTrader: (0)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by nullrouted View Post
I have not had any problems with the Bluetooth re-establishing connection upon entering the car with my iPhone5, is your phone running 6.1.3/4? However I do agree that the charging=no audio is dumb as hell. Made me switch from Spotify via BT to MOG via USB to compensate. I do not use the Y cable, just the standard iPhone cable to the USB port in the console.
I've got iPhone 4, maybe that's why? I noticed my phone acts a little screwy with other blue tooth too...but it's outta 3 mo warranty before I could figure out something seems wrong fer's.

Anyway, I hope that a BMW software update can fix the bluetooth streaming audio as it is dumb a f*!

So you've had better experience with MOG over Spotify? I just use Pandora for now and that seems to be OK with BMW, even though I find it easier to open Pandora and select my iPhone instead of trying to go to the Apps as it won't come up easily.

But ya, I guess I'll have to buy another iPhone cable to put in the car, hopefully they make short ones so I don't have to coil it up. I don't know why the Y cable won't let it work...seems ridiculous. Should be upgrading to iPhone 5 or Android soon anyway...
flea333 is offline   United_States
0
Reply With Quote
      08-05-2013, 01:53 AM   #4
ILSMKU
BMW FTW
 
ILSMKU's Avatar
 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

Posts: 1,638
iTrader: (5)

Garage List
Guys... Keeps BT streaming on and just plug your USB wire into the USB port in the glove box. That way it won't turn off BT streaming. BT streaming will pick up where it left off as you get in and out of the car. And if you need a charge it will without disabling BT streaming!

That's how I do it to use pandora. That whole disabling Bluetooth, launching connected drive, and loading the pandora plug in is lame IMO.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
ILSMKU is offline   No_Country
0
Reply With Quote
      08-05-2013, 05:52 AM   #5
rngrjag
Private First Class
 
Drives: E92 M3 ZCP 6MT
Join Date: May 2013
Location: USA

Posts: 117
iTrader: (0)

...on the Y cable

Folks, just received my 2013 M3. Dealership says no Y cable necessary now because you just use the power cord from associated iDevice. States that BMW no longer includes the Y cable with the car. Window sticker doesn't specify whether Y cable came with car. Salesman assures me that Y cable did not come with car. Plugged in iPod to USB port and, surprise, no charging. I went and bought the damned cable, but I want to know if I should have had to.

Can anyone else who picked up a 2013 M tell me whether their car came with the Y cable?

Thanks.
rngrjag is offline  
0
Reply With Quote
      08-05-2013, 07:13 AM   #6
alee0729
Lieutenant
 
alee0729's Avatar
 
Drives: 2013 E92 M3, 2001 E46 330Ci
Join Date: Mar 2013
Location: New York, NY

Posts: 416
iTrader: (0)

Quote:
Originally Posted by rngrjag View Post
Can anyone else who picked up a 2013 M tell me whether their car came with the Y cable?
Never used a Y cable before, and car didn't come with one.

Have always used the white iPhone cable with the armrest USB port and never had an issue. This is with an iPhone 5.
__________________
2001 E46 330Ci - 43K miles, 2013 E92 M3 - Back from PCD
Thinking about doing European Delivery? Read about my ED experience. Best trip, ever.
alee0729 is offline  
0
Reply With Quote
      08-05-2013, 08:59 AM   #7
nullrouted
Studying...
 
nullrouted's Avatar
 
Drives: AW '13 E92 ZCP 6MT M3
Join Date: Apr 2013
Location: North Central Florida

Posts: 850
iTrader: (0)

Quote:
Originally Posted by rngrjag
Folks, just received my 2013 M3. Dealership says no Y cable necessary now because you just use the power cord from associated iDevice. States that BMW no longer includes the Y cable with the car. Window sticker doesn't specify whether Y cable came with car. Salesman assures me that Y cable did not come with car. Plugged in iPod to USB port and, surprise, no charging. I went and bought the damned cable, but I want to know if I should have had to.

Can anyone else who picked up a 2013 M tell me whether their car came with the Y cable?

Thanks.
Mine did not. Prodded the delivery guy at the Welt about it and he said the same thing as your dealer, so I assume that is the truth.
nullrouted is offline   United_States
0
Reply With Quote
      08-05-2013, 09:24 PM   #8
rngrjag
Private First Class
 
Drives: E92 M3 ZCP 6MT
Join Date: May 2013
Location: USA

Posts: 117
iTrader: (0)

Thanks for the responses guys.
rngrjag is offline  
0
Reply With Quote
      08-06-2013, 04:05 AM   #9
flea333
Lieutenant
 
flea333's Avatar
 
Drives: 2013 M3 ZCP, LMB, DCT
Join Date: Jan 2011
Location: South Bay Area, CA

Posts: 446
iTrader: (0)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by ILSMKU View Post
Guys... Keeps BT streaming on and just plug your USB wire into the USB port in the glove box. That way it won't turn off BT streaming. BT streaming will pick up where it left off as you get in and out of the car. And if you need a charge it will without disabling BT streaming!

That's how I do it to use pandora. That whole disabling Bluetooth, launching connected drive, and loading the pandora plug in is lame IMO.
ILSMKU --- yes I finally dug through the manual and it looks like I totally neglected to go into the "OPTIONS" of the bluetooth connection. Apparently the default is NOT to reestablish audio etc.

I haven't played with it yet but I'm sure it will resolve the issue - hopefully as you describe above... Looks like there is two options under "Options"

1 - "Bluetooth® (audio)" selection box under the options
2 - Options -> Configure phone -> Activate "Audio" check box makes sure the phone will stream audio.

I haven't experimented with what each do. Seems like the same option to me.

The manual says whatever those options are will be remembered each time the phone connects. So for some reason the initial connection automatically connects the audio, but the settings aren't set to reconnect...weird.

Anyway, not sure I want a cable hanging out of my glove box, that's pretty cheesy. Actually, you're best bet is to just use a charger from the 12V plug inside the glove box. They have slim USB adapter plugs that fit right in the cigarette plug.

The reason this is so lame is that now you cannot utilize both Bluetooth AND all the connected drive features. It's just nonsense.
flea333 is offline   United_States
0
Reply With Quote
      08-06-2013, 04:09 AM   #10
flea333
Lieutenant
 
flea333's Avatar
 
Drives: 2013 M3 ZCP, LMB, DCT
Join Date: Jan 2011
Location: South Bay Area, CA

Posts: 446
iTrader: (0)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by rngrjag View Post
Folks, just received my 2013 M3. Dealership says no Y cable necessary now because you just use the power cord from associated iDevice. States that BMW no longer includes the Y cable with the car. Window sticker doesn't specify whether Y cable came with car. Salesman assures me that Y cable did not come with car. Plugged in iPod to USB port and, surprise, no charging. I went and bought the damned cable, but I want to know if I should have had to.

Can anyone else who picked up a 2013 M tell me whether their car came with the Y cable?

Thanks.
Hey -- my guy told me the same thing, I wanted to make sure I got the Y cable. He said it isn't needed. I said, well I'd like one anyway. He gave me one. But had he told me what I know now -- the iDrive doesn't support the Apps features over the Y cable I wouldn't have insisted.

This is the only issue. The Y cable still works with the audio plug plugged in. However, if you try to access any BMW Apps such as Pandora it gives you a message saying to connect your phone using a USB cable. This may be a design issue with the iPhone too that automatically only allows audio out of the analog cable if present, dunno.

Either way, best bet is to upgrade to iPhone 5, which of course isn't supported by the snap in adapter. F*** BMW... get your electronics design together.
flea333 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:50 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST