BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      04-24-2013, 02:46 PM   #1
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

clock and trip reset everytime

my clock and trip reset every times start the car ,repair shop had install new interstate battery and register , but the problem still there , anyone have this problem before please give advise . thank you
E93blackdct is offline  
0
Reply With Quote
      04-24-2013, 03:04 PM   #2
M3amigos
HP addict
 
M3amigos's Avatar
 
Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

Posts: 255
iTrader: (0)

Did they reprogram the ecu so it knows a new battery was installed? Also, if you changed the amperage rating, that needs to be coded. If this hasn't been done you need a trip to the dealer or shop that has this capability. You can also buy the cable and download the tools to do it yourself if you are tech savvy. Plenty of info about this online.
__________________
2008 Jerez Black Metallic E93 6MT
K&N Drop In Filter | HPA Pulley | Custom Catless Resonated X-Pipe | BPM Stage II Tune | Megan Racing Exhaust
M3amigos is offline   United_States
0
Reply With Quote
      04-24-2013, 03:19 PM   #3
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,823
iTrader: (8)

Quote:
Originally Posted by M3amigos
Did they reprogram the ecu so it knows a new battery was installed? Also, if you changed the amperage rating, that needs to be coded. If this hasn't been done you need a trip to the dealer or shop that has this capability. You can also buy the cable and download the tools to do it yourself if you are tech savvy. Plenty of info about this online.
^this
__________________
edwinm3 is offline   United_States
0
Reply With Quote
      04-24-2013, 05:54 PM   #4
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by M3amigos
Did they reprogram the ecu so it knows a new battery was installed? Also, if you changed the amperage rating, that needs to be coded. If this hasn't been done you need a trip to the dealer or shop that has this capability. You can also buy the cable and download the tools to do it yourself if you are tech savvy. Plenty of info about this online.
Yes the shop that install battery did all that
E93blackdct is offline  
0
Reply With Quote
      04-24-2013, 08:51 PM   #5
M3amigos
HP addict
 
M3amigos's Avatar
 
Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

Posts: 255
iTrader: (0)

The clock reset is an indication of a battery not holding its charge. How long does it sit? You may want to have the new battery tested just in case. I swapped my battery when this happened at about 45k miles and the clock resets went away immediately.
__________________
2008 Jerez Black Metallic E93 6MT
K&N Drop In Filter | HPA Pulley | Custom Catless Resonated X-Pipe | BPM Stage II Tune | Megan Racing Exhaust
M3amigos is offline   United_States
0
Reply With Quote
      04-24-2013, 09:55 PM   #6
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by M3amigos
The clock reset is an indication of a battery not holding its charge. How long does it sit? You may want to have the new battery tested just in case. I swapped my battery when this happened at about 45k miles and the clock resets went away immediately.
I dont drive the car that much , just weeken for little, most the time it in garage , that why i think the battery is bad , but after replace and reprogram it still does the same things , i dont know i should trust interstate battery go with the oem
E93blackdct is offline  
0
Reply With Quote
      04-25-2013, 06:53 AM   #7
M3amigos
HP addict
 
M3amigos's Avatar
 
Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

Posts: 255
iTrader: (0)

Quote:
Originally Posted by E93blackdct
Quote:
Originally Posted by M3amigos
The clock reset is an indication of a battery not holding its charge. How long does it sit? You may want to have the new battery tested just in case. I swapped my battery when this happened at about 45k miles and the clock resets went away immediately.
I dont drive the car that much , just weeken for little, most the time it in garage , that why i think the battery is bad , but after replace and reprogram it still does the same things , i dont know i should trust interstate battery go with the oem
In that case, because the car sits for more than a couple days, the ecu is removing power to some of the accessories to conserve power. A battery tender would more than likely fix this issue.
__________________
2008 Jerez Black Metallic E93 6MT
K&N Drop In Filter | HPA Pulley | Custom Catless Resonated X-Pipe | BPM Stage II Tune | Megan Racing Exhaust
M3amigos is offline   United_States
0
Reply With Quote
      04-25-2013, 09:01 AM   #8
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by M3amigos
Quote:
Originally Posted by E93blackdct
Quote:
Originally Posted by M3amigos
The clock reset is an indication of a battery not holding its charge. How long does it sit? You may want to have the new battery tested just in case. I swapped my battery when this happened at about 45k miles and the clock resets went away immediately.
I dont drive the car that much , just weeken for little, most the time it in garage , that why i think the battery is bad , but after replace and reprogram it still does the same things , i dont know i should trust interstate battery go with the oem
In that case, because the car sits for more than a couple days, the ecu is removing power to some of the accessories to conserve power. A battery tender would more than likely fix this issue.
I did try battery tender in for week , but still does that , back to the shop in wednesday for more check up , thank you for all your imfor
E93blackdct is offline  
0
Reply With Quote
      04-25-2013, 09:04 AM   #9
pbonsalb
Lieutenant Colonel
 
Drives: 08 E90 M3, 99 E36 M3 Turbo
Join Date: Feb 2011
Location: Concord, NH

Posts: 1,669
iTrader: (3)

Happened to me only in the last week or so before I replaced the battery. Has not happened since. I did reset adaption on the battery. To me, it was a sign the battery was on the way out. For months prior to that, the clock had simply been losing time. My car is an 08 and it has been driven regularly, year round. I replaced the battery about a month ago -- it was about 5 years old and the car had about 50k miles.
pbonsalb is online now  
0
Reply With Quote
      04-25-2013, 09:16 AM   #10
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by pbonsalb
Happened to me only in the last week or so before I replaced the battery. Has not happened since. I did reset adaption on the battery. To me, it was a sign the battery was on the way out. For months prior to that, the clock had simply been losing time. My car is an 08 and it has been driven regularly, year round. I replaced the battery about a month ago -- it was about 5 years old and the car had about 50k miles.
It seem like everyone had the same issue like my , after replace battery it take care the problem , but my after the battery replace it still do the same issue . Will have tech check more into it , hate to spend all that money for all that hrs ck up for little thing like this . Thanks you
E93blackdct is offline  
0
Reply With Quote
      04-25-2013, 09:41 AM   #11
skins333
Captain
 
skins333's Avatar
 
Drives: '08 E93 BMW M3 MR/'12 x5d SG
Join Date: May 2009
Location: Northern VA

Posts: 988
iTrader: (2)

Quote:
Originally Posted by E93blackdct View Post
I dont drive the car that much , just weeken for little, most the time it in garage , that why i think the battery is bad , but after replace and reprogram it still does the same things , i dont know i should trust interstate battery go with the oem
I had same trouble couple weeks ago that went away with oem battery change on my m3. I thought I would also mention that a couple years ago I replaced my 2007 335 battery with an interstate one and things worked out just fine too.
skins333 is offline   United_States
0
Reply With Quote
      04-25-2013, 11:04 AM   #12
Peahi
Captain
 
Peahi's Avatar
 
Drives: 2012 M3 CPE
Join Date: Jun 2011
Location: SF Bay Area

Posts: 671
iTrader: (0)

Start driving that thing!!! Your car hates sitting in the garage. Let the tiger out of the cage, lol.

You only live once.
__________________
Peahi is offline  
0
Reply With Quote
      04-25-2013, 12:59 PM   #13
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by Peahi
Start driving that thing!!! Your car hates sitting in the garage. Let the tiger out of the cage, lol.

You only live once.
I will love too, i work only 2 mile from home , when home kid and wife want to go with mini van , i hear you , got make more time to drive that car
E93blackdct is offline  
0
Reply With Quote
      07-26-2013, 01:26 AM   #14
slimmie
First Lieutenant
 
Drives: 2008 JB e92 335i
Join Date: Aug 2008
Location: Los Angeles, Koreatown

Posts: 343
iTrader: (1)

any solution to this?

experiencing the same problem after a battery replacement with registration.
slimmie is offline  
0
Reply With Quote
      07-26-2013, 08:26 AM   #15
schnell325
Bored at work....
 
schnell325's Avatar
 
Drives: '08 M3,'11 335xi
Join Date: Aug 2007
Location: BC

Posts: 3,863
iTrader: (5)

Always lock your car (even if in a secure garage) as this "shuts off" the car from draining the battery as quick vs if it was unlocked.
__________________
'08 M3: AA G2L3, Catless X-Pipe & Sig Series Rear. AP rods. TC Kline EDC Coil Overs. MRF Alum Sub Frame Bushings. TMS Delrin Diff'l Bushings. BFI Motor Mounts. Recaro PP. BMW Perf Steering Wheel. P3 Gauge. PS Overflow Kit. APEX ARC-8 18"x9.5"/10.5". Conti Slicks 275/35F 305/30R. Stoptech Pads/SS Lines. Cantrell Brake Ducts.
http://5252motorsports.blogspot.ca/2...3-sleeper.html
schnell325 is offline   Canada
0
Reply With Quote
      07-27-2013, 08:04 PM   #16
E93blackdct
New Member
 
Drives: E93 black dct , ess vt2-585
Join Date: Oct 2012
Location: Syracuse new york

Posts: 24
iTrader: (0)

Quote:
Originally Posted by slimmie
any solution to this?

experiencing the same problem after a battery replacement with registration.
Finally the shop find out , one of the connection in battery cable was not inplace , it take 2 day to find the problem , tell the shop that change the battery check all the connection , this battery cable is very sensetive. Good luck
E93blackdct is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST