BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      07-20-2013, 12:33 PM   #1
elim11
Captain
 
Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

Posts: 618
iTrader: (10)

EDC Connector Always Loose?

Hey guys,
Every week or so I get an EDC malfunction error, Drive with caution.

I typically unplug and re-plug the connectors on the top of the front struts and the error will go away for about a week-2weeks, then re-appear.

Anyone have any ideas? (I'm riding on swift springs)

Thanks
__________________
elim11 is offline  
0
Reply With Quote
      07-20-2013, 05:43 PM   #2
W Cole
Captain
 
Drives: 2009 M3
Join Date: Dec 2010
Location: Newport Coast, CA

Posts: 724
iTrader: (4)

Sounds like a loose connector but Im not an expert.

Can you tighten the connectors at all slightly with perhaps a pliers?
W Cole is offline  
0
Reply With Quote
      07-23-2013, 07:02 PM   #3
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,721
iTrader: (6)

Maybe wrap teflon tape (or something similar) around the connector before inserting it to make it a little tighter?
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      07-25-2013, 09:13 AM   #4
Car54
Captain
 
Drives: 1999 Z3 Mcoupe | 2008 M3/4
Join Date: Sep 2007
Location: Lutz, FL

Posts: 837
iTrader: (1)

Are you getting the weather cover sealed properly in the strut tower?
__________________

Craig Brickner
BM
W CCA/PBOC/Chin Motorsports DE Instructor
Click to Join: BMWCCA # 366493
Car54 is offline  
0
Reply With Quote
      07-25-2013, 11:47 AM   #5
elim11
Captain
 
Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

Posts: 618
iTrader: (10)

The error came back again after 1 wk. I will try the teflon tape to get a tighter seal.
__________________
elim11 is offline  
0
Reply With Quote
      07-25-2013, 11:50 AM   #6
elim11
Captain
 
Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

Posts: 618
iTrader: (10)

Question, are you suppose to feel a "click" to know when it is inserted properly? I just push it down, but not too hard...afraid to cause the fragile metal pins to bend or break.
__________________
elim11 is offline  
0
Reply With Quote
      07-25-2013, 06:57 PM   #7
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,721
iTrader: (6)

Quote:
Originally Posted by elim11 View Post
Question, are you suppose to feel a "click" to know when it is inserted properly? I just push it down, but not too hard...afraid to cause the fragile metal pins to bend or break.
In my experience (3 cars), it does not click. It just pushes in until it stops. In one case I went back to double check because I was unsure. You are doing it correctly most likely.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      07-26-2013, 11:28 AM   #8
elim11
Captain
 
Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

Posts: 618
iTrader: (10)

Quote:
Originally Posted by Car54 View Post
Are you getting the weather cover sealed properly in the strut tower?
Yeah, I am getting the weather cover sealed properly.
__________________
elim11 is offline  
0
Reply With Quote
      07-26-2013, 11:28 AM   #9
elim11
Captain
 
Drives: e90m3
Join Date: Apr 2008
Location: irvine/sf

Posts: 618
iTrader: (10)

Quote:
Originally Posted by M3PO View Post
In my experience (3 cars), it does not click. It just pushes in until it stops. In one case I went back to double check because I was unsure. You are doing it correctly most likely.
Thanks for double checking and confirming. We will see if the PTFE tape helps.
__________________
elim11 is offline  
0
Reply With Quote
      07-26-2013, 11:55 AM   #10
Evolve-US
BimmerPost Supporting Vendor

 
Evolve-US's Avatar
 
Drives: E92 M3
Join Date: Jan 2013
Location: USA

Posts: 267
iTrader: (0)

I believe they do click when they are fully locked. If the above solutions don't help you can always purchase new ones or find someone who is no longer using them
Evolve-US is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:09 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST