BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      07-03-2014, 02:27 PM   #1
evoXtoM3
Private
 
Drives: Black Coupe E92 M3
Join Date: Jul 2013
Location: Pittsburgh PA

Posts: 61
iTrader: (1)

Another Reduced Power Post... Help!

car is a 2008 E92 M3 DCT. No engine mods besides a catless X-pipe and ACM catback.

So I'm trying to sell the car as I am almost done with college and wont be able to afford both school loans and the payments for the car and most people get scared when I tell them the car will go into a reduced power mode. Now onto what the car is doing..

Plain and simple if you start the car and try and drive it right away the car will go into the reduced power mode after about 5 seconds of driving "I made two videos" If I let the car warm up for a minute or two the car drives and runs fine no matter what circumstance? Doesn't really make any sense to me and I keep having shops "trial and error fix it" and its costing me quite a bit of money for them not to guarantee the fix... The check engine light is on for the no cats from the exhaust and the tail light malfunction is from the excessive vibrations from the exhaust so don't mind those warning lights when you watch the videos..

Ive had this issue ever since I bought the car and the BMW dealer pretty much said screw you, you bought the car As is.. So before anyone buys a car make sure you try and drive the car cold and right away lol as I didn't and let it warm up before taking it out... They took the car in the first time, said it was a faulty hood latch sensor and fixed the issue for maybe a week and started doing it again.. took it back and they then said it was a sensor in the transmission thinking the car is in park when its in drive and wanted $2000 to fix.. Which that wouldn't make sense to me as why wouldn't the car throw the code all the time not just cold starts.

My buddy owns a European shop and said he wanted to try and pressure hose/tube and said he read that cars were having similar problems as mine so I said go for it and try and replace it... Well unfortunately for me it didn't fix it and I'm out another $340..

The issue really doesn't bother me as you should let the car warm up anyway before someone makes a smart comment about that, but im doing it for any possible interest in the car so they have reassurance..

Any help would be greatly appreciated...


evoXtoM3 is offline  
0
Reply With Quote
      07-03-2014, 03:34 PM   #2
tinman831
Captain
 
Drives: M3
Join Date: Oct 2013
Location: DFW

Posts: 603
iTrader: (0)

Did you try to scan the codes to see if any additional ones came up or did you just assume the CEL was because of the no cats?
tinman831 is online now  
0
Reply With Quote
      07-03-2014, 03:57 PM   #3
first350
Private
 
Drives: 2011 M3 E92 ZCP
Join Date: Feb 2013
Location: Seattle

Posts: 79
iTrader: (1)

you shouldn't get a CEL from a catless X-pipe...unless you also have deleted the primary cats. sounds like something else is going on.
__________________
Current: 2011 E92 6MT ZCP
Previous cars: 2012 135 DCT, lotus 7 turbo rep, 2005 350z, 1993/1994/1999 Miata, 2008 VW GTI, 1995 BMW 325is,
Previous bikes: 2011 Ducati 848, 2007 Ducati 748s, 1999 Honda CBR600, 1988 GSXR750
first350 is offline  
0
Reply With Quote
      07-03-2014, 04:05 PM   #4
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,526
iTrader: (7)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Could be anything - could be a bad throttle actuator, idle control valve problem, oxygen sensor problem, etc..

Scan and see what the faults are, no sense in guessing as there are tons of things that could cause this.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      07-03-2014, 04:14 PM   #5
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,540
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
If only when cold, perhaps taking a good look at the secondary air pump.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      07-03-2014, 04:21 PM   #6
tdott
First Lieutenant
 
Drives: M3
Join Date: Nov 2010
Location: T.Dot

Posts: 387
iTrader: (1)

Why haven't you scanned for fault codes like Mike suggests?

Quote:
Originally Posted by first350 View Post
you shouldn't get a CEL from a catless X-pipe...unless you also have deleted the primary cats. sounds like something else is going on.
A Catless X Pipe removes both cats, hence the name, catless.
__________________
tdott is offline  
0
Reply With Quote
      07-03-2014, 10:47 PM   #7
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,526
iTrader: (7)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by thekurgan View Post
If only when cold, perhaps taking a good look at the secondary air pump.
Secondary air pump won't cause an Engine Malfunction error, it will only cause an increased emissions error.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      07-04-2014, 05:52 PM   #8
evoXtoM3
Private
 
Drives: Black Coupe E92 M3
Join Date: Jul 2013
Location: Pittsburgh PA

Posts: 61
iTrader: (1)

Do you need a specific cable for BMW? I was told yes and don't feel like spending a ton of money for them. I have access to 3-4 scanners if you don't need a specific one or program.
evoXtoM3 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:08 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST