BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Cosmetic/Visual (Exterior + Interior) Modifications
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      03-08-2013, 02:30 AM   #1
jkim723
Private
 
jkim723's Avatar
 
Drives: E92 M3
Join Date: Feb 2008
Location: Cincinnati, OH

Posts: 71
iTrader: (4)

OEM 6MT shift knob not lighting up

Well a few months back I noticed the numbers on my shift knob stopped lighting up. It's really been bugging me these days, and my warranty expired in October so I can't take it to the dealer. All the other button's light up fine. Any idea's what the problem could be?

I just ordered the F10 M5 illuminated shift knob so I'm praying it lights up when I install it.
jkim723 is offline  
0
Reply With Quote
      03-08-2013, 02:52 AM   #2
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,682
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Have you lifted the boot to check the connector yet?
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      03-08-2013, 09:19 AM   #3
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,065
iTrader: (44)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Sounds like you're covered either way.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      03-08-2013, 10:07 AM   #4
Bel-Tirid
Private First Class
 
Drives: M3 e92 Interlagos blue
Join Date: Dec 2010
Location: Slovenia

Posts: 112
iTrader: (0)

F10 m5 shift knob is only illuminated or can u order without illumination ?
Bel-Tirid is offline  
0
Reply With Quote
      03-08-2013, 10:15 AM   #5
SROC5
Addicted to Track
 
SROC5's Avatar
 
Drives: E92 M3
Join Date: Apr 2009
Location: USCON

Posts: 1,587
iTrader: (3)

Quote:
Originally Posted by jkim723 View Post
Well a few months back I noticed the numbers on my shift knob stopped lighting up. It's really been bugging me these days, and my warranty expired in October so I can't take it to the dealer. All the other button's light up fine. Any idea's what the problem could be?

I just ordered the F10 M5 illuminated shift knob so I'm praying it lights up when I install it.
Sounds like loose connector, you'll probably be fine.
__________________

| Akrapovic Evo | ESSi | Swift Spec-R | CF Spoiler | APEX ARC-8 | RS-3 | PFC-08 | DIF |
SROC5 is offline   United_States
0
Reply With Quote
      03-09-2013, 12:55 AM   #6
jkim723
Private
 
jkim723's Avatar
 
Drives: E92 M3
Join Date: Feb 2008
Location: Cincinnati, OH

Posts: 71
iTrader: (4)

Quote:
Originally Posted by thekurgan View Post
Have you lifted the boot to check the connector yet?
Never tried until today, and this is what I find.



Well now I know what the problem was, so the new knob should be lighting up just fine...
jkim723 is offline  
0
Reply With Quote
      03-09-2013, 09:37 AM   #7
mdosu
Banned
 
Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

Posts: 8,517
iTrader: (6)

Quote:
Originally Posted by Bel-Tirid View Post
F10 m5 shift knob is only illuminated or can u order without illumination ?
No lights = is just the standard E9x zhp knob, a lot cheaper than the m5 knob, bc it doesn't come with the base ring
mdosu is offline   No_Country
0
Reply With Quote
      03-09-2013, 09:44 AM   #8
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,682
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Quote:
Originally Posted by jkim723 View Post
Never tried until today, and this is what I find.


Well now I know what the problem was, so the new knob should be lighting up just fine...
Those look like clean cuts?
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      04-04-2013, 12:41 PM   #9
kornykidd0
Private
 
Drives: 2008 E90 M3
Join Date: Feb 2012
Location: Yardley PA

Posts: 90
iTrader: (1)

Dumb question, did ALL model years of the e9x M3 have a lighted shift knob? My 2008 doesn't light up, but I haven't pulled the boot to see if it just isn't plugged in or what yet...sort of just assumed maybe '08s didn't light up to begin with?
kornykidd0 is offline  
0
Reply With Quote
      04-04-2013, 02:40 PM   #10
gatorfast
Colonel
 
gatorfast's Avatar
 
Drives: MR E90 M3
Join Date: Jan 2008
Location: SoFla

Posts: 2,539
iTrader: (3)

Quote:
Originally Posted by kornykidd0 View Post
Dumb question, did ALL model years of the e9x M3 have a lighted shift knob? My 2008 doesn't light up, but I haven't pulled the boot to see if it just isn't plugged in or what yet...sort of just assumed maybe '08s didn't light up to begin with?
Yes they all light up. My 2008 has a lighted knob.
gatorfast is offline  
0
Reply With Quote
      04-04-2013, 11:04 PM   #11
jkim723
Private
 
jkim723's Avatar
 
Drives: E92 M3
Join Date: Feb 2008
Location: Cincinnati, OH

Posts: 71
iTrader: (4)

Quote:
Originally Posted by kornykidd0 View Post
Dumb question, did ALL model years of the e9x M3 have a lighted shift knob? My 2008 doesn't light up, but I haven't pulled the boot to see if it just isn't plugged in or what yet...sort of just assumed maybe '08s didn't light up to begin with?
As gator mentioned, all 2008 are supposed to light up. In my case, the knob was lighting just fine and one day I noticed it stopped. I'm not sure how it got cut, but my guess is that maybe it happened during shifting??

My recommendation is to upgrade to the M5 shift knob
jkim723 is offline  
0
Reply With Quote
      04-05-2013, 07:39 AM   #12
yosman8
Private
 
Drives: F80 M3 MW/SO ordered
Join Date: Nov 2012
Location: MN/CA

Posts: 61
iTrader: (0)

Quote:
Originally Posted by kornykidd0 View Post
Dumb question, did ALL model years of the e9x M3 have a lighted shift knob? My 2008 doesn't light up, but I haven't pulled the boot to see if it just isn't plugged in or what yet...sort of just assumed maybe '08s didn't light up to begin with?
I have a 2008 and it lights up.
yosman8 is offline   United_States
0
Reply With Quote
      04-05-2013, 08:36 AM   #13
Endless619
DHS
 
Endless619's Avatar
 
Drives: bmw x5, m3, Acura TL
Join Date: Oct 2010
Location: Disneyland

Posts: 3,920
iTrader: (14)

They all light up but this was the first ugly looking thing to leave my M3.

Went with the Performance shift knob as its the best looking and feeling one for my M3.

I still cant see why a lot of you folks like the uncomfortable feeling, ugly looking, high sitting OEM shift knob. I just don't get it. It is not appealing in any way.

Who cares if it lights up or not. That is not a requirement for shifting gears. lol
Endless619 is offline   Spain
0
Reply With Quote
      04-12-2013, 08:06 AM   #14
kornykidd0
Private
 
Drives: 2008 E90 M3
Join Date: Feb 2012
Location: Yardley PA

Posts: 90
iTrader: (1)

Quote:
Originally Posted by jkim723 View Post
As gator mentioned, all 2008 are supposed to light up. In my case, the knob was lighting just fine and one day I noticed it stopped. I'm not sure how it got cut, but my guess is that maybe it happened during shifting??

My recommendation is to upgrade to the M5 shift knob
Sorry to bump this back up. Yesterday I popped my shift boot up to take a look at why my shift knob wasn't lighting up and I found EXACTLY the same cuts as you had - nice, clean snips. I don't see how that could happen during shifting. I assume you just stripped the wires and reconnected them right? The conspiracy theorist in me says it's part of BMW protocol to snip those wires in order to reject a claim or something. There's no need to snip them when installing an unlighted ZHP knob right? Just unplug the wire and you're set...
kornykidd0 is offline  
0
Reply With Quote
      04-12-2013, 04:50 PM   #15
jkim723
Private
 
jkim723's Avatar
 
Drives: E92 M3
Join Date: Feb 2008
Location: Cincinnati, OH

Posts: 71
iTrader: (4)

Quote:
Originally Posted by kornykidd0 View Post
Sorry to bump this back up. Yesterday I popped my shift boot up to take a look at why my shift knob wasn't lighting up and I found EXACTLY the same cuts as you had - nice, clean snips. I don't see how that could happen during shifting. I assume you just stripped the wires and reconnected them right? The conspiracy theorist in me says it's part of BMW protocol to snip those wires in order to reject a claim or something. There's no need to snip them when installing an unlighted ZHP knob right? Just unplug the wire and you're set...
I really can't think of any other explanation besides the wire somehow getting cut during shifting. I didn't even strip and reconnect the wires. I replaced the stock knob for a M5 shift knob. I think it's pretty much the ZCP knob but lights up? Straight plug and play, easy to install.
jkim723 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:53 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST