BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
rolloface
Post Reply
 
Thread Tools Search this Thread
      01-03-2009, 08:56 PM   #1
homel01
New Member
 
Drives: E92 M3 DCT
Join Date: Sep 2008
Location: Puerto Rico

Posts: 25
iTrader: (0)

Transmision, Engine, Emisions Problem.... HELPPPP

I looked through many most of the threads and didnt find anyone with this problem.

My car turned the check engine on and I decided to take it to BMW, driving the car to the BMW shop i turned 3 new things on. 1) increased emisions on
2) transmision failure 3) engine failure speed reduced or something like that and the car will go slower and will not accelerate like it is suppossed to.

I took the car to BMW and they told me that they were to reprogram the whole car plus reprogram the transmision because it had a recall.

I took the car back homw (1 hour 45 min far)
Drove the car for 1 day and lights came back, whe the car is turned on it will only say the emisions thing plus the check engine.

Drive the car for a while and as soon as it starts up and downshifting for a while the transmision thing comes on,
drive it a little longer and the engine bulsht.... comes on


Im really mad and dissapointed with this car I've been a BMW owner for a while and in sick of this type of problem

I owned a 2002 745i and sold it 2 months after buying it because of computer related problems like this one

I had a E46 M3 best car that has been buil by BMW i track it in solo 1, autocross, drag race it and street race it my car was modified like hell and never gave sht like this it put 70k miles on the cra in 3 years and it never cry

But this new M3 only has 4k miles and has never been race it, its been 4 months since i bought it , i have never launched the car. I just wish that someone at BMW USA reads this. Because i paid 104,000 US $$$ for this car in Puerto Rico and the car is a pain....
homel01 is offline  
0
Reply With Quote
      01-09-2009, 02:39 AM   #2
elmariachi
Major
 
elmariachi's Avatar
 
Drives: BMW ///M Division
Join Date: Jan 2007
Location: Singapore

Posts: 1,323
iTrader: (1)

Looks like a junction box failure. I dont think its anything serious if thats the issue. Have faith bro. I also had some minor hiccups but all good now. And i paid 250K USD for a car here in Singapore. Learn and let live. I am certain BMW will solve your problems for you.

Cheers!
__________________

2008 E92 ///M3 Alpine White M-DCT| Novillo-Black Interior| Carbon Fibre Roof| Premium Sound System| EDC| 19's Advan RS w/ Michelin PS2 Cups| iPod| GruppeM Air Intake| GruppeM Steel Braided Lines|Ferodo DS2500 Pads| Akrapovic Full Header-Back Titanium Exhaust| 6000K Philips D1S| 3M Tints|
elmariachi is offline  
0
Reply With Quote
      01-09-2009, 11:26 PM   #3
09E92M34ME
Captain
 
Drives: 2009 E92 M3
Join Date: Jul 2008
Location: VIRGINIA

Posts: 864
iTrader: (0)

Did they change your DCT fluid by mistake?
__________________
09 E92 M3,AW/FR. MODS:Performane Kidney Grills,Side Gills,Exhaust Tips,BMW Performance Pedals,359 Satin Black GTS Wheels,275/35/19R & 255/35/19F PSS's,Dinan Stage I Suspension,Macht Schnell Spacers 12mmF,5mmR,Rear Fogs,Euphoria 6k,LCI Tails,LUX v3,OEM IND Painted Alpine White CF Performance Spoiler, Front Splitters, and Front Reflectors,Gloss Black Hood Vents,M Performance Steering Wheel.
09E92M34ME is offline   United_States
0
Reply With Quote
      01-09-2009, 11:28 PM   #4
09E92M34ME
Captain
 
Drives: 2009 E92 M3
Join Date: Jul 2008
Location: VIRGINIA

Posts: 864
iTrader: (0)

Quote:
Originally Posted by elmariachi View Post
Looks like a junction box failure. I dont think its anything serious if thats the issue. Have faith bro. I also had some minor hiccups but all good now. And i paid 250K USD for a car here in Singapore. Learn and let live. I am certain BMW will solve your problems for you.

Cheers!
WOW! 250k US. You need to at least change your picture in your signature to the M3 for that price.
__________________
09 E92 M3,AW/FR. MODS:Performane Kidney Grills,Side Gills,Exhaust Tips,BMW Performance Pedals,359 Satin Black GTS Wheels,275/35/19R & 255/35/19F PSS's,Dinan Stage I Suspension,Macht Schnell Spacers 12mmF,5mmR,Rear Fogs,Euphoria 6k,LCI Tails,LUX v3,OEM IND Painted Alpine White CF Performance Spoiler, Front Splitters, and Front Reflectors,Gloss Black Hood Vents,M Performance Steering Wheel.
09E92M34ME is offline   United_States
0
Reply With Quote
      01-13-2009, 04:39 PM   #5
MTrizzy
Lieutenant
 
MTrizzy's Avatar
 
Drives: 2008 AW M3 Coupe
Join Date: Mar 2008
Location: Potomac, MD

Posts: 448
iTrader: (1)

I just got a service engine soon light the other day....car is in the shop right now I hope mine doesnt turn out this way (although I am 6MT so i dont need the DCT software update)

just to clarify My car is also saying increased emissions...initial reports from the dealer are a stuck thermostat though...nothing software realted
__________________

AW E92 M3|E92 LuX|Piaa GTX H3| Rear Fog Light Mod | Ventureshield (Raja)
|Eisenmann Race Exhaust |Macht Schnell Filter | Black Grills | Black Sides | H&R Springs | Fabspeed X-Pipe & High Flow Cats| CF VRS II rep diffuser|Most powerful Scoops in the world|

Last edited by MTrizzy; 01-13-2009 at 04:40 PM. Reason: update
MTrizzy is offline   United_States
0
Reply With Quote
      01-14-2009, 02:35 AM   #6
elmariachi
Major
 
elmariachi's Avatar
 
Drives: BMW ///M Division
Join Date: Jan 2007
Location: Singapore

Posts: 1,323
iTrader: (1)

Quote:
Originally Posted by 09E92M34ME View Post
WOW! 250k US. You need to at least change your picture in your signature to the M3 for that price.
I think I should. Working on it now!.
__________________

2008 E92 ///M3 Alpine White M-DCT| Novillo-Black Interior| Carbon Fibre Roof| Premium Sound System| EDC| 19's Advan RS w/ Michelin PS2 Cups| iPod| GruppeM Air Intake| GruppeM Steel Braided Lines|Ferodo DS2500 Pads| Akrapovic Full Header-Back Titanium Exhaust| 6000K Philips D1S| 3M Tints|
elmariachi is offline  
0
Reply With Quote
      02-15-2009, 11:38 AM   #7
dillon733
Major
 
dillon733's Avatar
 
Drives: Jet Black e92 M3
Join Date: Oct 2007
Location: new york

Posts: 1,126
iTrader: (2)

Quote:
Originally Posted by homel01 View Post
I looked through many most of the threads and didnt find anyone with this problem.

My car turned the check engine on and I decided to take it to BMW, driving the car to the BMW shop i turned 3 new things on. 1) increased emisions on
2) transmision failure 3) engine failure speed reduced or something like that and the car will go slower and will not accelerate like it is suppossed to.

I took the car to BMW and they told me that they were to reprogram the whole car plus reprogram the transmision because it had a recall.

I took the car back homw (1 hour 45 min far)
Drove the car for 1 day and lights came back, whe the car is turned on it will only say the emisions thing plus the check engine.

Drive the car for a while and as soon as it starts up and downshifting for a while the transmision thing comes on,
drive it a little longer and the engine bulsht.... comes on


Im really mad and dissapointed with this car I've been a BMW owner for a while and in sick of this type of problem

I owned a 2002 745i and sold it 2 months after buying it because of computer related problems like this one

I had a E46 M3 best car that has been buil by BMW i track it in solo 1, autocross, drag race it and street race it my car was modified like hell and never gave sht like this it put 70k miles on the cra in 3 years and it never cry

But this new M3 only has 4k miles and has never been race it, its been 4 months since i bought it , i have never launched the car. I just wish that someone at BMW USA reads this. Because i paid 104,000 US $$$ for this car in Puerto Rico and the car is a pain....
happened to me 2 days ago adn the car is in the shop now.I have dct btw.
dillon733 is offline  
0
Reply With Quote
      02-25-2013, 12:45 PM   #8
Ioannis
Private First Class
 
Ioannis's Avatar
 
Drives: BMW M4
Join Date: Dec 2011
Location: Pensylvania

Posts: 176
iTrader: (0)

Hey guys anyone knows why all of the sudden the check engine came plus the increase emissions ,it has to do with the exuast maybe leaking .Thank you.
Ioannis is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:16 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST