BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Strasse Forged
Post Reply
 
Thread Tools Search this Thread
      01-20-2016, 12:16 AM   #1
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

USB key not being read

Hi, I am very new to BMWs just purchased 2011 335i xdrive with m package and wanted to update the maps.

I cannot get the software update to work. It does not recognize the USB key in any of the ports. I have nothing but the Nav 2016-1 updates on it. I used Mac to format the drives as FAT. I have tried two different USB drives.

Any help would be much appreciated.

Thanks.
Appreciate 0
      01-20-2016, 01:03 AM   #2
mrMTB
Private First Class
16
Rep
145
Posts

Drives: 2009 e92 M3
Join Date: Apr 2015
Location: Seattle, WA

iTrader: (0)

Do you have the check mark over the "i" in your interface? (See attached)

__________________
09 e92 M3 | 6MT | Interlagos Blue over Fox Red | Premium | Technology | Cold Weather | +RVC | +Combox | +MPE
Appreciate 0
      01-20-2016, 01:07 AM   #3
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
Do you have the check mark over the "i" in your interface? (See attached)

Hi thanks for your reply, yes I do have a check mark.
Appreciate 0
      01-20-2016, 02:24 AM   #4
mrMTB
Private First Class
16
Rep
145
Posts

Drives: 2009 e92 M3
Join Date: Apr 2015
Location: Seattle, WA

iTrader: (0)

And the config.nfm and pkgdb files are in the root of the USB drive? Are you using the USB port in the glove box?
__________________
09 e92 M3 | 6MT | Interlagos Blue over Fox Red | Premium | Technology | Cold Weather | +RVC | +Combox | +MPE
Appreciate 0
      01-20-2016, 02:26 AM   #5
mrMTB
Private First Class
16
Rep
145
Posts

Drives: 2009 e92 M3
Join Date: Apr 2015
Location: Seattle, WA

iTrader: (0)

Also, you mentioned you'd formatted it as FAT. Reformat the drive to FAT32, and try again.
__________________
09 e92 M3 | 6MT | Interlagos Blue over Fox Red | Premium | Technology | Cold Weather | +RVC | +Combox | +MPE
Appreciate 0
      01-20-2016, 02:27 AM   #6
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
And the config.nfm and pkgdb files are in the root of the USB drive? Are you using the USB port in the glove box?
Yes, it has the the appropriate files only.

I also tried using the same stick with music and it works in the center console but not in the glove compartment.
Appreciate 0
      01-20-2016, 02:28 AM   #7
mrMTB
Private First Class
16
Rep
145
Posts

Drives: 2009 e92 M3
Join Date: Apr 2015
Location: Seattle, WA

iTrader: (0)

Quote:
Originally Posted by Akber View Post
I also tried using the same stick with music and it works in the center console but not in the glove compartment.
Glove compartment port is only for updates, not media.
__________________
09 e92 M3 | 6MT | Interlagos Blue over Fox Red | Premium | Technology | Cold Weather | +RVC | +Combox | +MPE
Appreciate 0
      01-20-2016, 02:28 AM   #8
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
Also, you mentioned you'd formatted it as FAT. Reformat the drive to FAT32, and try again.
I used apple to format it and I believe Fat means Fat32 using disk utility.
Appreciate 0
      01-20-2016, 02:29 AM   #9
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
Glove compartment port is only for updates, not media.
I think it is also used to upload music.
Appreciate 0
      01-20-2016, 02:33 AM   #10
mrMTB
Private First Class
16
Rep
145
Posts

Drives: 2009 e92 M3
Join Date: Apr 2015
Location: Seattle, WA

iTrader: (0)

Go to the terminal, and type

diskutil list

When you get to the USB drive, make a note of the device path (for example /dev/disk3). Make certain you know the correct disk number.

Use the following command to reformat the device:

sudo diskutil eraseDisk FAT32 Maps MBRFormat /dev/diskX

Replace "diskX" with the appropriate disk device. After that recopy the files to the drive. When I updated my maps, I believe it took three or four minutes for the CIC to prompt to start installing.
__________________
09 e92 M3 | 6MT | Interlagos Blue over Fox Red | Premium | Technology | Cold Weather | +RVC | +Combox | +MPE
Appreciate 0
      01-20-2016, 02:42 AM   #11
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
Go to the terminal, and type

diskutil list

When you get to the USB drive, make a note of the device path (for example /dev/disk3). Make certain you know the correct disk number.

Use the following command to reformat the device:

sudo diskutil eraseDisk FAT32 Maps MBRFormat /dev/diskX

Replace "diskX" with the appropriate disk device. After that recopy the files to the drive. When I updated my maps, I believe it took three or four minutes for the CIC to prompt to start installing.
Thanks a lot. Just formatted as you suggested. It will take 2 hours to copy back all the files to the drive. I will let you know it worked tomorrow. Thanks again for all your help.

Appreciate 0
      01-20-2016, 11:40 PM   #12
Akber
New Member
0
Rep
7
Posts

Drives: BMW 335i Xdrive M Package
Join Date: Jan 2016
Location: Ottawa

iTrader: (0)

Quote:
Originally Posted by mrMTB View Post
Go to the terminal, and type

diskutil list

When you get to the USB drive, make a note of the device path (for example /dev/disk3). Make certain you know the correct disk number.

Use the following command to reformat the device:

sudo diskutil eraseDisk FAT32 Maps MBRFormat /dev/diskX

Replace "diskX" with the appropriate disk device. After that recopy the files to the drive. When I updated my maps, I believe it took three or four minutes for the CIC to prompt to start installing.
Sorry to report but it still did not work. The USb port in the glove compartment does not work. I am going to see the dealer to see if they can figure out what is going on.

Thanks.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:38 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST