BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      08-26-2014, 08:14 PM   #1
kristianbmw21
New Member
0
Rep
6
Posts

 
Drives: e92
Join Date: Aug 2014
Location: peru

iTrader: (0)

Exclamation ABS , DSC LIGHTS ON and (!) this morning

Hi everybody First of all , Sorry for my bad english im from lima peru
and i bought a 33,000Km M3 e92 2009. DCT a month ago

and today i started up the car on morning and some CEL CODES APEARED.

1-(abs)
2-DSC or something like that.
3-(!) that its from tires level i think.


well ive been looking on internet for this codes and i read on some threads that can be caused by low battery level on car, low brake fluid, or maybe abs sensor/module control

I know i have a bad battery on the car and i thing it might be caused by that.

please i need somebody to tell me if they had the same problem and fixed it by changing battery and cleaning codes on obd2scaner... i dont know what to do i dont want to take it to the dealer right know because i dont trust them im afraid they are going to say its other stuff involved. and maybe its not a big deal.


please ill wait for your fast responses.!

thx u all!
Appreciate 0
      08-26-2014, 08:29 PM   #2
kscarrol
Colonel
United_States
35
Rep
2,297
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Well if you know you have a bad battery anyway, change that first. Should be changed anyway...

If that does not do the trick, I was getting some similar codes and it was a bad wheel speed sensor.
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      08-26-2014, 08:34 PM   #3
E90M3velocity
Second Lieutenant
Philippines
2
Rep
236
Posts

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA

iTrader: (2)

You should of post this at the mechanical or engine threads to get more help. Either way you need to get a code reader and look up the error codes. These are more specific, also theres an error code glossary thread that will help you with more explanation of the error codes. http://www.m3post.com/forums/showthread.php?t=928325
Unfortunately there are several things that can cause those lights and limp mode
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:35 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST