BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      10-21-2014, 03:25 PM   #1
E90M3velocity
Second Lieutenant
Philippines
2

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 230
iTrader: (2)

engine dying

Engine is going into limp mode, dies, and gives out an "increase emissions" message. I try to restart it and it sounds like its running rough, eventually starts sounding normal with limp mode still activated. It keeps shutting off so i cant even bring it to my shop. I have no more warranty so it seems im pretty fucked, but does anyone have a rough idea what it could be? Trying to prepare for the worst.
__________________
Appreciate 0
      10-21-2014, 03:51 PM   #2
IMG
M.POWER
103

 
IMG's Avatar
 
Drives: E36 M3 Track car,Ess E90 M3 DD
Join Date: Feb 2008
Location: Location


Posts: 7,058
iTrader: (6)

Can you scan the car and post the codes stored in the DME ?
__________________
NO FEAR.NO LIMITS.NO EQUAL

Ess VT3 LC built motor,Volk TE37SL,Euro taillights,Dinan Xpipe,Custom Headers,Akra axle back CF tips,ModeCarbon FR lip,BMW CF wing
LOW BOOST 60-130 6.7 sec
Appreciate 0
      10-21-2014, 04:05 PM   #3
4corners
Captain
United_States
19

 
4corners's Avatar
 
Drives: 2008 Jet Black M3 Coupe
Join Date: Feb 2011
Location: Yucca Valley, CA - Kelowna, BC


Posts: 806
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
2007 Ford E350 4x4  [2.75]
Throttle actuator? SCAN IT!! easy to fix if that's it
Appreciate 0
      10-21-2014, 04:20 PM   #4
Mike Benvo
BimmerPost Supporting Vendor
United_States
92


 
Mike Benvo's Avatar
 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal


Posts: 4,765
iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
If it's shutting off it's probably not a throttle actuator - sounds like a bad crank sensor to me.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 1
      10-21-2014, 06:09 PM   #5
K-M3
Second Lieutenant
2

 
Drives: '12 M3
Join Date: Sep 2011
Location: DFW, TX


Posts: 276
iTrader: (0)

Faulty idle control valve?? Faulty O2 sensor maybe ?? I am no mechanical expert ... Just thinkin out loud re the common issues with this motor ...
Appreciate 0
      10-21-2014, 07:42 PM   #6
vividracing
BimmerPost Supporting Vendor
United_States
137


 
vividracing's Avatar
 
Drives: 2011 BMW M3 DCT
Join Date: Aug 2006
Location: Arizona


Posts: 3,726
iTrader: (13)

Send a message via AIM to vividracing
Check engine lights? You have the codes??

-Anthony
__________________

480.966.3040 Ext: 226
Call and ask for Sean for quotes and special M3post pricing!
www.vividracing.com

Sean@VividRacing.com
Appreciate 0
      10-21-2014, 08:07 PM   #7
MilehighM3
Colonel
21

 
MilehighM3's Avatar
 
Drives: E90 M3
Join Date: May 2011
Location: Colorado Springs


Posts: 2,162
iTrader: (9)

Stalling is likely an idle control valve issue. Codes are needed to know for sure though.
Appreciate 0
      10-21-2014, 09:20 PM   #8
tinman831
Captain
7

 
Drives: M3
Join Date: Oct 2013
Location: DFW


Posts: 796
iTrader: (0)

It's all a stab in the dark until he gets the codes read.
Appreciate 0
      10-21-2014, 09:32 PM   #9
m3ray
Captain
No_Country
69

 
m3ray's Avatar
 
Drives: '09 e92 M3
Join Date: Jun 2014
Location: New York City


Posts: 682
iTrader: (0)

Quote:
Originally Posted by tinman831 View Post
It's all a stab in the dark until he gets the codes read.
This.
Appreciate 0
      10-21-2014, 10:04 PM   #10
ciges
Enlisted Member
United_States
0

 
ciges's Avatar
 
Drives: 2008 E90 M3 IB 6MT
Join Date: Aug 2014
Location: NV


Posts: 40
iTrader: (0)

Sounds like rod bearings to me
__________________
Appreciate 0
      10-21-2014, 10:06 PM   #11
spdy330
Major General
United_States
98

 
spdy330's Avatar
 
Drives: 05 Tundra, 11 M3, 08 Odyssey
Join Date: Dec 2009
Location: Chino, CA


Posts: 6,058
iTrader: (160)

Garage List
Send a message via AIM to spdy330 Send a message via Yahoo to spdy330
Oh no you didn't!

Quote:
Originally Posted by ciges View Post
Sounds like rod bearings to me
__________________
If you will be purchasing ANY AT&T services online or in store could you mention that you were referred by me? My Employee Referral ID is eo4489. This would be a great help, thank you!
Appreciate 0
      10-22-2014, 08:28 AM   #12
E90M3velocity
Second Lieutenant
Philippines
2

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 230
iTrader: (2)

Im going to have to get it towed to the shop later today to pull the codes, just wondering someone out there experienced this problem. Its not throttle actuators as they are new. I'll ask the shop to check the crank sensor, thanks mike.
__________________
Appreciate 0
      10-23-2014, 08:35 PM   #13
E90M3velocity
Second Lieutenant
Philippines
2

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 230
iTrader: (2)

My shop couldnt find a definite solution even dealing with the tech info from autologic. They did reset the ecu adaptations and it drives really good now and better than it did before these problems manifested. No limp mode or engine stalls on the way home. I do have a persistent error code for the map sensor (i had it for last two times i pulled codes after going into limp mode), which they ordered one just in case it happens again. Here are the error codes for people wondering-
CDB7 (Had edc coded out)
27AB- charge plausibility, diagnosis hot - bank 2
27AA- charge plausibility, diagnosis hot - bank 1
2738- charge plausibility, diagnosis, cold-start strategy, bank 2
2B0D- idle actuator monitoring, bank 1
2714- intake-manifold pressure sensor
2B29- moment manager monitoring
__________________
Appreciate 0
      10-27-2014, 11:04 AM   #14
E90M3velocity
Second Lieutenant
Philippines
2

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 230
iTrader: (2)

Well it didnt fixed it! It went into limp mode this morning with dsc malfunction so i turned it off and started it back up. Ran rough like it did before.
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:22 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST