BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
PYSPEED
Post Reply
 
Thread Tools Search this Thread
      12-03-2012, 04:15 PM   #1
JamesKilcarr
Enlisted Member
 
Drives: 2011 jet black e92 m3
Join Date: Sep 2012
Location: queens ny

Posts: 49
iTrader: (0)

Increased emissions becuase of exhaust leak?

Hi everyone i have a fabspeed x pipe but no hfc just the stock cats, iv driven with this setup for 10,000miles and havent gotten this warning before i know i have An exhaust leak is that whats causing this to show up? The car says service engine soon increased emmisions. If i fix the leak will this warning go away? Any help would be much appreciated. Thanks
JamesKilcarr is offline  
0
Reply With Quote
      12-03-2012, 07:59 PM   #2
signes
Brigadier General
 
signes's Avatar
 
Drives: E90 M3
Join Date: Sep 2008
Location: Spinnin at 8k

Posts: 4,207
iTrader: (3)

A leak would generate a CEL, but you should get it fixed regardless. Where is it? You have both the primary and secondary stock cats still on? You could also have a faulty O2 sensor among about 1000 other reasons.
__________________
08 E90 | Jet Black / Black | 6MT
Mods: RAC RG63 w/ Pirelli Corsa 255F/285R | Akrapovic Evo Exhaust | OEM Blacklines
Winter Setup: OEM 18s w/ Nokian Hakkapeliita R 245/40-18
signes is offline   United_States
0
Reply With Quote
      12-03-2012, 08:34 PM   #3
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal

Posts: 4,699
iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by signes View Post
A leak would generate a CEL, but you should get it fixed regardless. Where is it? You have both the primary and secondary stock cats still on? You could also have a faulty O2 sensor among about 1000 other reasons.
A leak in the exhaust system may not trigger any CEL - depends where it is.

You probably have an o2 sensor that has a problem, if you're confident there isn't a leak somewhere.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      12-03-2012, 08:35 PM   #4
Pontrelli
Banned
 
Drives: e92 M3
Join Date: Nov 2012
Location: Dallas, TX

Posts: 157
iTrader: (0)

This car relies heavily on 100% fit exhaust for its performance,,you should make sure to correct all leaks, make sure to use exhaust assembly paste between all slip joints...once you do that you can clear the codes..and it wont come back assuming this was the reason for the code to begin with
Pontrelli is offline  
0
Reply With Quote
      12-03-2012, 09:35 PM   #5
JamesKilcarr
Enlisted Member
 
Drives: 2011 jet black e92 m3
Join Date: Sep 2012
Location: queens ny

Posts: 49
iTrader: (0)

Quote:
Originally Posted by signes View Post
A leak would generate a CEL, but you should get it fixed regardless. Where is it? You have both the primary and secondary stock cats still on? You could also have a faulty O2 sensor among about 1000 other reasons.
i have the primary cats still on, i had it like this for the last 10,000 miles at least and it never gave a problem i turned the code off and it just came back on its the codes 2298, and 0492
JamesKilcarr is offline  
0
Reply With Quote
      12-03-2012, 09:36 PM   #6
JamesKilcarr
Enlisted Member
 
Drives: 2011 jet black e92 m3
Join Date: Sep 2012
Location: queens ny

Posts: 49
iTrader: (0)

Quote:
Originally Posted by Mike Benvo View Post
A leak in the exhaust system may not trigger any CEL - depends where it is.

You probably have an o2 sensor that has a problem, if you're confident there isn't a leak somewhere.
it is the joint right before the primary cats its the joining between the front of the x pipe and the primary cats, i turned the cel off and it just came back on its codes 2298 and 0492
JamesKilcarr is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:41 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST