BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      04-02-2013, 08:27 PM   #1
jaehshim
Captain
 
jaehshim's Avatar
 
Drives: E90 M3
Join Date: Dec 2008
Location: Northern NJ

Posts: 722
iTrader: (1)

Increased Emission, then gone...okay?

was driving on highway, increased emission + check engine light came on.
It was one for one more day (drove ~ 40 miles)
Then today the sign is gone.
Okay? or take it to dealer? searched here and it seems this may indicate all sorts of random things.
__________________
jaehshim is offline   United_States
0
Reply With Quote
      04-02-2013, 08:40 PM   #2
RBB
First Lieutenant
 
RBB's Avatar
 
Drives: E92 M3
Join Date: Mar 2012
Location: NOVA

Posts: 344
iTrader: (10)

Pull your codes....I'm sure something will be stored.
RBB is offline  
0
Reply With Quote
      04-02-2013, 08:48 PM   #3
1MtoM3
HayZeus
 
1MtoM3's Avatar
 
Drives: 2012 E92 M3
Join Date: Jan 2013
Location: Brossard , Canada

Posts: 302
iTrader: (0)

mine did that first 200 kms.....then gone since . never checked at dealer, will inquire at 2000km oil change .
__________________
BLOME !!!

MW E92 , Turner test pipes , Vorsteiner Titanium catback, TMS spacers, ESS remap , KW sleeves.
1MtoM3 is offline   Canada
0
Reply With Quote
      04-02-2013, 09:27 PM   #4
FVM3
Major General
 
FVM3's Avatar
 
Drives: e92 m3, f30 328i
Join Date: Sep 2010
Location: Los Angeles

Posts: 5,711
iTrader: (2)

check it when your next service is up
FVM3 is offline  
0
Reply With Quote
      04-04-2013, 12:22 AM   #5
Sirius Black
Private First Class
 
Sirius Black's Avatar
 
Drives: 2009 E90 M3 6sp man
Join Date: Jan 2012
Location: Annapolis, MD

Posts: 180
iTrader: (0)

I had that a while back, replacing the front O2 sensors took care of it.
__________________

2009 E90 M3|ACTIVE AUTOWERKE GEN 2 LVL 3 SC|TTP|FABSPEED XPIPE|AE EXHAUST|RD SPORT SPRINGS|TTFS CUSTOM TUNE
Sirius Black is offline  
0
Reply With Quote
      04-04-2013, 01:35 PM   #6
DNTJDGM3
Boss Man
 
DNTJDGM3's Avatar
 
Drives: E46 M3 Sedan//ZCP M3 6MT
Join Date: Nov 2010
Location: Turn Around

Posts: 77
iTrader: (0)

GHOST CODE?

Quote:
Originally Posted by jaehshim View Post
was driving on highway, increased emission + check engine light came on.
It was one for one more day (drove ~ 40 miles)
Then today the sign is gone.
Okay? or take it to dealer? searched here and it seems this may indicate all sorts of random things.
Im going thru the same exact thing now ; both increased emission and check engine light would come on about after the same amount of driving and cause the car to redline at 4k. It wont even allow you to rev over 2k (not that i would want to anyway with all these lights on). But anyway i would take the car to the dealer and the tech would claim no lights were on and no codes were stored. No one knows what is going on with my car and i am starting to get a little frustrated. Its as if i am getting a ghost code. Happens when i drive gone when dealer starts working on car. I had o2 sensors replaced and still same problem.
__________________
E92 /// ZCP M3 6MT Mineral White - Fox red
"Stop beggin for spots and grab a lane motherf***er"
DNTJDGM3 is offline   United_States
0
Reply With Quote
      04-04-2013, 01:45 PM   #7
leemik
Major
 
Drives: 2013 LRP M3 Coupe
Join Date: Jan 2009
Location: Quincy, MA

Posts: 1,342
iTrader: (2)

Garage List
2013 BMW M3  [4.67]
My 2009 did that the first week I got it.. Dealer found it was a faulty gas cap that they replace under warranty.. so sometimes it's as simple as that.
__________________
leemik is offline   United_States
0
Reply With Quote
      04-18-2013, 11:31 PM   #8
///WeissBlitz76
First Lieutenant
 
///WeissBlitz76's Avatar
 
Drives: '13 E92 ZCP M3
Join Date: Feb 2011
Location: TN

Posts: 306
iTrader: (0)

Anyone ever heard of this happening after driving with engine throttle response set to Sport Plus mode? I think mine is doing that. It seems to be fine whenever it is on 'Normal' or 'Sport', but then throws a CEL and the increased emissions warning whenever I press the 'M' button and turn Sport Plus on. That lasts for about 3 driving cycles if I don't use it, and then typically goes away.
///WeissBlitz76 is offline   United_States
0
Reply With Quote
      04-19-2013, 11:07 AM   #9
urnzvay
Enlisted Member
 
Drives: 2008 E90 M3 6MT
Join Date: Dec 2012
Location: Boise

Posts: 32
iTrader: (0)

Had this happen to me, turned out to be the low pressure fuel sensor. Easy to get to and fix.
urnzvay is offline  
0
Reply With Quote
      04-19-2013, 03:52 PM   #10
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,727
iTrader: (6)

You should probably go ahead and sell it before the engine blows up.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      04-19-2013, 04:32 PM   #11
///WeissBlitz76
First Lieutenant
 
///WeissBlitz76's Avatar
 
Drives: '13 E92 ZCP M3
Join Date: Feb 2011
Location: TN

Posts: 306
iTrader: (0)

Quote:
Originally Posted by M3PO View Post
You should probably go ahead and sell it before the engine blows up.
Really? It can do that?
///WeissBlitz76 is offline   United_States
0
Reply With Quote
      04-19-2013, 04:34 PM   #12
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,727
iTrader: (6)

Quote:
Originally Posted by blitzboy76 View Post
Really? It can do that?
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:54 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST