BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Post Reply
 
Thread Tools Search this Thread
      10-11-2012, 08:48 PM   #1
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Engine revving by itself during cold start?'

This has happened twice today.

Outside temperate is about 7 - 10 Celsius.

I start the car, reverse out of the stall and proceed out of the lot at about 20 - 30 KM/H, at say 2000RPM.

Then all of the sudden, I hear engine revving and sure enough, RPM needle is jumping from 500RPM to 1500RPM, and this happened for about 4 or 5 times.

WTF??? Am I alone here?
FairladyZ is offline  
0
Reply With Quote
      10-11-2012, 09:28 PM   #2
Sean05
Putcha ang ganda...
 
Sean05's Avatar
 
Drives: 08 MR E92 M3
Join Date: Feb 2010
Location: Los Angeles, Brea CA.

Posts: 5,287
iTrader: (9)

Send a message via Yahoo to Sean05
ICV probably the cause but if your not getting a cel then im pretty sure your Low fuel pressure sensor is going out...

I had the same issue when its really cold then finally a cel P0175 and P0172 replaced the Low fuel pressure sensor and it worked.. my idle is good at stays below 1k even at 30f...
__________________
Sean05 is offline   Philippines
0
Reply With Quote
      10-11-2012, 09:41 PM   #3
MStar
Banned
 
Drives: e92 M3
Join Date: Oct 2012
Location: Here and there

Posts: 290
iTrader: (0)

Not normal
MStar is offline   No_Country
0
Reply With Quote
      10-11-2012, 09:51 PM   #4
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Quote:
Originally Posted by Sean05
ICV probably the cause but if your not getting a cel then im pretty sure your Low fuel pressure sensor is going out...

I had the same issue when its really cold then finally a cel P0175 and P0172 replaced the Low fuel pressure sensor and it worked.. my idle is good at stays below 1k even at 30f...
I think you are right! What is ICV by the way?

So when CEL does come on, will tjf engine suddenly cut power on me?

My low fuel light usually comes on right below the quarter tank mark.
FairladyZ is offline  
0
Reply With Quote
      10-11-2012, 09:55 PM   #5
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Just googled. ICV = idle control valve.

What would cause this valve or sensor to go bad? Does my driving habit has anything to do with this?
FairladyZ is offline  
0
Reply With Quote
      10-11-2012, 10:21 PM   #6
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Here we go, this is similar to what I am experiecing, except mine isn't as bad:

FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 01:20 PM   #7
Invadermoose
Private First Class
 
Drives: camaro
Join Date: Apr 2012
Location: florida

Posts: 144
iTrader: (0)

God damnit.. I thought this was normal. Sort of how the car is jerky when you first turn it on. My car does this sometimes for like 2 seconds after I start it.. Its like 90 degrees here
Invadermoose is offline  
0
Reply With Quote
      10-12-2012, 01:24 PM   #8
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

I'm going to the dealership again. I'm so fed up with this car. Had it for less than a year and a series of problems:

- Rear suspension squeaking (fixed)
- Brake booster vacuum pump failure (fixed)
- Front wheel bearing making noise when turning (fixed)

Now this.

I will NEVER buy a German car again. My friends Audi and Merc also take frequent trips to the shops for repair.
FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 02:39 PM   #9
MStar
Banned
 
Drives: e92 M3
Join Date: Oct 2012
Location: Here and there

Posts: 290
iTrader: (0)

Quote:
Originally Posted by FairladyZ View Post
I'm going to the dealership again. I'm so fed up with this car. Had it for less than a year and a series of problems:

- Rear suspension squeaking (fixed)
- Brake booster vacuum pump failure (fixed)
- Front wheel bearing making noise when turning (fixed)

Now this.

I will NEVER buy a German car again. My friends Audi and Merc also take frequent trips to the shops for repair.


High performance cars..to be expected
MStar is offline   No_Country
0
Reply With Quote
      10-12-2012, 02:42 PM   #10
NoM3ForMe
Major
 
NoM3ForMe's Avatar
 
Drives: '04 Quest, '07 Kia Sorrento
Join Date: Aug 2008
Location: ...location, location?

Posts: 1,423
iTrader: (0)

Send a message via MSN to NoM3ForMe
Quote:
Originally Posted by Yolkster View Post


High performance cars..to be expected
+1

(pass the popcorn, I brought ).
__________________
try { Life.Live(); } catch (Experience exp) { Console.WriteLine(exp.ToString(); } finally { Brian.Dispose(); }
"There are only 10 kinds of people in the world; those that read binary, and those that don't."
NoM3ForMe is offline   United_States
0
Reply With Quote
      10-12-2012, 02:58 PM   #11
W///
Brigadier General
 
W///'s Avatar
 
Drives: 2008 E92 M3/1999 E36 M3 Coupe
Join Date: Sep 2011
Location: SC

Posts: 4,435
iTrader: (11)

Now that it's colder weather, is anyone else noticing that the car takes just a bit longer to crank?
__________________
2008 E92 M3: Sparkling Graphite | Bamboo Beige | 6MT | CF Roof | HRE | Eisenmann | BPM Sport | Swift | Arkym | Mode Carbon | M.Perf
W/// is offline  
0
Reply With Quote
      10-12-2012, 02:59 PM   #12
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

^^^Can't believe you guys are willing to pay $80000 and put up with this BS.
FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 03:27 PM   #13
GIdriver
Major
 
GIdriver's Avatar
 
Drives: 2011 SG/FR E90 M3 DCT
Join Date: Dec 2010
Location: Somewhere in Time

Posts: 1,338
iTrader: (0)

Sounds like the ICV going south?
__________________
Akrapovic Evolution with Carbon Fiber tips | ESS Akra Evo tune V2 | Dinan Pulley | iND Cosmetic Package (Color Matched Front Grilles/Reflectors/Side Gills) in Space Gray | LUX H8 Angel Eyes

GIdriver is offline   United_States
0
Reply With Quote
      10-12-2012, 03:30 PM   #14
GIdriver
Major
 
GIdriver's Avatar
 
Drives: 2011 SG/FR E90 M3 DCT
Join Date: Dec 2010
Location: Somewhere in Time

Posts: 1,338
iTrader: (0)

Quote:
Originally Posted by FairladyZ View Post
^^^Can't believe you guys are willing to pay $80000 and put up with this BS.
LOL!! I paid 100k thanks to a "luxury car tax" implemented where I live...
__________________
Akrapovic Evolution with Carbon Fiber tips | ESS Akra Evo tune V2 | Dinan Pulley | iND Cosmetic Package (Color Matched Front Grilles/Reflectors/Side Gills) in Space Gray | LUX H8 Angel Eyes


Last edited by GIdriver; 10-12-2012 at 04:43 PM.
GIdriver is offline   United_States
0
Reply With Quote
      10-12-2012, 04:03 PM   #15
RBB
First Lieutenant
 
RBB's Avatar
 
Drives: E92 M3
Join Date: Mar 2012
Location: NOVA

Posts: 344
iTrader: (10)

Quote:
Originally Posted by W/// View Post
Now that it's colder weather, is anyone else noticing that the car takes just a bit longer to crank?
I'm noticing this. Takes a few extra cranks in the mornings and I've had a few instances of rev hunting between 700-1200....bounces back and forth for a second or two immediately after starting. Nowhere near as bad as Fairlady's video but not normal cold start procedure. Think I'm going to go ahead and replace my low pressure sensor since its a cheap fix. Hopefully my ICV isn't on the way out.
RBB is offline  
0
Reply With Quote
      10-12-2012, 05:38 PM   #16
W///
Brigadier General
 
W///'s Avatar
 
Drives: 2008 E92 M3/1999 E36 M3 Coupe
Join Date: Sep 2011
Location: SC

Posts: 4,435
iTrader: (11)

Quote:
Originally Posted by RBB View Post
I'm noticing this. Takes a few extra cranks in the mornings and I've had a few instances of rev hunting between 700-1200....bounces back and forth for a second or two immediately after starting. Nowhere near as bad as Fairlady's video but not normal cold start procedure. Think I'm going to go ahead and replace my low pressure sensor since its a cheap fix. Hopefully my ICV isn't on the way out.
Mine takes about a second or 2 longer to crank when it's cold out. Not really a problem in the afternoon when it's back in 60-70 degree weather. Luckily, once it starts, no problem with the fluctuating RPM's though.
__________________
2008 E92 M3: Sparkling Graphite | Bamboo Beige | 6MT | CF Roof | HRE | Eisenmann | BPM Sport | Swift | Arkym | Mode Carbon | M.Perf
W/// is offline  
0
Reply With Quote
      10-12-2012, 05:46 PM   #17
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,708
iTrader: (6)

My car used to do this a bit but not nearly as bad. I used to think that my ICV was going bad. It is solid as a rock ever since I got the DME software updated. :dunno:
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      10-12-2012, 06:25 PM   #18
ILSMKU
BMW FTW
 
ILSMKU's Avatar
 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

Posts: 1,636
iTrader: (5)

Garage List
Quote:
Originally Posted by FairladyZ
^^^Can't believe you guys are willing to pay $80000 and put up with this BS.
I hear ya bro! Mine has been in the shop more than my 4 prior Subaru STI's were COMBINED (03/06/09/11) !!!Mine is doing this funky idle thing too and it just started a week ago for me. It gets old and I'm with you on this.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
ILSMKU is offline   No_Country
0
Reply With Quote
      10-12-2012, 06:35 PM   #19
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Quote:
Originally Posted by ILSMKU View Post
I hear ya bro! Mine has been in the shop more than my 4 prior Subaru STI's were COMBINED (03/06/09/11) !!!Mine is doing this funky idle thing too and it just started a week ago for me. It gets old and I'm with you on this.

That's just it. My previous $40,000 350Z had ONE issues in my 3 years of driving, and now my $80,000 M3 has FOUR issues in less than 1 year.

Come on. I know performance cars are more prone to problems than their lessen counterparts, but when I shell out $80,000 for a car, I don't want to have to make weekly trips to dealerships.

Sounds like you and are I very much on the same boat. Fuck, honestly, I am never buying another German car again. My next car will be a JDM (maybe R35 or something).
FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 06:39 PM   #20
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Quote:
Originally Posted by M3PO View Post
My car used to do this a bit but not nearly as bad. I used to think that my ICV was going bad. It is solid as a rock ever since I got the DME software updated. :dunno:

Quote:
Originally Posted by RBB View Post
I'm noticing this. Takes a few extra cranks in the mornings and I've had a few instances of rev hunting between 700-1200....bounces back and forth for a second or two immediately after starting. Nowhere near as bad as Fairlady's video but not normal cold start procedure. Think I'm going to go ahead and replace my low pressure sensor since its a cheap fix. Hopefully my ICV isn't on the way out.

The video I posted is of another M3 having the same issue. Mine isn't as bad as this, and it hasn't happened today, YET. Mind you today is more like 12 degrees so maybe it only happens when it's -10 degrees cold?
FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 06:42 PM   #21
FairladyZ
Second Lieutenant
 
Drives: 2011 E92 M3
Join Date: Mar 2011
Location: Vancouver

Posts: 227
iTrader: (0)

Quote:
Originally Posted by Team Plutonium View Post
You should start modding your car... you'll hear all kinds of weird noises, random check engine lights will come on, a flat tire will leave you stranded for good, etc... I think you'd deal with it well.

Seriously, sorry for your troubles, but it is hardly the norm for these cars. They are pretty reliable, and fairly bullet proof even when tracked on a regular basis. Once in a while Dieter and Hans build a car while drunk or with a hangover - it happens. You probably got a car built during the Oktoberfest season.

My previous car was modded a bit and you are right, as soon as OEM parts get replaced with aftermakert ones, car started to sound like a tin can with a coin sealed inside.

The M3 is my daily driver, and my job is rather demanding when it comes to time. I just want a damn car that I could drive, forget, rev to 8250RPM, have fun, park and forget it again. And since I haven't modded the M3, I ***SHOULD BE ABLE TO*** have this peace of mind, except that I don't.
FairladyZ is offline  
0
Reply With Quote
      10-12-2012, 06:51 PM   #22
HALOTHANE
First Lieutenant
 
HALOTHANE's Avatar
 
Drives: INTERLAGOS ZCP
Join Date: Jun 2011
Location: Anywhere fast

Posts: 393
iTrader: (0)

Garage List
Quote:
Originally Posted by FairladyZ
I'm going to the dealership again. I'm so fed up with this car. Had it for less than a year and a series of problems:

- Rear suspension squeaking (fixed)
- Brake booster vacuum pump failure (fixed)
- Front wheel bearing making noise when turning (fixed)

Now this.

I will NEVER buy a German car again. My friends Audi and Merc also take frequent trips to the shops for repair.
Uh, you think the Italians or Brits do a better job? This is fair game with any high perf car. You can always get a civic and stick an M badge on it.
HALOTHANE is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:29 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST