BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      10-29-2012, 07:44 PM   #1
Flying05
Private
 
Flying05's Avatar
 
Drives: 2008 E92 M3 Jerez Black
Join Date: Mar 2012
Location: ATL

Posts: 66
iTrader: (0)

Question Iphone 4s aux input noises?

My iphone 4s makes a high pitch screeching noise when plugged into my aux input while playing music (Non usb in my car). It also makes the speakers crack at higher volume where as a cd does not. I tried another cable with the same result. Even tried an ipod which worked better, but still not that good.

The dealer told me awhile back that it is my phone that is causing the problem. The more I think about this it pisses me off because it is unbearable to use so I have just dealt with it. My vw passat does not have this problem at all nor did other cars I had. Am I doing something wrong or is the dealer right? Thanks!!
Flying05 is offline  
0
Reply With Quote
      10-31-2012, 10:01 PM   #2
Flying05
Private
 
Flying05's Avatar
 
Drives: 2008 E92 M3 Jerez Black
Join Date: Mar 2012
Location: ATL

Posts: 66
iTrader: (0)

nobody has this issue? Well this sucks...
Flying05 is offline  
0
Reply With Quote
      11-01-2012, 10:51 AM   #3
YouW1n
Private
 
Drives: 2013 F06 M6 Gran Coupe
Join Date: Oct 2011
Location: Taipei

Posts: 57
iTrader: (2)

well it happens with me too.. i realized this like 2-3 days ago. I haven't tried a new cable yet though. it doesn't bother me much because most of the time i just listen to satellite radio or listen to the music on my iphone 4s through bluetooth.......

sorry no fix.
YouW1n is offline   Taiwan
0
Reply With Quote
      11-01-2012, 12:23 PM   #4
djseto
Private
 
Drives: 2008 M3 Coupe
Join Date: Aug 2012
Location: NC

Posts: 91
iTrader: (0)

I get what sounds like alternator whine or ground noise when I tried the AUX jack so I went to eBay and got the USB cord for $15. USB vs. BlueTooth is night and day. Always go with an attached cord over BT
djseto is offline  
0
Reply With Quote
      11-01-2012, 02:20 PM   #5
MineralWeiss
USAF Retired
 
Drives: 2011 BMW M3
Join Date: Jun 2011
Location: Oklahoma City

Posts: 252
iTrader: (0)

It sounds like you are suffering from a grounding issue between the iPhone and the car. Usually, the easiest way to fix this is with an isolation transformer (aka ground-loop isolator). Here is a sample of two I found on Amazon, but there are several others available.

3.5mm ground-loop isolator cable

PAC 3.5mm isolation cable
MineralWeiss is offline   United_States
0
Reply With Quote
      11-01-2012, 06:59 PM   #6
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,738
iTrader: (7)

I have this issue as well.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      11-01-2012, 08:41 PM   #7
Flying05
Private
 
Flying05's Avatar
 
Drives: 2008 E92 M3 Jerez Black
Join Date: Mar 2012
Location: ATL

Posts: 66
iTrader: (0)

Quote:
Originally Posted by MineralWeiss View Post
It sounds like you are suffering from a grounding issue between the iPhone and the car. Usually, the easiest way to fix this is with an isolation transformer (aka ground-loop isolator). Here is a sample of two I found on Amazon, but there are several others available.

3.5mm ground-loop isolator cable

PAC 3.5mm isolation cable
I guess this is worth the try. If not I don't know what to do. The aux input is unbearable. This is ridiculous for a 70K+ car.
Flying05 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:38 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST