BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      10-31-2012, 05:06 PM   #1
CarbonFoot
First Lieutenant
CarbonFoot's Avatar
6
Rep
332
Posts

 
Drives: 2009 E90 M3 DCT
Join Date: Dec 2011
Location: CA - Bay Area

iTrader: (0)

Anyone else have springs that continue to sag?

I installed a KW sleeve kit early this year and I immediately setup the ride height to be -1"F and -.75"R from stock. Within 2 weeks, the springs settled a little less than .25" in front and little more than .125" in the rear. I then readjusted to bring it back to -1"F and -.75"R and got an alignment done.

So it's been several months since making those adjustments and my car is sitting lower than ever now at -1.25"F and -1.125"R. That's another quarter inch sag in the front and a considerable half inch drop in the rear.

Has anyone else experienced this with KW or any other manufacturer for that matter? Some settling is definitely expected, which is why I waited a few weeks to make my first adjustment. I guess I just didn't expect to need to do it again.
Appreciate 0
      10-31-2012, 08:07 PM   #2
M3PO
Colonel
M3PO's Avatar
34
Rep
2,777
Posts

 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

iTrader: (7)

I have the same kit and I could swear mine has been getting lower. I thought I was crazy...
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
Appreciate 0
      11-01-2012, 02:31 PM   #3
CarbonFoot
First Lieutenant
CarbonFoot's Avatar
6
Rep
332
Posts

 
Drives: 2009 E90 M3 DCT
Join Date: Dec 2011
Location: CA - Bay Area

iTrader: (0)

^^ You're definitely not going crazy. Fortunately, I took very careful measurements along the way to verify that I wasn't going crazy myself.

Hopefully after my next adjustment, enough time will have passed to fully settle the springs and they will stay relatively stable going forward.
Appreciate 0
      11-01-2012, 07:19 PM   #4
Richard@M-World
Richard@M-World's Avatar
United_States
25
Rep
683
Posts

 
Drives: NASA TTA #92 M3
Join Date: May 2011
Location: TX/IL

iTrader: (0)

Give KW tech support a call at 800-445-3767 (8-5 PST) and perhaps they can help you.
__________________
Authorized AiM Dealer - Solo/Solo DL | SmartyCam HD | www.m-world.us
Appreciate 0
      11-01-2012, 08:05 PM   #5
CarbonFoot
First Lieutenant
CarbonFoot's Avatar
6
Rep
332
Posts

 
Drives: 2009 E90 M3 DCT
Join Date: Dec 2011
Location: CA - Bay Area

iTrader: (0)

Not a bad idea. I doubt they'll be able to do anything, but at least they might be able to tell me if I should no longer experience any further settling. Thanks...
Appreciate 0
      11-01-2012, 09:34 PM   #6
eternallx
S2ktoM3
eternallx's Avatar
United_States
2
Rep
207
Posts

 
Drives: 2009 E92
Join Date: Aug 2012
Location: Bergen County, NJ

iTrader: (6)

Assuming you have a 2012 judging by your join date, the oem rubber top mounts sag over time which could be your problem. This is just a guess tho.

Photo by HP Autowerks
http://www.m3post.com/forums/showthr...=716188&page=3

__________________
People don't understand people like us
Appreciate 0
      11-02-2012, 01:24 PM   #7
M3PO
Colonel
M3PO's Avatar
34
Rep
2,777
Posts

 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

iTrader: (7)

Quote:
Originally Posted by eternallx View Post
Assuming you have a 2012 judging by your join date, the oem rubber top mounts sag over time which could be your problem. This is just a guess tho.

Photo by HP Autowerks
http://www.m3post.com/forums/showthr...=716188&page=3

Whoa, that's definitely interesting! I have an 08 though.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
Appreciate 0
      11-05-2012, 10:50 AM   #8
edwinm3
Colonel
edwinm3's Avatar
United_States
38
Rep
2,082
Posts

 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

iTrader: (8)

Quote:
Originally Posted by eternallx
Assuming you have a 2012 judging by your join date, the oem rubber top mounts sag over time which could be your problem. This is just a guess tho.

Photo by HP Autowerks
http://www.m3post.com/forums/showthr...188&page=3

WTF
__________________
Appreciate 0
      11-05-2012, 04:17 PM   #9
Denk
Lieutenant Colonel
United_States
23
Rep
1,960
Posts

 
Drives: E92 M3 ZCP
Join Date: May 2011
Location: PNW

iTrader: (2)

I've never experienced spring sag or even settling. I've played with a few brands of springs on 2 generation M3's, never went the KW route though.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:34 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST