BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Post Reply
 
Thread Tools Search this Thread
      10-21-2012, 11:47 PM   #1
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Apple Lighting adapter cable audio quality sucks

I went and bought a 30 pin to lightning adapter cable (the $39 one) to use with the BMW y-cable for ipod audio and it works... but the audio quality is plain terrible! I unplugged it, ran a regular aux audio cable from the headphone output and it sounds 10x better.

With the adapter plugged into the y-cable the audio sounds super compressed with little dynamic range. FM radio quality... or worse. A far cry from CD quality or the regular y-cable ipod output. It looks like the adapter cable does D/A conversion inside the adapter and whatever it is doing just sounds terrible. The old 30 pin connector passed audio that was D/A converted in the iPhone/iPod which probably has better audio processing.

I am going to return this POS adapter tomorrow. I may have to look into getting an old iPod to use with the Y-cable or just stick to using the Aux cable.

Anyone else have any experience with the adapter?
Z K is offline   United_States
0
Reply With Quote
      10-22-2012, 08:37 AM   #2
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,079
iTrader: (44)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
That sucks. I will be trying mine this week.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      10-22-2012, 10:07 AM   #3
6spdg37s
Captain
 
Drives: none
Join Date: Aug 2012
Location: dirty jerz

Posts: 753
iTrader: (3)

I got my adapter in the mail... still waiting on the car to be built and ship lol
6spdg37s is offline  
0
Reply With Quote
      10-22-2012, 10:21 AM   #4
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Some other people have reported the same problem with bad sound quality but the problem doesn't look consistent. Maybe some of the units are bad? I may try another one to check.

http://forums.macrumors.com/showthread.php?t=1469329
Z K is offline   United_States
0
Reply With Quote
      10-22-2012, 02:50 PM   #5
nchan50
Second Lieutenant
 
Drives: 2009 JzB/FR e92 M3
Join Date: Feb 2011
Location: NYC

Posts: 208
iTrader: (0)

Personally, I just put my music and playlists onto a USB drive and plug it into the armrest compartment. Don't have to deal with any of this craziness and there shouldn't be any loss of audio quality. Works flawlessly for me but can see how that won't work if you're using pandora or all your music is from itunes.
nchan50 is offline  
0
Reply With Quote
      10-22-2012, 03:16 PM   #6
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Quote:
Originally Posted by nchan50 View Post
Personally, I just put my music and playlists onto a USB drive and plug it into the armrest compartment. Don't have to deal with any of this craziness and there shouldn't be any loss of audio quality. Works flawlessly for me but can see how that won't work if you're using pandora or all your music is from itunes.
The USB drive would work except the CCC i-drive can't play 320kps high bitrate mp3 files which most of my music is.
Z K is offline   United_States
0
Reply With Quote
      10-23-2012, 09:20 AM   #7
nchan50
Second Lieutenant
 
Drives: 2009 JzB/FR e92 M3
Join Date: Feb 2011
Location: NYC

Posts: 208
iTrader: (0)

Quote:
Originally Posted by Z K View Post
The USB drive would work except the CCC i-drive can't play 320kps high bitrate mp3 files which most of my music is.
Gotcha - wasn't aware of that.
nchan50 is offline  
0
Reply With Quote
      10-23-2012, 09:26 AM   #8
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,980
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Z K View Post
The USB drive would work except the CCC i-drive can't play 320kps high bitrate mp3 files which most of my music is.
The USB drive is connected to the MULF and then via MOST to the CCC, and it does play 320kps MP3.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      10-23-2012, 12:16 PM   #9
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

According to BMW, 6FL does not support files larger than 256kbps.
Z K is offline   United_States
0
Reply With Quote
      10-23-2012, 06:11 PM   #10
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,980
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Z K View Post
According to BMW, 6FL does not support files larger than 256kbps.
Not correct... try it.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      10-23-2012, 08:48 PM   #11
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Just confirmed.. 320kps does not work.

Plugged in USB drive, the car starts to play it then 2 sec in it stops and freezes. It dumps you to radio and when u go back to select USB again, the USB option is greyed out and is not selectable until u remove and reinsert USB drive.
__________________
Auto Detailing Enthusiast!
Z K is offline   United_States
0
Reply With Quote
      10-23-2012, 09:06 PM   #12
kmarei
Major General
 
kmarei's Avatar
 
Drives: 1988 E30 M3 Evo II
Join Date: Jul 2008
Location: Reston, VA

Posts: 6,479
iTrader: (33)

Garage List
I've played songs encoded at 320kpbs
Not sure if it's your encoder or something else
But the system CAN play 320
__________________
This user has been banned from the 4 series forum because he doesn't sing its merits like the admins want us all to

kmarei is offline   Egypt
0
Reply With Quote
      10-23-2012, 10:23 PM   #13
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

I have tried multiple files from different locations. Playback varies. The 320k constant bitrate chokes within a few seconds consistently no matter where the file is from or what it was encoded under. 320 Variable bit rate files will play longer but it will choke after a while too. Other files that have less than 320kps work fine. Only the 320k files don't work. Could it have to do with I drive version? I have an early 08 build. No updates have been performed.
__________________
Auto Detailing Enthusiast!
Z K is offline   United_States
0
Reply With Quote
      10-24-2012, 12:26 AM   #14
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,980
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by kmarei View Post
I've played songs encoded at 320kpbs
Not sure if it's your encoder or something else
But the system CAN play 320
320kbps and 320kbps VBR works for me as well, both in a USB stick (CCC and CIC, MULF and Combox) and loaded into the HDD (CIC).
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      10-24-2012, 06:00 AM   #15
kmarei
Major General
 
kmarei's Avatar
 
Drives: 1988 E30 M3 Evo II
Join Date: Jul 2008
Location: Reston, VA

Posts: 6,479
iTrader: (33)

Garage List
Wasn't there an update we could install from the USB slot in the glove box?
I recall doing that
But that was on a 2012, not sure about the 08s
__________________
This user has been banned from the 4 series forum because he doesn't sing its merits like the admins want us all to

kmarei is offline   Egypt
0
Reply With Quote
      10-24-2012, 11:36 PM   #16
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Alright... now this is weird. I had left the USB drive in the car since the last time I tested it with mp3 files.

Today I started the car and decided to take a look at files on the USB again... the 320kps files played! I have no idea why it didn't play before and now it does? Maybe the i-drive needed to cache the USB drive directories or something so it couldn't index while playing? So strange.

But we are totally off topic now... the lightning adapter sounds terrible.
Z K is offline   United_States
0
Reply With Quote
      10-26-2012, 05:21 PM   #17
badazzm
Lieutenant
 
badazzm's Avatar
 
Drives: RRS GT2
Join Date: May 2012
Location: San Jose, CA

Posts: 543
iTrader: (1)

Hi guys. I m lost. So, is it worth getting the iPhone converter thing or no? I really liked charging and playing songs together.
badazzm is offline   India
0
Reply With Quote
      10-26-2012, 05:56 PM   #18
Z K
Colonel
 
Z K's Avatar
 
Drives: E90 M3
Join Date: Jul 2011
Location: San Francisco

Posts: 2,076
iTrader: (3)

Quote:
Originally Posted by badazzm View Post
Hi guys. I m lost. So, is it worth getting the iPhone converter thing or no? I really liked charging and playing songs together.
For me, when I used the adapter it made a big difference in sound quality and it sounded real bad. So I am not happy with the adapter. I went the USB route for music playback.
Z K is offline   United_States
0
Reply With Quote
      10-27-2012, 03:12 PM   #19
badazzm
Lieutenant
 
badazzm's Avatar
 
Drives: RRS GT2
Join Date: May 2012
Location: San Jose, CA

Posts: 543
iTrader: (1)

Quote:
Originally Posted by Z K View Post
For me, when I used the adapter it made a big difference in sound quality and it sounded real bad. So I am not happy with the adapter. I went the USB route for music playback.
Thanks man. USB for me too.
badazzm is offline   India
0
Reply With Quote
      10-27-2012, 04:26 PM   #20
rjd598
Brigadier General
 
rjd598's Avatar
 
Drives: 10' M3
Join Date: Jan 2009
Location: San Diego,CA

Posts: 4,555
iTrader: (2)

Garage List
2010 BMW M3  [4.50]
1999 BMW M3  [0.00]
I'm in for more feedback on people who have used the adapter($30). They still haven't come into the store steadily enough for me to grab one so I haven't gotten my chance but I check the store every weekend
__________________
rjd598 is offline   United_States
0
Reply With Quote
      11-01-2012, 09:13 PM   #21
mikefromMA
First Lieutenant
 
Drives: 2013 e92 M3
Join Date: Aug 2011
Location: MA

Posts: 302
iTrader: (6)

Garage List
2013 M3  [4.50]
2013 BMW x3  [0.00]
Purchased and returned adapter. Speaking to apple rep, functionality is lost regardless of identifying the change in quality. I had terrible distortion. Therefore, I returned and picked up another USB to lightning. It'll take time, but BMW will adopt this new technology flawlessly, as seen with media adapter
mikefromMA is offline   United_States
0
Reply With Quote
      11-02-2012, 12:54 PM   #22
///Mperative
Second Lieutenant
 
///Mperative's Avatar
 
Drives: like grandma
Join Date: Jul 2010
Location: New England

Posts: 280
iTrader: (0)

Garage List
2014 BMW 550xi  [0.00]
2011 E92 M3  [0.00]
Strange. I got the lightning adapter and plugged it into the BMW Y-cable (w/ 30-pin plug) and the sound quality is great; same quality as my previous iPhone. Not sure why the OP is having issues. I do have the premium sound system. Maybe that has something to do with it??? Or maybe it has something to do with the iDrive changes since MY2008. Mine is MY2011 (no combox).
__________________
///Mperative is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:52 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST