BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > UK
 
ESS Tuning
Post Reply
 
Thread Tools Search this Thread
      09-18-2012, 02:44 AM   #1
Sailorbaz
Enlisted Member
Sailorbaz's Avatar
Ireland
0
Rep
44
Posts

 
Drives: 2009 E90 M3 & 2004 M3 CSL
Join Date: Jan 2011
Location: Northern Ireland

iTrader: (0)

Heater / Heating interior

On top of the lack of heated seats, I'm now got the Mrs complaining that the heating in the new car is crap. No heat coming from the vents at all, even after a 30 minute run. Her Golf is in at the dealers getting some work done so she's using our E90 M3.

When I left to come back offshore, I don't think I'd used the heating to be honest if anything I was still using the AC since we rarely used the car in the evenings when it was cooler.

Question is, is there anything straight forward she can check herself? Obviously both dials are up to Max and left on 'Auto' with the wee wheel up by the Hazards rolled up to 'Red' and open but still she says it's luke warm.

I'm thinking it might be air-locked but why it might be air-locked, I don't know. Would it have had a coolant change in 3 years? Fuse maybe?

I'm kinda getting fed up with this car, every time I'm home it's in the dealer once, maybe twice for something. And I'm only home 4 weeks at a time.
__________________

2004 M3 CSL with Supersprint and E90 M3!
Worldwide M3 CSL Register based in the UK
Appreciate 0
      09-18-2012, 01:24 PM   #2
hugehead
Lieutenant
hugehead's Avatar
United Kingdom
4
Rep
468
Posts

 
Drives: E90 M3
Join Date: Feb 2010
Location: manchester

iTrader: (5)

Garage List
maybe the heating valve/flaps is not working, other than that....... cant figure why you would not feel the heat after 30 minute for use !!

also make sure the temperature dail is turn up atleast 20c+.
oh and heated seat are a "must" tick option

Last edited by hugehead; 09-19-2012 at 11:39 AM.
Appreciate 0
      10-01-2012, 09:38 AM   #3
Sailorbaz
Enlisted Member
Sailorbaz's Avatar
Ireland
0
Rep
44
Posts

 
Drives: 2009 E90 M3 & 2004 M3 CSL
Join Date: Jan 2011
Location: Northern Ireland

iTrader: (0)

An update I had last week was they'd found a kinked hose but how it happened, is anyone's guess.

The gearbox was replaced recently, could someone have kinked a hose when reinstalling that? Just an idea, I've no idea if it was working before the gearbox was replaced since I've only had the car since May and it's never been cold enough to notice/need the heating.
__________________

2004 M3 CSL with Supersprint and E90 M3!
Worldwide M3 CSL Register based in the UK
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:10 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST