BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      04-02-2016, 08:16 PM   #1
bkdore
Private First Class
bkdore's Avatar
United_States
16
Rep
126
Posts

Drives: 2011 E92 ZCP 6MT
Join Date: Oct 2014
Location: United States

iTrader: (0)

Carly dongle troubleshooting

I have a Carly wi-fi dongle I purchased from Amazon and I can't seem to get it to work. When I plug it into the car OBD2 connector I get a single red light. From my iphone/ipad I am able to see the carly wifi and get an IP on DHCP. When I start the app and try to connect I see a yellow light on the adapter blink on for half a second then back off and the app just sits there trying to connect. I get the iphone "waiting" animation until it times out. Should I be seeing any other lights on the adapter before or during the connection attempt? I've tried a variety of settings on the adapter as well as the troubleshooting steps that support sends no matter what questions I ask. Is the adapter generic enough that I can connect it to another (non-bmw) car and somehow verify the adapter is working or not? Is the adapter compatible with any other code reading apps? I'd hate to order another adapter and have the same issues.
Appreciate 0
      04-02-2016, 09:18 PM   #2
Down_Shift
Lieutenant
23
Rep
559
Posts

Drives: Slay
Join Date: Jan 2011
Location: Beantown

iTrader: (4)

Quote:
Originally Posted by bkdore
I have a Carly wi-fi dongle I purchased from Amazon and I can't seem to get it to work. When I plug it into the car OBD2 connector I get a single red light. From my iphone/ipad I am able to see the carly wifi and get an IP on DHCP. When I start the app and try to connect I see a yellow light on the adapter blink on for half a second then back off and the app just sits there trying to connect. I get the iphone "waiting" animation until it times out. Should I be seeing any other lights on the adapter before or during the connection attempt? I've tried a variety of settings on the adapter as well as the troubleshooting steps that support sends no matter what questions I ask. Is the adapter generic enough that I can connect it to another (non-bmw) car and somehow verify the adapter is working or not? Is the adapter compatible with any other code reading apps? I'd hate to order another adapter and have the same issues.
Get Amazon to replace it before you're out of the return window.

My first one did this and I got a replacement and everything's been great.

Their tech support is great too if you want to contact them direct.
Appreciate 1
      04-03-2016, 03:31 AM   #3
vsix
Major
vsix's Avatar
No_Country
332
Rep
1,464
Posts

Drives: M3 E92
Join Date: Nov 2012
Location: ATL

iTrader: (0)

1.) Turn off your wifi ( make sure no bluetooth either )
2.) plug the adapter into your OBD2 port
3.) turn back on your WIFI
4.) open your app
5.) start the car
6.) connect ( button ) your car with app

Note:
When you uploaded the Carly app and afterwards did an IOS software update, you need to erase the carly app and freshly upload it.
Then check if you have the newest carly update and you're good to go.
Appreciate 1
      04-03-2016, 07:32 AM   #4
bkdore
Private First Class
bkdore's Avatar
United_States
16
Rep
126
Posts

Drives: 2011 E92 ZCP 6MT
Join Date: Oct 2014
Location: United States

iTrader: (0)

Thanks for the replies. I have tried multiple phones and ipads. I've followed the instructions exactly, and tried every variation. I've emailed support several times, sent logs from the app, and no matter what I ask I get sent a link to their troubleshooting page which says the pretty much the same things that VISX says above - things I have already tried. Is there a way to tell if I have a bad adapter? Should I see more lights on the adapter than just the single red light when it is plugged into the car? Can I try the adapter on another car or with another App? Should I just order another adapter and hope for better results?
Appreciate 0
      04-03-2016, 11:04 AM   #5
vsix
Major
vsix's Avatar
No_Country
332
Rep
1,464
Posts

Drives: M3 E92
Join Date: Nov 2012
Location: ATL

iTrader: (0)

Quote:
Originally Posted by bkdore View Post
Thanks for the replies. I have tried multiple phones and ipads. I've followed the instructions exactly, and tried every variation. I've emailed support several times, sent logs from the app, and no matter what I ask I get sent a link to their troubleshooting page which says the pretty much the same things that VISX says above - things I have already tried. Is there a way to tell if I have a bad adapter? Should I see more lights on the adapter than just the single red light when it is plugged into the car? Can I try the adapter on another car or with another App? Should I just order another adapter and hope for better results?
Hmmm....
in what condition is your battery?
Give it a try:
Charge your battery over night
and do the mentioned 1-6 steps I mentioned in my previous post.
If even this attempt fails, just replace your Carly adapter.
You anyhow benefit from the life time guarantee on all electrical conponents of your Carly OBD2 WIFI adapter.
Appreciate 1
      04-03-2016, 12:39 PM   #6
bkdore
Private First Class
bkdore's Avatar
United_States
16
Rep
126
Posts

Drives: 2011 E92 ZCP 6MT
Join Date: Oct 2014
Location: United States

iTrader: (0)

Quote:
Originally Posted by vsix View Post
Hmmm....
in what condition is your battery?
It's a 2011 with the larger size OEM battery. It's a daily driver and I haven't had any issues with it. I have no problems starting the car and all my electrical accessories work as expected. It's simple for me to hook up a charger and try again, but I'd be very surprised if it makes a difference. I do expect my battery will need to be changed in the next year or so - and that's one of the main reasons I bought the adapter and the app.

I'm fine with buying another $75 adapter - in fact I've already ordered one. However I'd really like it if support or someone could TRY to answer my questions about what the lights on the adapter mean and what they look like in normal operation, if I can plug the thing into my wifes Honda, use it with any other apps, connect to it to my PC and telnet into it, etc. I'm legitimately trying to troubleshoot the thing, asking very specific questions and getting nothing more than "did you turn it off and back on again" types of responses. Sorry if this reads like a rant, but it is getting a little frustrating. If the lights mean nothing and the adapter won't work with any other car or app then fine - just tell me. If nobody knows, I'm good with that answer. If I'm asking in the wrong place - please point me in the right direction. Thanks again for your help. Hopefully I'll have another adapter to try by the weekend.
Appreciate 1
      04-03-2016, 01:39 PM   #7
vsix
Major
vsix's Avatar
No_Country
332
Rep
1,464
Posts

Drives: M3 E92
Join Date: Nov 2012
Location: ATL

iTrader: (0)

Quote:
Originally Posted by bkdore View Post
It's a 2011 with the larger size OEM battery. It's a daily driver and I haven't had any issues with it. I have no problems starting the car and all my electrical accessories work as expected. It's simple for me to hook up a charger and try again, but I'd be very surprised if it makes a difference. I do expect my battery will need to be changed in the next year or so - and that's one of the main reasons I bought the adapter and the app.

I'm fine with buying another $75 adapter - in fact I've already ordered one. However I'd really like it if support or someone could TRY to answer my questions about what the lights on the adapter mean and what they look like in normal operation, if I can plug the thing into my wifes Honda, use it with any other apps, connect to it to my PC and telnet into it, etc. I'm legitimately trying to troubleshoot the thing, asking very specific questions and getting nothing more than "did you turn it off and back on again" types of responses. Sorry if this reads like a rant, but it is getting a little frustrating. If the lights mean nothing and the adapter won't work with any other car or app then fine - just tell me. If nobody knows, I'm good with that answer. If I'm asking in the wrong place - please point me in the right direction. Thanks again for your help. Hopefully I'll have another adapter to try by the weekend.
More than understandable but unfortunately, thats what people usually get do and it usually also works. Really strange, that it didnt worked on your side.
Can you please make an screenshot, of the from you mentioned empty screen you have? ( no dme's found )

As for carly headquarters response:
Keep in mind, they are located in munich germany, so there is an different time zone. They will definately get back at you.
Never heard that any email wasn't answered. Patience is on this particular subject also the key.
Please do yourself a favour, stay calm and keep cool, nothing in the world is worth getting heated up specially when we talk about an electrical component that was built for our personal enthusiasts pleasure.
It will work, maybe its just a little problem, we'll see.
Keep us posted

Last edited by vsix; 04-03-2016 at 01:58 PM.
Appreciate 0
      04-03-2016, 03:44 PM   #8
bkdore
Private First Class
bkdore's Avatar
United_States
16
Rep
126
Posts

Drives: 2011 E92 ZCP 6MT
Join Date: Oct 2014
Location: United States

iTrader: (0)

I've always received a prompt reply from support when I contacted them, but the response was just a generic troubleshooting steps and links to their troubleshooting page. It's possible something was lost in translation.

It's possible I just got a bad adapter. Amazon might have sent me the one Down Shift returned. The reason most people want Carly is to troubleshoot their own problems, avoid unneeded expense and not have to bring the car in to to the dealer. That is exactly what I'm now trying to do with my Carly adapter.



The app sits at this screen for several minutes when I try to connect to the car:



And then eventually times out to this page:

Appreciate 1
      04-07-2016, 07:51 PM   #9
bkdore
Private First Class
bkdore's Avatar
United_States
16
Rep
126
Posts

Drives: 2011 E92 ZCP 6MT
Join Date: Oct 2014
Location: United States

iTrader: (0)

I received a new adapter today and it worked perfectly. Apparently my original adapter has issues.
Appreciate 0
      04-09-2016, 12:26 PM   #10
vsix
Major
vsix's Avatar
No_Country
332
Rep
1,464
Posts

Drives: M3 E92
Join Date: Nov 2012
Location: ATL

iTrader: (0)

Quote:
Originally Posted by bkdore View Post
I received a new adapter today and it worked perfectly. Apparently my original adapter has issues.
Cool! Now happy coding, CEL reading/erasing etc!!!
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:25 PM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST