BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Heel & Toe Apparel
Post Reply
 
Thread Tools Search this Thread
      05-17-2016, 12:56 AM   #1
ShaunPatrick220
Enlisted Member
United_States
8
Rep
35
Posts

Drives: 2013 M3 Competition Coupe
Join Date: May 2014
Location: Orange County, CA

iTrader: (0)

Uneven Idle after fill up

Recently picked up a 2013 Space Grey E92, 48k miles. PPO came back clean, appears to be a very solid and well maintained car. After my first fill up at Costco, I noticed an uneven idle when stopped at a light-like the car was revving between 500 and 1000 RPM on its own. Took it to the dealer and idle control valve was replaced under warranty, but I'm still noticing the problem. It happens the first time I come to a stop after filling up. I've switched to Shell (unfortunately 91 octane here in CA), is this an actual problem or normal behavior for these cars? I've got about 800 miles left on the warranty so I'll be taking it back to the dealer.

Appreciate 0
      05-17-2016, 01:04 AM   #2
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
455
Rep
5,809
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
2008 BMW M3  [3.50]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Could be fuel tank vent valve..
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      05-17-2016, 02:54 AM   #3
Emm Tree
Second Lieutenant
43
Rep
270
Posts

Drives: M3 bro
Join Date: Jun 2015
Location: SoCal

iTrader: (2)

Quote:
Originally Posted by Mike Benvo
Could be fuel tank vent valve..
Had this problem until I replaced my fuel tank vent valve. Problem solved.
Appreciate 0
      05-17-2016, 10:53 AM   #4
jontothekim
First Lieutenant
United_States
11
Rep
344
Posts

Drives: 2012 E92 M3
Join Date: Jul 2013
Location: Los Angeles, CA

iTrader: (0)

I have this problem too after initial fill up.. it goes away after a while though.. mines a 2012
Appreciate 0
      05-17-2016, 12:34 PM   #5
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
455
Rep
5,809
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
2008 BMW M3  [3.50]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by Emm Tree
Quote:
Originally Posted by Mike Benvo
Could be fuel tank vent valve..
Had this problem until I replaced my fuel tank vent valve. Problem solved.
Yup, classic symptom of this valve being bad. Knock on wood mine is approaching 60k and no issues yet.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      05-17-2016, 01:33 PM   #6
ShaunPatrick220
Enlisted Member
United_States
8
Rep
35
Posts

Drives: 2013 M3 Competition Coupe
Join Date: May 2014
Location: Orange County, CA

iTrader: (0)

Thanks for the replies! I'll mention that to the dealer, glad I caught it before the warranty is up. So far seems to be the only problem with this car.
Appreciate 0
      05-19-2016, 07:33 AM   #7
TomHudson
Private First Class
13
Rep
112
Posts

Drives: 2011 E90 M3
Join Date: May 2015
Location: Toronto

iTrader: (0)

"Unfortunately only Shell 91"?
That is an excellent ethanol free fuel....

Good luck with idle issue! Does sound like the fuel vent valve....
Appreciate 1
      05-19-2016, 11:10 AM   #8
ResoKP
Private
Canada
22
Rep
67
Posts

Drives: E93 M3
Join Date: Aug 2015
Location: Toronto, ON

iTrader: (0)

Quote:
Originally Posted by TomHudson View Post
"Unfortunately only Shell 91"?
That is an excellent ethanol free fuel....

Good luck with idle issue! Does sound like the fuel vent valve....
I support ethanol free 91 as well. I only fill up with Shell
__________________
E93 M3 - 6MT - Alpine White/Extended Fox Red - Garage Queen
RSX Type-S - Premium White Pearl - Garage Queen
Public Transit - Daily Driver
Appreciate 0
      05-19-2016, 02:49 PM   #9
RoshDawg
Second Lieutenant
31
Rep
252
Posts

Drives: E92 M3
Join Date: Mar 2015
Location: Orange County

iTrader: (0)

This problem sometimes happens to me only when I use Shell gas. I am absolutely positive with that statement (at least for me). Ive never had this happen with Chevron. I even made a log and took videos with my observations with different top teir gas stations. I now only fill up at chevron or don't fill up all the way with shell. I'm sure it's just the fuel vent valve. I just haven't gotten around to DIY'ing yet
Appreciate 0
      05-19-2016, 04:00 PM   #10
ShaunPatrick220
Enlisted Member
United_States
8
Rep
35
Posts

Drives: 2013 M3 Competition Coupe
Join Date: May 2014
Location: Orange County, CA

iTrader: (0)

Quote:
Originally Posted by TomHudson View Post
"Unfortunately only Shell 91"?
That is an excellent ethanol free fuel....

Good luck with idle issue! Does sound like the fuel vent valve....
I've heard that the cars run better with 93 Octane but we can only get 91 here in Cali. It's at the dealer now since warranty repair, I hope to have an update soon!
Appreciate 0
      05-19-2016, 04:29 PM   #11
JsL
First Lieutenant
35
Rep
319
Posts

Drives: 2011 AW M3 ZCP
Join Date: Dec 2013
Location: SF Bay Area

iTrader: (2)

http://www.m3post.com/forums/showthr...t=Erratic+idle
Appreciate 0
      07-30-2016, 08:36 PM   #12
ShaunPatrick220
Enlisted Member
United_States
8
Rep
35
Posts

Drives: 2013 M3 Competition Coupe
Join Date: May 2014
Location: Orange County, CA

iTrader: (0)

Well 2 months later is better than never, sorry I've been MIA pouring money into a different car . Wanted to post the outcome, if you would like to know more details about the Puma case etc. feel free to dm me, I will summarize here:

Found fault in DME for idle control, test plan instructs replacement of idle actuator. Idle actuator was replaced last time so opened Puma case. Remove idle strips and check for seal, no fault found. Perform smoke injection test of intake system and check for air leaks, found small leak in intake boot. Replace boot and continue test, perform compression and leak down test on engine, no fault found. Open engine harness housing and check ground splice, ground location, and terminal can resistor, check wires directly between DME and idle actuator, no fault found. Replace idle actuator again per puma, re-assemble and test. Fault code returned on test drive, check charcoal canister for fuel contamination. Compare weight of installed canister with new canister and find variance. Replace charcoal canister, DMTL module, fuel tank breather valve, clear fault. Test and find no further issues.

So tl;dr, idle control actuator, charcoal canister, fuel tank breather valve, DMTL module. 2 months later and no further issues. Possible previous owner overfilled resulting in fuel in charcoal canister.

Now onto my newly discovered engine tick, just 400 miles out of warranty
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:54 PM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST