BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      06-27-2012, 03:30 AM   #1
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

Increased Emissions Service Engine Soon *code P2430*

Hi everyone,

Hope someone can help out. My car threw the lights at me and the dealer reset them and said they coud not get it to duplicate. It only happened once over 7 or so starts ...

2 Days later after about 20 starts or so it threw the lights again.

Just spoke to dealer and asked what code it threw the first time and told me P2430.

Can someone find what code that is? I searched for that specific code and series but could not find anything. I also searched the E90 forum ...

Thanks,

Denny
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      06-27-2012, 04:38 AM   #2
DJDeez
Got my license back!
Canada
7

 
DJDeez's Avatar
 
Drives: TransLink
Join Date: Jul 2011
Location: Surrey, BC


Posts: 200
iTrader: (1)

Quote:
Originally Posted by My Schnell View Post
Just spoke to dealer and asked what code it threw the first time and told me P2430.

Can someone find what code that is?
The code number P2430 is properly noted as; Secondary Air Injection System Air Flow/Pressure Sensor Circuit.

I would highly recommend you take this issue up with your Service Advisor and ask for them to rectify the problem opposed to simply clearing the fault codes.
__________________
aFe cold air intake system (stage 2) ▫ Agency Power cat delete/section 2 midpipes ▫ Agency Power exhaust system ▫ Beltronics STiR Plus ▫ BMW M style (ZHP) weighted short shift knob ▫ CIC iDrive ▫ Clutch pedal spring removal ▫ Coding ▫ Evolve-R tune ▫ Laser Interceptor ▫ LUX H8 V3 Angel Eyes ▫ pickyeater334 clutch stop ▫ Rear fog lights (2011 light control switch assembly) ▫ T3 Alpha laser gun protection ▫ Turner Motorsport power pulley kit

Last edited by DJDeez; 06-27-2012 at 05:42 AM. Reason: Incorrect information provided
Appreciate 0
      06-27-2012, 05:03 AM   #3
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

Quote:
Originally Posted by DJDeez View Post
The code number P2430 is properly noted as; Secondary air system mass air flow sensor rationality.

This fault is indicating that the Mass Air Flow Sensor (MAF) for the air intake of the secondary air injection system is giving a faulty signal. The MAF measures the amount of air flowing into the secondary air pump when it is running. Make sure that the harness plug is properly connected. If it is, the sensor may indeed be faulty.
Thanks!!

Where is the plug? On the sensor?

Great info!!
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      06-27-2012, 05:43 AM   #4
DJDeez
Got my license back!
Canada
7

 
DJDeez's Avatar
 
Drives: TransLink
Join Date: Jul 2011
Location: Surrey, BC


Posts: 200
iTrader: (1)

Quote:
Originally Posted by My Schnell View Post
Thanks!!

Where is the plug? On the sensor?

Great info!!
My apologies in not proof-reading, I simply copied/pasted my original post and did not pay enough attention! Our vehicles do not have a Mass Air Flow Sensor (MAF) but rather a Manifold Absolute Pressure Sensor (MAP). I have updated my initial post, again I am sorry for any confusion caused on my behalf.
__________________
aFe cold air intake system (stage 2) ▫ Agency Power cat delete/section 2 midpipes ▫ Agency Power exhaust system ▫ Beltronics STiR Plus ▫ BMW M style (ZHP) weighted short shift knob ▫ CIC iDrive ▫ Clutch pedal spring removal ▫ Coding ▫ Evolve-R tune ▫ Laser Interceptor ▫ LUX H8 V3 Angel Eyes ▫ pickyeater334 clutch stop ▫ Rear fog lights (2011 light control switch assembly) ▫ T3 Alpha laser gun protection ▫ Turner Motorsport power pulley kit
Appreciate 0
      06-27-2012, 06:49 AM   #5
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

Quote:
Originally Posted by DJDeez View Post
My apologies in not proof-reading, I simply copied/pasted my original post and did not pay enough attention! Our vehicles do not have a Mass Air Flow Sensor (MAF) but rather a Manifold Absolute Pressure Sensor (MAP). I have updated my initial post, again I am sorry for any confusion caused on my behalf.
The dealer is the first one (only one) who cleared it. I was just trying to gather more info so I know what to expect. Thanks again ...

Still couple questions though ... Possibly the pressure sensor? or SAS pump? or is it looking like a MAP?

Denny
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!

Last edited by My Schnell; 06-27-2012 at 06:52 AM. Reason: grammer
Appreciate 0
      07-04-2012, 02:26 PM   #6
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

The dealer found the problem. The sensor on the hose, item 3, was the fualt.

03 SUCTION HOSE 1 11727838504 $124.92

__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      10-19-2012, 10:33 AM   #7
MaxL
Captain
Canada
54

 
Drives: E90 M3, Cayenne T, 991 GT3
Join Date: Jun 2007
Location: Bay Area


Posts: 951
iTrader: (0)

I had the same issue last May (dealer replaced the hose and sensor), and now, not even 5 months later I have "Increased emissions" message again, and the secondary air pump does not come on. What can be causing this?
Appreciate 0
      10-20-2012, 11:18 PM   #8
PurM3
Private First Class
8

 
Drives: M3 vert
Join Date: Apr 2012
Location: Los Angeles


Posts: 104
iTrader: (0)

I had this problem a few weeks ago. Dealer changed the fuel pressure sensor and it was fine after
Appreciate 0
      10-20-2012, 11:48 PM   #9
Gearhead999s
Major General
221

 
Gearhead999s's Avatar
 
Drives: F25 2.8d(wifes)F82 M4
Join Date: Apr 2007
Location: Toronto


Posts: 6,803
iTrader: (0)

I had this warning last week and the car is going in on Monday AM.
Appreciate 0
      10-21-2012, 08:41 AM   #10
gatorfast
Colonel
61

 
gatorfast's Avatar
 
Drives: MR E90 M3
Join Date: Jan 2008
Location: SoFla


Posts: 2,628
iTrader: (3)

Quote:
Originally Posted by PurM3 View Post
I had this problem a few weeks ago. Dealer changed the fuel pressure sensor and it was fine after
Same thing for me a few months ago. Should be an easy fix.
Appreciate 0
      10-22-2012, 03:06 PM   #11
Gearhead999s
Major General
221

 
Gearhead999s's Avatar
 
Drives: F25 2.8d(wifes)F82 M4
Join Date: Apr 2007
Location: Toronto


Posts: 6,803
iTrader: (0)

The dealer said it is the suction hose that is causing the check engine light on my car.Part should be in tomorrow.
Appreciate 0
      10-30-2012, 02:37 PM   #12
E90M3velocity
Second Lieutenant
Philippines
4

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 229
iTrader: (2)

hi all, did any of you had to replace the throttle actuator? my dealer said they have replace that since the pressure sensor has been replaced and the code is still on.
__________________

Last edited by E90M3velocity; 10-31-2012 at 04:08 PM.
Appreciate 0
      10-31-2012, 04:10 PM   #13
E90M3velocity
Second Lieutenant
Philippines
4

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA


Posts: 229
iTrader: (2)

Pulled codes 2738 and 2737 which shows the pressure sensor solenoid "F" control circuit not working properly, which i dont know why my dealer intends to replace both the throttle actuators (a grand per piece) to fix it.
Appreciate 0
      06-04-2013, 12:12 PM   #14
2000gsr
First Lieutenant
Canada
9

 
2000gsr's Avatar
 
Drives: 2008 E92 M3
Join Date: Aug 2008
Location: Toronto, ON


Posts: 365
iTrader: (0)

I just got these codes as well (P2432 & P2430). Had them cleared and the came back the next day. Can these codes be triggered by a dirty air filter? Is this suction hose that seems to be the problem in the front of the engine or near the firewall? Could it be a bad MAP sensor? Does anybody know where the MAP sensor is located?
__________________
http://www.m3post.com/forums/image.php?type=sigpic&userid=44350&dateline=125013  4806
Appreciate 0
      06-04-2013, 04:17 PM   #15
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

In my case, the suction hose was cracked. So the sensor was getting the wrong pressures. It's one unit too ...
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      06-05-2013, 09:10 AM   #16
2000gsr
First Lieutenant
Canada
9

 
2000gsr's Avatar
 
Drives: 2008 E92 M3
Join Date: Aug 2008
Location: Toronto, ON


Posts: 365
iTrader: (0)

So the actual sensor on your hose was fine? Do you know where the crack was? I'm going to pull mine out tonight and see.
__________________
http://www.m3post.com/forums/image.php?type=sigpic&userid=44350&dateline=125013  4806
Appreciate 0
      06-05-2013, 05:16 PM   #17
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

Right at the connection point to the sensor, forward side, I believe ...
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      06-05-2013, 09:50 PM   #18
2000gsr
First Lieutenant
Canada
9

 
2000gsr's Avatar
 
Drives: 2008 E92 M3
Join Date: Aug 2008
Location: Toronto, ON


Posts: 365
iTrader: (0)

I checked my suction hose tonight, didn't see any cracks. Maybe my sensor is bad. Anything else that could throw these codes?
__________________
http://www.m3post.com/forums/image.php?type=sigpic&userid=44350&dateline=125013  4806
Appreciate 0
      07-10-2013, 07:14 PM   #19
SROC5
Addicted to Track
United_States
55

 
SROC5's Avatar
 
Drives: E92 M3
Join Date: Apr 2009
Location: USCON


Posts: 1,605
iTrader: (3)

Quote:
Originally Posted by My Schnell View Post
Right at the connection point to the sensor, forward side, I believe ...
How many miles does your car have? Curious if it's a wear and tear item.
__________________

| Akrapovic Evo | ESSi | Swift Spec-R | CF Spoiler | APEX ARC-8 | RS-3 | PFC-08 | DIF |
Appreciate 0
      07-11-2013, 02:37 PM   #20
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

Quote:
Originally Posted by SROC5 View Post
How many miles does your car have? Curious if it's a wear and tear item.
Mine happened around 42K the first time ... About 4K later it came back but they did not tell me if it was the same issue.
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
      11-13-2013, 02:39 PM   #21
bwoon
Private
10

 
Drives: 08 e92 M3
Join Date: Feb 2012
Location: SoCal


Posts: 89
iTrader: (0)

Garage List
2008 BMW e92 M3  [0.00]
I'm getting this error too p2430 p2432. I notice that on the realOEM picture posted above, item #3 suction hose, there isn't a sensor connected to the hose. Or is #11 the sensor? I looked up that part number and it seems like it's just an electrical plug? I'm going to try and fix this on my own since I hate having my wallet destroyed by the dealer. Does anybody know where exactly the sensor is?
Appreciate 0
      11-13-2013, 03:34 PM   #22
My Schnell
Private First Class
United_States
3

 
My Schnell's Avatar
 
Drives: E90 ///M3 SG Fox Red 6MT
Join Date: Sep 2008
Location: New Mexico


Posts: 114
iTrader: (1)

The dealer showed me the hose, sensor and crack. It is one unit, hose and sensor ... #3
__________________
2009 E90 ///M3 SG Fox Red 6MT, AA X-pipe w/HFCs w/Eisenmann Sport, Dinan intake, AA Pulley, ZCP strut retro w/Dinan Stage III susp, BPM Stage II tune, Rear Fog LCI switch, BMW Edition Front & Side Grill/Gill, Smoked Reflectors, Black 19" ZCPs and AiB v4-Now, Not Wife approved!!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:10 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST