BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > DIY Guides/ Discussions
 
Strasse Wheels
Post Reply
 
Thread Tools Search this Thread
      09-08-2012, 03:17 PM   #1
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Using Bavarian Technic to reset condition based service

Hi, i have a Bavarian Technic cable Enthusiast version. I've used it before to reset errors no problem. I am running aftermarket brake pads and change them myself, now my iDrive shows that my front pads are gone when they are almost new. I want to use my BT to reset indicator to 100%, i go in the module but I get error that control unit did not accept the command. Does anyone know how to make it work and what the deal is?

E92 2011

Thanks
Appreciate 0
      09-08-2012, 03:35 PM   #2
TheBingoBalls
Lieutenant Colonel
Canada
19
Rep
1,821
Posts

 
Drives: E90 325i, R56 MINI Cooper
Join Date: Mar 2011
Location: Toronto, Ontario

iTrader: (1)

Did your sensors triggered? Did you try to reset through the instrument cluster?
Appreciate 0
      09-08-2012, 11:44 PM   #3
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by 宝马.e90 View Post
Did your sensors triggered? Did you try to reset through the instrument cluster?
might have been sensors. How do you reset thru the instrument cluster?
Appreciate 0
      09-09-2012, 08:30 PM   #4
warp10
Captain
warp10's Avatar
9
Rep
699
Posts

 
Drives: 2011 M3 Jet Black:ZCP, ZCV, ZP
Join Date: May 2011
Location: Atlanta, Ga

iTrader: (2)

Garage List
2011 M3  [5.00]
2011 28i X3  [0.00]
Appreciate 0
      09-09-2012, 08:33 PM   #5
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Sounds like you may need to replace the brake pad sensors..its always a good idea to replace them when you replace pads..they arent too expensive
Appreciate 0
      09-10-2012, 12:07 AM   #6
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Thanks guys. I'll try that!
Appreciate 0
      09-12-2012, 10:54 PM   #7
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by warp10 View Post

I tried this today, I can get to the menu, but then I can press and hold BC button forever and Reset doesn't come up..? Any suggestions here?
Appreciate 0
      09-12-2012, 11:30 PM   #8
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Did you change the sensors? Dont you have a BT Tool?
Appreciate 0
      09-13-2012, 09:37 PM   #9
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by tibra1 View Post
Did you change the sensors? Dont you have a BT Tool?
No, i didnt. I was hoping to get away without changing them, but it seems i'll have to buy them. I have BT, but i get the error...
Appreciate 0
      09-14-2012, 10:30 PM   #10
thorny
Captain
thorny's Avatar
United_States
16
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

It finally worked! With engine running, Press and hold button on the dash. You'll see exclamation mark, without releasing the button press on BC button. You'll see front brake indicator first (you can toggle between indicators with the flip switch next to BC button.) Then I think I let go both buttons and pressed and held BC button again until it asked me to Reset. Not sure why I couldn't figure this out earlier
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:24 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST