BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      04-27-2012, 05:59 PM   #1
yuwa
Private First Class
United_States
2
Rep
157
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2011
Location: Pasadena CA

iTrader: (1)

Send a message via MSN to yuwa
i got so many trouble code, CEL especially engine malfunction

im worried about my car is gonna die



Appreciate 0
      04-27-2012, 06:25 PM   #2
m3an
Banned
m3an's Avatar
19
Rep
1,611
Posts

 
Drives: M3
Join Date: Oct 2010
Location: South Florida

iTrader: (2)

I would start with 02 sensors
Appreciate 0
      04-27-2012, 06:37 PM   #3
Cal@Sonic MS
Cal@Sonic MS's Avatar
United_States
193
Rep
4,653
Posts

 
Drives: bmw
Join Date: Jan 2011
Location: earth

iTrader: (2)

Don't worry Yu! We'll get this sorted out ASAP...just keep the car in sleep mode in it's garage for now...until Monday.
Appreciate 0
      05-01-2012, 05:54 AM   #4
yuwa
Private First Class
United_States
2
Rep
157
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2011
Location: Pasadena CA

iTrader: (1)

Send a message via MSN to yuwa
Sal help me to clear the trouble code, and upgrade my car to the latest bmw ecu program. after that, i start up my car for 5min, the engine malfunction come up again, then i let a truck tow my car to the local dealer since Sal is thinking there must be some problem in the car but not ecu. do you have any experience with this? i want to know which part i might to pay for to fix my car since i already change the exhaust, the dealer can say the aftermarket exhaust cause this problem.
Quote:
Originally Posted by Cal@Sonic MS View Post
Don't worry Yu! We'll get this sorted out ASAP...just keep the car in sleep mode in it's garage for now...until Monday.
Appreciate 0
      05-01-2012, 06:04 AM   #5
yuwa
Private First Class
United_States
2
Rep
157
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2011
Location: Pasadena CA

iTrader: (1)

Send a message via MSN to yuwa
and these are the new trouble i got after the car got reflash to stock ecu.

////////////////////////////////////////////////////////////////////
// BMW Trouble Code list
//
// ECU Type : Siemens DME MSS60
// Vehicle Manufacturer Ecu Hardware Number : 7846903
// Vehicle Manufacturer Ecu Software Number : 7846397
// Hardware Reference Number : 0569QT0Z231EEKUV1
// Vehicle Identification Number :
// Ecu Manufacturing Date : 17.06.2011
//
// 1) 27B1 Secondary air system throughput bank 2
// 2) 2B39 Combustion misfire with cut-out cyl 5
// 3) 2B3A Combustion misfire with cut-out cyl 6
// 4) 2B3B Combustion misfire with cut-out cyl 7
// 5) 2B3C Combustion misfire with cut-out cyl 8
// 6) 2B41 Combustion misfire with cut-out several cyl
// 7) 2B57 Motor emergency programm activated
// 8) 2796 Motor emergency programm activated
////////////////////////////////////////////////////////////////////

Quote:
Originally Posted by Cal@Sonic MS View Post
Don't worry Yu! We'll get this sorted out ASAP...just keep the car in sleep mode in it's garage for now...until Monday.

Last edited by yuwa; 05-03-2012 at 01:22 AM.
Appreciate 0
      05-01-2012, 07:32 AM   #6
IMG
M.POWER
IMG's Avatar
104
Rep
7,065
Posts

 
Drives: E36 M3 Track car,Ess E90 M3 DD
Join Date: Feb 2008
Location: Location

iTrader: (6)

Quote:
Originally Posted by yuwa
and these are the new trouble i got after the car got reflash to stock ecu.

////////////////////////////////////////////////////////////////////
// BMW Trouble Code list
//
// ECU Type : Siemens DME MSS60
// Vehicle Manufacturer Ecu Hardware Number : 7846903
// Vehicle Manufacturer Ecu Software Number : 7846397
// Hardware Reference Number : 0569QT0Z231EEKUV1
// Vehicle Identification Number :
// Ecu Manufacturing Date : 17.06.2011
//
// 1) 27B1 Secondary air system throughput bank 2
// 2) 2B39 Combustion misfire with cut-out cyl 5
// 3) 2B3A Combustion misfire with cut-out cyl 6
// 4) 2B3B Combustion misfire with cut-out cyl 7
// 5) 2B3C Combustion misfire with cut-out cyl 8
// 6) 2B41 Combustion misfire with cut-out several cyl
// 7) 2B57 Motor emergency programm activated
// 8) 2796 Motor emergency programm activated
////////////////////////////////////////////////////////////////////

Quote:
Originally Posted by Cal@Sonic MS View Post
Don't worry Yu! We'll get this sorted out ASAP...just keep the car in sleep mode in it's garage for now...until Monday.
Don't post your VIN# on a public forum !
The dealer won't void your warranty for an axle back.
__________________
NO FEAR.NO LIMITS.NO EQUAL

Ess VT3 LC built motor,Volk TE37SL,Euro taillights,Dinan Xpipe,Custom Headers,Akra axle back CF tips,ModeCarbon FR lip,BMW CF wing
LOW BOOST 60-130 6.7 sec

Last edited by IMG; 05-02-2012 at 07:24 AM.
Appreciate 0
      05-01-2012, 09:37 AM   #7
Sean05
Putcha ang ganda...
Sean05's Avatar
Philippines
89
Rep
5,331
Posts

 
Drives: 08 MR E92 M3
Join Date: Feb 2010
Location: Los Angeles, Brea CA.

iTrader: (9)

Send a message via Yahoo to Sean05
Quote:
Originally Posted by img View Post
Don't post your VIN# on a public forum !
.
why not... what can you do to it....
Appreciate 0
      05-01-2012, 09:51 AM   #8
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by img View Post
The dealer won't void your warranty for an axle back.
He has an Evo iirc.

I still think this guy should stay away from mods though.
__________________
Appreciate 0
      05-01-2012, 01:04 PM   #9
Cal@Sonic MS
Cal@Sonic MS's Avatar
United_States
193
Rep
4,653
Posts

 
Drives: bmw
Join Date: Jan 2011
Location: earth

iTrader: (2)

Quote:
Originally Posted by yuwa View Post
Sal help me to clear the trouble code, and upgrade my car to the latest bmw ecu program. after that, i start up my car for 5min, the engine malfunction come up again, then i let a truck tow my car to the local dealer since Sal is thinking there must be some problem in the car but not ecu. do you have any experience with this? i want to know which part i might to pay for to fix my car since i already change the exhaust, the dealer can say the aftermarket exhaust cause this problem.
Sounds like something is wrong with the car. Akrapovic EVO or any exhaust system will not cause the kind of issues you are experiencing.
Appreciate 0
      05-01-2012, 01:08 PM   #10
Sean@PYSpeed.com
Sean@PYSpeed.com's Avatar
United_States
145
Rep
8,956
Posts

 
Drives: 2009 AW E92 M3
Join Date: Nov 2009
Location: Bay Area

iTrader: (22)

Send a message via AIM to Sean@PYSpeed.com
Quote:
Originally Posted by img View Post
Don't post your VIN# on a public forum !
The dealer won't void your warranty for an axle back.
And you didn't block him out when you quoted him...
Appreciate 0
      05-01-2012, 01:20 PM   #11
m33
Banned
m33's Avatar
United_States
50
Rep
2,697
Posts

 
Drives: E92 VT650 MCB Individual
Join Date: Dec 2008
Location: CT

iTrader: (5)

Basically either way you look at it it's pretty dumb to post your vin on a public forum as anyone can pull up your records that contain personal info like address, just not smart !
Ever notice how people block out their plates from pictures ...

But I would take your car to a dealer cause those codes don't look to healthy but at the same token it could be something as stupid as a simple sensor either way send it to the dealer ! Exhaust will not raise any red flags .

Good luck !
Appreciate 0
      05-01-2012, 01:22 PM   #12
m33
Banned
m33's Avatar
United_States
50
Rep
2,697
Posts

 
Drives: E92 VT650 MCB Individual
Join Date: Dec 2008
Location: CT

iTrader: (5)

Quote:
Originally Posted by Sean@PYSpeed.com View Post
And you didn't block him out when you quoted him...
He gave him a chance to delete and correct his mistake ! Look at it from a positive perspective not a negative one , I doubt he Meant any harm .
Appreciate 0
      05-01-2012, 04:36 PM   #13
yuwa
Private First Class
United_States
2
Rep
157
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2011
Location: Pasadena CA

iTrader: (1)

Send a message via MSN to yuwa
my dealer said they wont fix my car till i put oem exhaust back on, i think thats no point, cause after they fix the car with oem exhaust on, then i put akra evo back on again, im thinking the problem will be eventually come back again.

Quote:
Originally Posted by m33 View Post
Basically either way you look at it it's pretty dumb to post your vin on a public forum as anyone can pull up your records that contain personal info like address, just not smart !
Ever notice how people block out their plates from pictures ...

But I would take your car to a dealer cause those codes don't look to healthy but at the same token it could be something as stupid as a simple sensor either way send it to the dealer ! Exhaust will not raise any red flags .

Good luck !
Appreciate 0
      05-01-2012, 04:43 PM   #14
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by yuwa View Post
my dealer said they wont fix my car till i put oem exhaust back on, i think thats no point, cause after they fix the car with oem exhaust on, then i put akra evo back on again, im thinking the problem will be eventually come back again.
Your statement is not based on any facts. Unless you messed up the o2 sensors when you put on the exhaust, there's no way for a different exhaust to cause your problems. Go to another dealer.
__________________
Appreciate 0
      05-01-2012, 05:27 PM   #15
m33
Banned
m33's Avatar
United_States
50
Rep
2,697
Posts

 
Drives: E92 VT650 MCB Individual
Join Date: Dec 2008
Location: CT

iTrader: (5)

This makes no sense whatsoever ! Like the tech said either you messed up an 02 durring install ! Different exhausts don't mean diddly
Appreciate 0
      05-01-2012, 06:18 PM   #16
yuwa
Private First Class
United_States
2
Rep
157
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2011
Location: Pasadena CA

iTrader: (1)

Send a message via MSN to yuwa
my car was fine after akra and evolve tune installed for 600 miles, then got CEL pop up suddenly. the next day after i put on new summer tires, i got engine malfunction.

Quote:
Originally Posted by THE TECH View Post
Your statement is not based on any facts. Unless you messed up the o2 sensors when you put on the exhaust, there's no way for a different exhaust to cause your problems. Go to another dealer.
Appreciate 0
      05-01-2012, 06:55 PM   #17
kitw
Colonel
kitw's Avatar
61
Rep
2,628
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

honestly, put your car back to stock and let the dealership fix it. If you really want to mod if after that, post here about what the dealership fixed to get the codes to go away. Should not be exhaust related.
Appreciate 0
      05-13-2012, 12:13 PM   #18
Moxie
Lieutenant Colonel
Moxie's Avatar
Germany
25
Rep
1,860
Posts

 
Drives: AW 328d Touring/SG 335d
Join Date: Jul 2009
Location: Stuttgart

iTrader: (11)

Quote:
Originally Posted by Cal@Sonic MS View Post
Don't worry Yu! We'll get this sorted out ASAP...just keep the car in sleep mode in it's garage for now...until Monday.
Quote:
Originally Posted by yuwa View Post
my car was fine after akra and evolve tune installed for 600 miles, then got CEL pop up suddenly. the next day after i put on new summer tires, i got engine malfunction.
Any update to this?

Last edited by Moxie; 05-14-2012 at 06:52 AM.
Appreciate 0
      05-13-2012, 12:19 PM   #19
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Quote:
Originally Posted by Sean05 View Post
why not... what can you do to it....
+1 every car on Autotrader.com has the VIN # listed
Appreciate 0
      05-14-2012, 07:59 AM   #20
jamze132
Second Lieutenant
jamze132's Avatar
Germany
6
Rep
258
Posts

 
Drives: 2011 X6M
Join Date: Nov 2011
Location: Wiesbaden, Germany

iTrader: (0)

Won't loading an ECU tune kind of give BMWNA reason enough to void the warranty?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:09 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST